Search:

Type: Posts; User: Mljbone; Keyword(s):

Search: Search took 0.00 seconds.

  1. Replies
    15
    Views
    495

    I replace resistors, cleaned and tightened up...

    I replace resistors, cleaned and tightened up terminals on sockets. No redplating, amp sounds "great". Thanks all for the help!
  2. Replies
    15
    Views
    495

    Thanks for the information Enzo!

    Thanks for the information Enzo!
  3. Replies
    15
    Views
    495

    So I replaced the resistors on the 3rd power tube...

    So I replaced the resistors on the 3rd power tube socket. Plugged the head in to check output on pin number 5 on all sockets. Started with the first 3 with -53.6v the others at -49.1v. Waited a...
  4. Replies
    15
    Views
    495

    Thanks Randall!

    Thanks Randall!
  5. Replies
    15
    Views
    495

    Thanks nevetslab, they're wrap around.

    Thanks nevetslab, they're wrap around.
  6. Replies
    15
    Views
    495

    Thanks for the input! I picked up 470 ohm and...

    Thanks for the input! I picked up 470 ohm and 1500 resistors to replace on that power tube socket. But they are 2 watt , I'm not sure if that makes a difference I think they need to be 1 Watt. Also...
  7. Replies
    15
    Views
    495

    Thanks Randall, is it weird that the tube with...

    Thanks Randall, is it weird that the tube with the bad resistors isn't redplating? I've 2 new tubes!
  8. Replies
    15
    Views
    495

    Redplating Fender Super Twin Reverb.

    Hi,

    New here, but have had success in the past with other forums!! I have a '78 Fender Super Twin Reverb (blackface) that has a power tube redplating. I know it's a beast, and some say to put it...
Results 1 to 8 of 8