Results 1 to 4 of 4

Thread: K900FX Behringer minimal sound

  1. #1
    Senior Member
    Join Date
    Jun 2010
    Posts
    186
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0

    K900FX Behringer minimal sound

    Hey, have a cust's K900FX that has very very low sound cranked. He sent to another center and they said throw it away.

    Line out works, so the input stuff is alright. Orig it came in with cracked XLR connector, and busted jack on Ch2.
    Checked the output Ic and it was checking ok. Replaced it per another local tech.

    Found a manual K3000FX and though some things are similar, it's not that close. Maybe a 450 would be better, but they are not on the web.

    Next step was checking the op amps. Went through several and one TL074 was shorted. B+ on several pins. Explained the audio pop when shut down.

    Changed it out. That was Ic 11 on the board. Problem is even with a new one I am getting 14v dc on pin 1 which is an output. If I disconnect the pin, it's still there.
    Now it's a matter of hunting that down.

    Any ideas outside of this? A couple other 74's on there but I'm not seeing the leaked DC like the other.

    Thx in adv

    0 Not allowed! Not allowed!

  2. #2
    Old Timer J M Fahey's Avatar
    Join Date
    Oct 2007
    Location
    Buenos Aires, Argentina
    Posts
    10,046
    Thumbs Up/Down
    Received: 56/0
    Given: 59/2
    Busted XLR and jack *strongly* hint at amp falling nose down *hard* with some cables plugged in.

    Since those parts are usually mounted straight on PCB, they transmit impact and PCB cracks, breaking some tracks open.

    I bet strong bemch light and reading glasses or jeweler´s loupe will help you find one or more cracks, specially near said connectors but also near other controls.

    Board may "give" a little at the connector but crack a couple inches away, where board moves but, say, a pot or jack does not.

    Patience and eagle sight are your friends

    And a little bit luck

    A Schematic always helps but you don´t *really* need one.

    I bet bthe OpAmp with DC voltage on its output is not bad by itself (so replacing it cures nothing) but some tracks around it are cracked, for example an open input (not referenced to ground) can make an Op Amp drift/float to some random voltage.
    Or an open feedback path usually slams output against some rail.

    0 Not allowed! Not allowed!
    Juan Manuel Fahey

  3. #3
    Senior Member
    Join Date
    Jun 2010
    Posts
    186
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Quote Originally Posted by J M Fahey View Post
    Busted XLR and jack *strongly* hint at amp falling nose down *hard* with some cables plugged in.

    Since those parts are usually mounted straight on PCB, they transmit impact and PCB cracks, breaking some tracks open.

    I bet strong bemch light and reading glasses or jeweler´s loupe will help you find one or more cracks, specially near said connectors but also near other controls.

    Board may "give" a little at the connector but crack a couple inches away, where board moves but, say, a pot or jack does not.

    Patience and eagle sight are your friends

    And a little bit luck

    A Schematic always helps but you don´t *really* need one.

    I bet bthe OpAmp with DC voltage on its output is not bad by itself (so replacing it cures nothing) but some tracks around it are cracked, for example an open input (not referenced to ground) can make an Op Amp drift/float to some random voltage.
    Or an open feedback path usually slams output against some rail.
    I've looked at that. The owner said the two jacks were broken at different times. I inspected with a magnifier, and did not find any cracks. I have good audio from the input board to the main and fx board. Have audio out of the line out. After that, seems like if you had an old receiver in tape monitor mode and cranked the receiver audio... you get some sound, but not much. That's what happens. The manual for the 3000 is too different. None of the IC's in the audio path seem to match.

    I'll keep inspecting the boards though.

    0 Not allowed! Not allowed!

  4. #4
    Senior Member
    Join Date
    Jun 2010
    Posts
    186
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Twas a bad 4580L IC. 13v on pins 1,2,3,7,8..... kind of reached out and said.... that's not good me bad !!

    Fixed!!

    Funny thing so many around here at svc centers won't touch these. I guess they see no money in it. I spent a couple hrs on it. Quoted 100. Cust was ok with that. Not bad. I know these used are not going to get much, but new they are 249. New board would be more than unit was worth. $168 per Full Compass.

    This cust is a local musician friend of mine, so he'll be happy.

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Behringer Ultratone K900FX
    By dwatki in forum Schematic Requests
    Replies: 10
    Last Post: 07-22-2015, 09:16 AM
  2. Behringer K900FX
    By clemens72 in forum Schematic Requests
    Replies: 9
    Last Post: 07-17-2015, 05:56 AM
  3. Behringer K900FX - no sound output
    By MrBungle in forum Other Amps
    Replies: 3
    Last Post: 04-28-2011, 04:59 PM
  4. Behringer K900FX Parts.
    By Curtis2Smith in forum Music Electronics
    Replies: 2
    Last Post: 12-29-2010, 01:41 AM
  5. Behringer ULTRATONE K900FX PA/ Keyboard Amp
    By Wonker in forum Other Amps
    Replies: 4
    Last Post: 05-21-2009, 03:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •