Results 1 to 4 of 4

Thread: Peavey Ultra 60 clean channel only

  1. #1
    New Member
    Join Date
    Aug 2018
    Location
    Gambrills, MD
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0

    Peavey Ultra 60 clean channel only

    I picked up a Peavey Ultra 60 (410 combo) and initially it was changing between the clean and Ultra channel, but now it is not.
    The clean channel works but when I press the channel button I hear a relay click but I do not get any sound out of the Ultra channel. If I press the button again it goes back to the clean channel and sound comes out.
    I did some reading and I would guess it is a relay, but I am unsure which one or how to test it.
    Any help would be great.
    Thanks.

    0 Not allowed! Not allowed!

  2. #2
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    30,413
    Thumbs Up/Down
    Received: 434/1
    Given: 0/0
    A relay COULD be the problem, but then so could ANYTHING in the Ultra channel. A bad relay could keep a good Ultra channel from sounding, but just as likely a good relay would switch to an Ultra channel that was not working. Apply a steady signal to the input. I use a CD player to keep my hands free. Then trace the signal through the bad channel to see where it disappears.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  3. #3
    New Member
    Join Date
    Aug 2018
    Location
    Gambrills, MD
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Thanks for the advice. I pulled out the new tubes I just installed one by one and found a bad one. That was the issue.

    0 Not allowed! Not allowed!

  4. #4
    New Member
    Join Date
    Aug 2018
    Location
    Gambrills, MD
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Dup post

    0 Not allowed! Not allowed!
    Last edited by evilive69; 08-10-2018 at 04:01 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Peavey Ultra Plus - No Clean and switching issues
    By stereomonostereo in forum Maintenance, Troubleshooting & Repair
    Replies: 19
    Last Post: 03-18-2017, 06:16 PM
  2. Peavey VTM 60 Clean Channel?
    By gbono in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 08-31-2015, 02:34 PM
  3. Peavey ultra 60
    By STYLES2067 in forum Schematic Requests
    Replies: 1
    Last Post: 02-27-2009, 03:35 AM
  4. Peavey Ultra 60
    By chunkitup in forum Mods & Tweaks
    Replies: 4
    Last Post: 06-16-2008, 04:11 AM
  5. Peavey Ultra 60
    By chunkitup in forum Theory & Design
    Replies: 4
    Last Post: 03-22-2007, 12:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •