Page 7 of 7 FirstFirst 1234567
Results 211 to 228 of 228
Like Tree23Likes

Thread: Behringer DDX3216 - Trying to repair, please help!

  1. #211
    I'm a member? nickb's Avatar
    Join Date
    Dec 2009
    Location
    Devon, UK
    Posts
    2,071
    Thx for the link. That's commonly called an Octopus or sometimes 'component curve tracer' (very misleading name) - current on Y axis and Voltage on X. Dirty cheap component tester (a.k.a. ?Octopus? curve tracer) ? JAMMArcade.net It allows you see see the phase relationship between V & I easily.
    Experience is something you get, just after you really needed it.

  2. #212
    Member
    Join Date
    Jan 2017
    Posts
    21
    Hi,

    Short update.
    Measured everything again. inputs/outputs of the toshiba T6A39's en T6A40. Can't find anything wrong. Again, disassembled the display and put it together again. Soldered a new LM234. For now it is working again, but still very sensitive to temperature changes on the 4,7 uF caps.

    I ordered the LM324, didnt look any furhter on the details of this chip. But I checked the original one that I took of the first time. And it is a LM324M. Not sure if this would make a big difference, I checked some data sheets. And at least from the few doc's that I looked in, I can see that the LM324 actually can manage a bigger output current than the lm324M.So that would be a plus or the lm324. But I read from the LM324M specs that it has an internal temperature adjusting circuit, can't find that on the lm324 specs. Anyway I ordered the LM324M and will test it, also ordered new Panasonic 4,7 uF caps. Maybe the panasonic's are better then the "Würth Elektronik" ones I have now.
    Anyone can confirm differences in behaviour from the lm234 and lm324M?

    Maurice

  3. #213
    I'm a member? nickb's Avatar
    Join Date
    Dec 2009
    Location
    Devon, UK
    Posts
    2,071
    If possible, I would add a small resistor say 10 ohms between the LM324 and the driver chips. By looking at voltage drop over it using two scope probes in differential mode, you will be able to see if that is where the current is going. I would expect the LM324 to feel hot too if so much current is being drawn that it fails.

    The caps should not be that temperature sensitive - that is very odd. I'd be tempted to remove the caps that attach to that output. The output impedance of the LM324's is very small up to 100KHz+ therefore I think you could remove the two caps that attach to the troublesome output just to see what happens. I wonder if that section might be oscillating.

    I am not aware of any major differences between LM324 but I suppose one manufacturer will differ from the next.
    Experience is something you get, just after you really needed it.

  4. #214
    Member
    Join Date
    Jan 2017
    Posts
    21
    Hi Nick,

    Good advice regarding the 10 ohms resistor for measurements.
    Also I followed up on the cap removal. It was getting messy. But I did a few things...
    Firstly I got the LM324M and the panasonic 4,7uF caps in the mail. So I replaced it with the LM324...result garbled display. But....I have to admit that I caused that myself. When desoldering the old LM324, I used some flux. Apparently this flux went through the holes on the pcb (the through hole connection that connect to another trace on the other side of the board) So when opening the LCD assembly again I found flux between the elastomeric connector and the glass plate....pfffffff.
    Cleaned everything with alcohol again and put it together....garbled screen again...
    Ditched the 4,7 uF caps. same result. desoldered the lm324M and put back the older lm324...pronto...good screen.
    I suspect I killed the lm324m when the flux was on the connector....but i'm not sure. Like I said, it is getting messy. Also the traces on the pcb are starting to get bad because of all the heat from soldering.

    But at this moment it is working with a lm324 and no caps. I leave it like this for a while. Probably build the screen back into the mixer and leave it on for a day and see what happens.

    I don't know about you...but at this moment I need some kind of success in my repairs...sometimes repairs go well, and sometimes nothing works...I find myself in the bad stage at this moment haha.

    br
    Maurice

  5. #215
    Member
    Join Date
    Jan 2017
    Posts
    21
    Left it runnning for a few hours, and still going strong.
    clear display, no heat sensitive symptoms.
    I'm happy that it works now. But it is still bothering me that I don't know the real cause. The right thing to do would be soldering back the caps and start measuring like Nickb suggested. Start with checking what is going back into the negative inputs of the lm324. Maybe there the problem starts. Also the design of this voltage follower can be different I think. Why all the capacitors in series. Since the voltage coming out of the opamp output is regulated, the caps could be terminated to V- I think.
    From the other hand...it works. And I don't want to go over cleaning the LCD again and risk loosing traces on the pcb. I'll save it till the time it brakes down again...and if it is still interesting to fix a ddx3216

    Maurice
    Jazz P Bass likes this.

  6. #216
    Junior Member
    Join Date
    Apr 2017
    Posts
    7
    Quote Originally Posted by Nisse View Post
    Hi,
    So how do you replace your capacitors if you don't dismount your PSU?
    By the way, I think you have to clean your PSU-fan a bit!

    Well, does anybody know the difference between the V112.bex and V109.bex? For me it looks like V112.bex is a newer firmware, but on behringes homepage it says:
    V109.bex = Latest firmware
    V112.bex = Audio software (surround software)

    Do I need to install them both?
    How can I see the installed version(s)

    Ps.
    If anyone needs the DDXUpdate, I can share it for you.

    /Nisse
    I know it's 2017 and your post is since 2012 but if you have that DDX Update software I need that too. I have same message "No valid program...". I hope you still have it.
    Last edited by sazema; 04-08-2017 at 11:58 PM. Reason: quote added

  7. #217
    Han
    Han is offline
    Junior Member
    Join Date
    Apr 2012
    Posts
    16
    Quote Originally Posted by sazema View Post
    I know it's 2017 and your post is since 2012 but if you have that DDX Update software I need that too. I have same message "No valid program...". I hope you still have it.
    Hello, i attached the files
    Attached Files Attached Files
    nickb and g1 like this.

  8. #218
    Junior Member
    Join Date
    Apr 2017
    Posts
    7
    Quote Originally Posted by Han View Post
    Hello, i attached the files
    Thanks for upload. And those files are just bex files. I think there is no valid connection with PC now after latest firmware update is broken. How to upload those to DDX if you have no PCMCI card?
    I think that DDXUpdate v.1.11 application is standalone application, and when you run it, it recognizes connected DDX hardware etc.

  9. #219
    Han
    Han is offline
    Junior Member
    Join Date
    Apr 2012
    Posts
    16
    Quote Originally Posted by sazema View Post
    Thanks for upload. And those files are just bex files. I think there is no valid connection with PC now after latest firmware update is broken. How to upload those to DDX if you have no PCMCI card?
    I think that DDXUpdate v.1.11 application is standalone application, and when you run it, it recognizes connected DDX hardware etc.
    Hello,

    Do you have connection via midi (usb midi interface) or rs232 (usb rs232 interface)?
    Han

  10. #220
    Junior Member
    Join Date
    Apr 2017
    Posts
    7
    Quote Originally Posted by Han View Post
    Hello,

    Do you have connection via midi (usb midi interface) or rs232 (usb rs232 interface)?
    Han
    Yes, I have but RS232 seams to not work after this. That's the problem. Will try this tonight again.

  11. #221
    Han
    Han is offline
    Junior Member
    Join Date
    Apr 2012
    Posts
    16
    Quote Originally Posted by sazema View Post
    Yes, I have but RS232 seams to not work after this. That's the problem. Will try this tonight again.
    Hello,
    you also need the communication program which was written for xp so in a w10 pc you should run it as software compatible for xp, i attached the software also...
    Attached Files Attached Files
    nickb likes this.

  12. #222
    Junior Member
    Join Date
    Apr 2017
    Posts
    7
    Quote Originally Posted by Han View Post
    Hello,
    you also need the communication program which was written for xp so in a w10 pc you should run it as software compatible for xp, i attached the software also...
    I tried last night, XP mode, but it says "Unable to establish connection, Connection error".
    Also tried with Windows 2000 old pc, same thing.

    Now, I'm doubt in rs232 cable, today I will try to find a new one, or USB -> RS232 cable.

    But, also I doubt, because software is broken in mixer that causing the problem with connection ?!?

    Mixer still showing "NO VALID PROGRAM, restart update!" and nothing.

    Here is excerpt from this site: http://fors.doctorproaudio.com/messages/32286.html

    Take a look at the behringer website and find the solution, according to them doing the following solves the problem:

    This is due to an interruption during the firmware update attempt. In this case, the EPROM flash memory is erased and the mixer does not turn on. We have emergency software (version 1.11) to assist you in these cases. Proceed as follows:
    - Install the program on your computer
    - Connect the DDX to the RS232 port
    - Start the software.
    - Choose the communications port (com) the DDX is connected to
    - Press the "GROUP" button and turn on the mixer
    - The update will start and will last approximately 10 minutes. Progress will be indicated.


    Or this page: http://www.plzi.com/aanta/ddx3216.asp

    When you get the fault description of an DDX3216 Program is not loaded, this is caused by an interruption during a firmware update attempt. In this case the flash eprom is erased and the mixer does not start up. There is an emergency tool (DDXupdate V1.11) available (Ask your BEHRINGER support dept.) To start up a DDX3216 when the firmware upgrade has failed. Proceed as follows:

    Install the programm to your computer
    Connect the DDX to the RS232 port
    Start the software
    Choose the com port the DDX is connected to
    Press down the GROUP button and switch on the mixer
    Update will start and last about 10 minutes. Progress is displayed.


    I contacted Behringer support also, but they provide to me files same as provided here, transfer app + firmware versions.

    PS: These days DDXUpdate v.1.11 is pure gold
    Last edited by sazema; 04-12-2017 at 09:42 AM.

  13. #223
    Member
    Join Date
    Jan 2017
    Posts
    21
    I missed a few posts I see

    I know I was fighting this as well. But I managed to do it from a windows 7 machine via rs232. (Actually a laptop in a docking bay. Most docking stations still have a rs232 port on it). The errors from the program sound familiar, but not always true.
    When I get home I will check what rs232 cable I was using and maybe shoot a short vid.
    New broken 3216 on my bench here. Missing 17 volt lines, fixed the 17 volts, but now missing the 5 volts on that same part of the psu. Maybe open a new thread for it.

    br
    Maurice

  14. #224
    Junior Member
    Join Date
    Apr 2017
    Posts
    7
    Quote Originally Posted by dutch_anykey View Post
    I missed a few posts I see

    I know I was fighting this as well. But I managed to do it from a windows 7 machine via rs232. (Actually a laptop in a docking bay. Most docking stations still have a rs232 port on it). The errors from the program sound familiar, but not always true.
    When I get home I will check what rs232 cable I was using and maybe shoot a short vid.
    New broken 3216 on my bench here. Missing 17 volt lines, fixed the 17 volts, but now missing the 5 volts on that same part of the psu. Maybe open a new thread for it.

    br
    Maurice

    No, it's impossible to do anything in current state with just a cable and transfer software, because indeed there is no valid software on CHIP.
    CHIP must be programmed with programmer or with that dedicated software - but no longer exists. Maybe, some of you has in archive somewhere, and that's all.

  15. #225
    Member
    Join Date
    Jan 2017
    Posts
    21
    oow o.k. your eeprom is corrupted?
    I found these files as well somewhere on the forum here. Can't remember where exactly. Let me know if you can't find them. I will search on my p.c. this evening.
    I haven't done it myself, but you have a programmer?

    br
    Maurice

  16. #226
    Junior Member
    Join Date
    Apr 2017
    Posts
    7
    Quote Originally Posted by dutch_anykey View Post
    oow o.k. your eeprom is corrupted?
    I found these files as well somewhere on the forum here. Can't remember where exactly. Let me know if you can't find them. I will search on my p.c. this evening.
    I haven't done it myself, but you have a programmer?

    br
    Maurice
    Yes, a friend of mine knows how to program eprom, we will see.

  17. #227
    Junior Member
    Join Date
    Apr 2017
    Posts
    7
    Ok, just to inform you, I solved issue.

    As we have 5 chips, 1 is unique, rest 4 chips are identical, and just one note: 4 chips are writable and programmable while 1 unique chip is writable only once and can't be programmed, it's write protected by design.
    So, friend of mine, just do programming of 4 chips and mixer started to work correctly.
    Jazz P Bass and g1 like this.

  18. #228
    Junior Member
    Join Date
    Jun 2017
    Posts
    1

    HELP PLEASE!!

    Hi
    I'm new one here.....I have my ddx mixer....it's working all the time fine but one day I turn on the ddx and all led's are turn on....display dead....feders dont work....nothing....i put microphone and signal lamp are showe that are a signal input and I do not test for output signal works :/
    on picture see's problem....
    What do you think what the problem is??

    Please help me some how behringer-ddx3216-slika-79670961.jpg

Page 7 of 7 FirstFirst 1234567

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Behringer MX3282
    By keys77 in forum Music Electronics
    Replies: 1
    Last Post: 12-10-2010, 12:17 AM
  2. Behringer PMP5000
    By Jazz P Bass in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 03-23-2010, 03:19 AM
  3. Behringer gmx110
    By spsimmons in forum Schematic Requests
    Replies: 0
    Last Post: 02-07-2010, 05:27 PM
  4. Behringer XY1200 Keyboard Amp repair?
    By doc_drop in forum Other Amps
    Replies: 37
    Last Post: 06-23-2009, 11:01 AM
  5. Behringer GMX2112
    By BigDogM in forum Music Electronics
    Replies: 2
    Last Post: 09-08-2008, 04:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •