Results 1 to 5 of 5

Thread: Traynor YBA-3: voltages all look good, but low output

  1. #1
    Gaz
    Gaz is offline
    Senior Member
    Join Date
    Feb 2009
    Posts
    448

    Traynor YBA-3: voltages all look good, but low output

    I've got a YBA-3 that's putting out really low power - 2VAC at the speaker. All voltages check out with the schematic, and a 1k sine wave test signal looks good at the grids of the power tubes, but is small and squashed at the output.

    My intuition tells me that it's gotta be between the phase inverter and the speaker jack. I tried new tubes, but got the same results. Could it be the OT? Or am I missing something. Thanks for any advice.

    P.S. for some reason the amp had a 12DW7 in the PI in stead of a 12AX7!

  2. #2
    Gaz
    Gaz is offline
    Senior Member
    Join Date
    Feb 2009
    Posts
    448
    Awesome. Found the solution in an old thread where the (amazing) Enzo suggested the surge limiting components across the primaries. Funny, my inclination was right - that it was between the power tubes and the speaker - but I failed to notice (both in the amp and schematic) those two pesky components. Hopefully this can at least help someone else. And thanks Enzo!

  3. #3
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    11,736
    Can you post a link to said Enzo post?

  4. #4
    g1
    g1 is offline
    don't forget the joker g1's Avatar
    Join Date
    Feb 2010
    Location
    Canada, somewhere north of Fargo
    Posts
    8,710
    This one? Traynor YBA-1A...low distorted output.
    Seems to be fairly common fault in old Traynors that had them. Probably best to remove them if you come across them. Some folks may want to use the diode scheme instead. The factory never used to suggest replacing them with something else, just removal.
    Certified Dotard

  5. #5
    Gaz
    Gaz is offline
    Senior Member
    Join Date
    Feb 2009
    Posts
    448
    That's the one. Yeah, I just pulled the suckers out. Here's the schem (because there's a few different models) Prowess Amplifiers - Traynor - Schematics - Custom Special Yba 3 - Version 3
    This one's a bit better for bass than the one that's almost identical to a Plexi.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 07-04-2010, 02:50 PM
  2. question on traynor yba-1
    By Bruno in forum Vintage Amps
    Replies: 8
    Last Post: 05-29-2010, 04:38 PM
  3. Traynor YBA-1A...low distorted output.
    By acorkos in forum Maintenance, Troubleshooting & Repair
    Replies: 5
    Last Post: 07-02-2009, 01:03 AM
  4. Vintage Traynor YBA-3 - First One Produced!?
    By vinylcollecter787 in forum Vintage Amps
    Replies: 1
    Last Post: 05-17-2007, 05:10 PM
  5. Traynor custom 40 low voltages
    By Guitarist in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 01-31-2007, 10:14 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •