Results 1 to 2 of 2

Thread: Peavey classic 30

  1. #1
    Junior Member
    Join Date
    Aug 2011
    Posts
    2

    Peavey classic 30

    Hi guys, I'm new to the forum. Can anyone help me with my Classic 30, all of the valves light up in the back,but I have no volume.
    what do you reckon?

  2. #2
    Supporting Member
    Join Date
    Nov 2008
    Location
    los angeles
    Posts
    153
    Welcome to the forum.You will receive plenty of assistance with your Classic 30.
    Let me suggest that you delete this post and re-post in the Guitar Amp section under Maintenance,Troubleshooting and Repair.Also,it always helps to post a schematic with your questions.
    Check out this page: Tube Amplifier Debugging Page
    In fact, check out the whole site.Lots of good information from one of the best.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Peavey Classic 30
    By OMguy in forum Maintenance, Troubleshooting & Repair
    Replies: 11
    Last Post: 07-31-2011, 11:02 PM
  2. Peavey Classic 30 Help
    By Shawnobi in forum Maintenance, Troubleshooting & Repair
    Replies: 18
    Last Post: 11-11-2010, 06:30 PM
  3. peavey classic 30
    By Ron S ANDERSON in forum Maintenance, Troubleshooting & Repair
    Replies: 8
    Last Post: 01-19-2009, 05:17 PM
  4. Peavey Classic 30
    By peavey in forum Maintenance, Troubleshooting & Repair
    Replies: 1
    Last Post: 04-12-2008, 02:41 AM
  5. Peavey Classic 30 same as always??
    By PlayItAll in forum Mods & Tweeks
    Replies: 2
    Last Post: 02-16-2008, 04:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •