Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By Enzo

Thread: Marshall 2266 50watt Vintage Modern Head

  1. #1
    Senior Member
    Join Date
    Jan 2012
    Posts
    484

    Marshall 2266 50watt Vintage Modern Head

    Has anybody had any experience repairing this amp?? I have one where the effects won't work when engaged in loop mode...there is no sound. Take it out of effects loop mode and everything is fine. The problem I am having is that there is not one single voltage level marked on the schematic...I have no idea of what to look for....If I run a signal into the return jack I can get sound. If I scope the send jack, there is nothing. I checked the switch that activates the effects loop for continunity and it checks fine...apart from that, I have no idea if any of the voltages I am seeing are correct or not....any ideas anybody??? I am beginning to think that Marshall does this sort of thing on purpose...

  2. #2
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    7,768
    Would you be so kind as to post the schematic?

  3. #3
    Senior Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    20,894
    Me too, post the schematic.


    "On purpose"? Nah. First, the schematics are printed for the service techs, not the general public. They are not trying to make it difficult for their own techs. And in that I include us poor saps out here at service centers. Second, "voltage charts" are not usually needed by experienced techs. If I have an amp making no sound, after checking th obvious things, I go down the row of tubes checking voltages, before even looking for the schematic. I know that every 12AX7 should have a milliamp or two running through it. If I know the cathode resistance, I can do Ohm's Law in an instant and know what to expect on eaqch cathode. And since current is the same through a series circuit, I can also figure out the voltage dropped across the plate resistors. But even without that, I know that all preamp triodes will have something like a volt or two on their cathodes, and the plate resistor will probably drop something like 100-150v. Regardless of what the tube OUGHT to conduct, if I find zero volts on the cathode, either the cap is shorted or more likely the tube is simply not conducting. Once in a while ther is a cathode follower, and so then I see 100-200v on the cathode. Maybe ther is a phase inverter, so I expect something around 100v on that cathode.

    And on the plates, if I see zero volts there, I can expect the plate resistor is open. If I see a high B+, about the same as the supply voltage, that means the tube is conducting no current. That would be the same tube with zero on its cathode.

    Your problem is no sound under certain conditions. If your tube wanted to have 200v and had only 100v, it would still make sound. Wrong voltages rarely silence the amp. If they are grossly wrong, then we are facing one of the things I described above.

    Your amp works all except the FX loop. I don't have that schematic, so I can;t look at what they did, but if it has FX loop level controls or a balance control, effect/dry, I'd be looking there first. Your switch works that controls the loop, but what actually switches the signal path? A relay? So then is ther power supply to the relay? Does it click in and out when that switch is pushed? Relay probably says a voltage right on it, but it may be 5v, 12v, 24v. Chances are the voltage will either be present or not, not likely present but wrong. No voltage at all, no relay working.
    Jazz P Bass likes this.
    Education is what you're left with after you have forgotten what you have learned.

  4. #4
    Senior Member
    Join Date
    Jan 2012
    Posts
    484
    Sorry for the delay. I think the problem lies with Fet3...when removed from the ckt, the signal actually gets to the copper trace there the input of the Fet is...Put the fet back in and no signal at all. I have a couple of Fets on order. Marshall has suggested replacing both of them...(they both have the same number VN2410L)... I can't get the schematics attached to this....

  5. #5
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    7,768
    Quote Originally Posted by bsco View Post
    . I can't get the schematics attached to this....
    The forum has a 3 meg max upload limit.
    If the file is larger, get the free pdf writer "Cute PDF Writer".
    You can 'print' (to a pdf file) a range of pages to help break down the file.

  6. #6
    Senior Member
    Join Date
    Jan 2012
    Posts
    484
    OK. I'll try something here...no..that didn't work. Send me an email to berniescott2005@yahoo.ca and I'll send them to you. I can't get them uploaded and it is less than a meg....Can't seem to figure out what I am doing wrong...anyway...that's it..I'll email them to you.....
    Cheers,
    Bernie

  7. #7
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    7,768
    Try this.
    Click on:
    -Reply to thread
    -Go advanced
    -Manage attachments
    A new window will open
    -Add files
    -Browse (your hard drive for the file to upload)
    -Click on your file to upload to the 'browse' window
    -Click upload.
    -Close out that window (when the file shows up at the lower left)
    -Submit reply

  8. #8
    Senior Member
    Join Date
    Jan 2012
    Posts
    484
    Sorry about the delay. Here are the schematics......
    Cheers,
    Bernie
    Attached Files Attached Files

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 50Watt Vintage tube PA Tubes?
    By James R in forum Tubes (Valves)
    Replies: 7
    Last Post: 02-09-2012, 05:16 PM
  2. Marshall 2466 Vintage Modern schematic needed
    By Stevek.1 in forum Schematic Requests
    Replies: 4
    Last Post: 02-01-2011, 12:29 AM
  3. Marshall Vintage Modern 2266:Schematics??
    By Kas in forum Schematic Requests
    Replies: 5
    Last Post: 12-27-2010, 11:38 PM
  4. modern marshall amp head cab
    By soultribe in forum Cabinetry
    Replies: 1
    Last Post: 09-18-2008, 02:55 AM
  5. Marshall Vintage Modern 2466 Schematic?
    By mensur in forum Maintenance, Troubleshooting & Repair
    Replies: 0
    Last Post: 08-16-2008, 08:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •