Results 1 to 16 of 16

Thread: DigiTech GSP5 schemo,please!

  1. #1
    Member Le Basseur's Avatar
    Join Date
    Jun 2006
    Location
    Croatia
    Posts
    99

    DigiTech GSP5 schemo,please!

    Just got this old,trusty GSP on repair but I couldn't find any schematic.
    Primarily,there are some blown components (a small elecrolytic,maybe a diode and a IC) so I'd have to identify some values.
    Thank you!
    Regards,
    Le Basseur

  2. #2
    Member Le Basseur's Avatar
    Join Date
    Jun 2006
    Location
    Croatia
    Posts
    99

    ...and here's the victim!

    No trace of the schemo so far.The worst is that I cannot contact any service center in the area where I live (the local DigiTech dealer is unable to provide a schematic and the DigiTech website doesn't offer any help for overseas users except an expensive Europe-to-USA phone line).
    ...so that I made a couple of pics.
    As you can see,the C30 is shot.
    Judging by the nearby components,the C30 should be a tantalum electrolytic,as is C29 (10 micro/16V).OK,just for being sure,I'll replace C29 as well as has burning marks on it.
    Any hint about what else should I look for?
    Thanks!
    Regards,
    Le Basseur
    Attached Thumbnails Attached Thumbnails 31.5.2007-11-41-48.jpg   31.5.2007-11-45-46.jpg  
    Last edited by Le Basseur; 05-31-2007 at 12:15 PM.

  3. #3
    Old Timer
    Join Date
    Jun 2006
    Location
    Norristown state hospital
    Posts
    1,775
    By asking very nicely I got a guy at Digitech to fax me a schematic for my ValveFX about 8 years ago.
    It was modded to use a regular footswitch to change channels but the Digitech Control One foot controller would not work with it (that's why I got it cheap).

  4. #4
    Member Le Basseur's Avatar
    Join Date
    Jun 2006
    Location
    Croatia
    Posts
    99
    Hi drewl,
    The problem is that I didn't find any e-mail contact on the Digi website.
    Aside of that inter-continental call (wich I cannot afford),there's no other option there.
    Thanks,
    Le Basseur

  5. #5
    Junior Member
    Join Date
    Jul 2007
    Posts
    3
    Quote Originally Posted by Le Basseur View Post
    Hi drewl,
    The problem is that I didn't find any e-mail contact on the Digi website.
    Aside of that inter-continental call (wich I cannot afford),there's no other option there.
    Thanks,
    Le Basseur
    Hi Did you have any success finding the value of the components as I have a GSP5 with the same problem, and it would be great if you have discovered the solution.
    Many thanks
    Soundhouse

  6. #6
    Senior Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    28,475
    I just went to www.digitech.com and on the welcome page there is a "contact" button along the top bar, on the side menu, and at the bottom. They all go the same place.

    Click contact, and select customer service. That opens a fill in the blanks type of request page. Fill it in and include your email address and tell them you need the schematic and can't find it where you are.

  7. #7
    Member Le Basseur's Avatar
    Join Date
    Jun 2006
    Location
    Croatia
    Posts
    99
    Quote Originally Posted by Soundhouse View Post
    Hi Did you have any success finding the value of the components as I have a GSP5 with the same problem
    I figured out what values might have the exploded tantalums (they're 10mf/16V) and I replaced them with "normal" electrolytics of a better quality (some Elna's).Also,I replaced the LM311 chip as it seemed to be a little "toasted" (the processor didn't function after the cap's replacement but it worked as I replaced the chip).
    In the lack of a schemo,it's the best I could do...I know,what I did is totally un-professional and empirical and I'm THE shame of this forum but,let's put it this way:I got lucky this time.
    However,after getting it alive,I noticed that the processor has some other small flaws (the signal and clipping LEDs aren't working as they're supposed to do) but the owner doesn't seem to be bothered about that...still,I am,so a schemo should be of a great benefit as I really don't like to leave things half-way.
    Quote Originally Posted by Enzo View Post
    I just went to www.digitech.com and on the welcome page there is a "contact" button along the top bar, on the side menu, and at the bottom. They all go the same place.
    Click contact, and select customer service. That opens a fill in the blanks type of request page. Fill it in and include your email address and tell them you need the schematic and can't find it where you are.

    (more embarrased than ever)
    Thanks Enzo,
    I deserve several baseball bats in my head for this.
    I'll try what you said.
    Regards,
    Last edited by Le Basseur; 07-06-2007 at 09:35 AM.

  8. #8
    Junior Member
    Join Date
    Jul 2007
    Posts
    3
    Many thanks for your information a great help. I do know that Digitech have just redesigned their webpage so the contacts bit may be new. I will also try and see if I can get a schematic from them.
    Thanks.

  9. #9
    Member Le Basseur's Avatar
    Join Date
    Jun 2006
    Location
    Croatia
    Posts
    99
    Hey,
    I just sent to Digitech a schematic request as Enzo suggested...let's hope that one of us'll get it.
    Regards,

  10. #10
    Senior Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    28,475
    Over here, I have been charged something in the past, but plead overseas and they might relent if that is still their policy.

    In the lack of a schemo,it's the best I could do...I know,what I did is totally un-professional and empirical and I'm THE shame of this forum
    No no no, you used your wits and resources to get around the lack of documentation. Never be ashamed of using alternative means to get to your goal. When they say "think outside the box," they mean what you did.

  11. #11
    Junior Member
    Join Date
    Jul 2007
    Posts
    3
    Brilliant I have just received two emails from Digitech with schematics attached. I am seriously impressed with their support guys. Let me know if you get a copy otherwise I can forward it to you.

  12. #12
    Member Le Basseur's Avatar
    Join Date
    Jun 2006
    Location
    Croatia
    Posts
    99

    Talking 2Fast&2Furious

    Hey Soundhouse,
    Glad you got the schemos...I didn't received nothing.
    Could I get a copy by e-mail?
    sorincristearo/at/yahoo.com
    ...or,simply,attach them on this board?
    Regards,

  13. #13
    Supporting Member Steve A.'s Avatar
    Join Date
    May 2006
    Posts
    3,868
    I had picked up a used Digitech DSP 128+ about 10 years ago with no owners manual, and called Digitech customer service. They mailed me a photocopy of the manual (something like 64 pages)... NO CHARGE. Hey, those Mormons over in Salt Lake City are allright! LOL

  14. #14
    Member
    Join Date
    Nov 2007
    Posts
    83
    Quote Originally Posted by Soundhouse View Post
    Brilliant I have just received two emails from Digitech with schematics attached. I am seriously impressed with their support guys. Let me know if you get a copy otherwise I can forward it to you.
    Any chance of posting the schemo here? (or emailing?)

    I've had a defunct GSP5 for years, which I bought new. The readout was scrambled, so I assumed the logic was fried. Today I plugged it in, and the same darn tantalum cap (C30) went poof....but the readout works OK now!

  15. #15
    Member Le Basseur's Avatar
    Join Date
    Jun 2006
    Location
    Croatia
    Posts
    99
    gmoon,
    Sorry for the delayed reply.
    Here's the file you asked for:
    http://www.ampix.org/albums/userpics...itech_DSP5.pdf
    (kudos to soundhouse who got this schemo and kindly shared it)
    Enjoy!
    Regards,

  16. #16
    Member
    Join Date
    Nov 2007
    Posts
    83
    @Le Basseur

    Thanks so much! And to Soundhouse, too.

    It's nice to have this up and running again (kinda like the late 80's in a box...)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zenner trick??? Where's the schemo?
    By Satamax in forum Guitar Amps
    Replies: 21
    Last Post: 08-04-2011, 03:09 PM
  2. Gem Mars G15 schemo???
    By Satamax in forum Music Electronics
    Replies: 4
    Last Post: 01-29-2008, 06:58 PM
  3. Fender M-80..Digitech RP-20?
    By evildikk in forum Guitar Amps
    Replies: 1
    Last Post: 03-14-2007, 12:03 AM
  4. TSL 100 no sound??? Schemo???
    By Satamax in forum Maintenance, Troubleshooting & Repair
    Replies: 7
    Last Post: 01-27-2007, 10:09 PM
  5. Digitech Bass Synth Wah Inductors
    By primussy in forum Guitar Effects
    Replies: 0
    Last Post: 11-04-2006, 11:53 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •