Results 1 to 5 of 5

Thread: Fender Blues Deluxe reverb problem

  1. #1
    Junior Member
    Join Date
    Jul 2013
    Posts
    2

    Fender Blues Deluxe reverb problem

    I'm new to this forum and I'm a guitar repair tech who rarely works on amplifiers or sound systems. I own a Fender Blues Deluxe (1996 American made) and the reverb pops in and out randomly. I've De-oxed the microswitches that change the channels and all of the inputs as well as the connectors at the reverb tank with no success. I can make the reverb pop back in by thumping the top control plate.
    Has anyone out there had this problem?

    I'm out of my league with amp problems!

    Thanks,
    Tom Sawyer (really!)

  2. #2
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    11,860
    What is the 'Top Control Plate'?

  3. #3
    Junior Member
    Join Date
    Jul 2013
    Posts
    2
    Quote Originally Posted by Jazz P Bass View Post
    What is the 'Top Control Plate'?
    By top control plate I mean the actual control section of the amp (volume, tone, reverb etc...). Instead of a front loaded control panel, the controls are on top of the amp. When I tap the chrome plate, the reverb kicks back in. Tried it again last evening and I noticed that the led for the channel switch pops on when the reverb cuts out which confounds me even further! The reverb is not footswitch controlled.

    The humidity level in my teaching studio and guitar repair shop is at approximately 40 to 45% almost all of the time because of all the instruments in storage or on the bench, so that really shouldn't be a factor. The amp is on an elevated amp stand which tilts it back so heat build up could have been a contributing factor, I suppose (this particular model, although an open back, has a rather elaborate back protection panel that could really be restricting the ventilation).

    Thanks for your interest and reply

    T.S.

  4. #4
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    11,860
    If tapping the amp makes it work, then something is loose.
    You can tap (with a wooden dowel) the circuit board & try to narrow down where the loose component is located & resolder that area.

  5. #5
    Old Timer
    Join Date
    Jun 2007
    Posts
    4,925
    Quote Originally Posted by Tom Sawyer View Post
    By top control plate I mean the actual control section of the amp (volume, tone, reverb etc...). Instead of a front loaded control panel, the controls are on top of the amp. When I tap the chrome plate, the reverb kicks back in. Tried it again last evening and I noticed that the led for the channel switch pops on when the reverb cuts out which confounds me even further! The reverb is not footswitch controlled.
    If the problem comes and goes with a mechanical stimulation, then there is probably something loose on the board. If fact your amp is old enough that it could be the typical low voltage power supply problem related to the large dropping resistors and Zener diodes coming unsoldered due to overheating.

    If you have the skill set to safely remove the pc board and resolder the loose parts, then that would be the next step. If you don't have the ability to do this safely, then it needs to go to a qualified tech.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fender Hotrod Deluxe reverb problem
    By Swampy in forum Maintenance, Troubleshooting & Repair
    Replies: 11
    Last Post: 10-05-2012, 05:35 PM
  2. Blues Deluxe Modern SS Reverb Problem
    By captntasty in forum Maintenance, Troubleshooting & Repair
    Replies: 7
    Last Post: 05-17-2012, 06:44 PM
  3. Blues Deluxe Tube problem.
    By Danglin' Fury in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 05-04-2011, 09:50 PM
  4. blues deluxe reissue problem
    By shay in forum Maintenance, Troubleshooting & Repair
    Replies: 9
    Last Post: 09-21-2009, 04:24 PM
  5. blues deluxe problem
    By trashcole in forum Maintenance, Troubleshooting & Repair
    Replies: 1
    Last Post: 06-15-2008, 08:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •