Results 1 to 7 of 7
Like Tree2Likes
  • 2 Post By Elettronico

Thread: Behringer DDX3216 - Problems with boot

  1. #1
    Junior Member
    Join Date
    Nov 2016
    Location
    Italy
    Posts
    4

    Behringer DDX3216 - Problems with boot

    Hi all,
    I'm new in this forum and I've found here very useful infos about the Behringer DDX3216 Mixer.
    I have a trouble with this device. I've already read all the previous threads but unfortunately I haven't found the solution.
    In my DDX3216, the first part of boot is correct but the mixer remains in the state shown by the following picture.

    photo_2016-11-06_20-55-21.jpg

    Fader positions are not shown on the display. Furthermore, pressing buttons makes no change in the mixer state and all faders remains in the lower position. The 7-segments displays are off. All the front panel is "freezed" and, obviously, there is no sound at the output.

    I've checked the PSU, that is correctly working (tested with resistive loads and oscilloscope), and the crystal Q3 that oscilllate.
    I try to disconnect all the flat cables from the CPU01 board, except the display, and the boot procedure ends with something like "error, check faders...": so, I think that the 386 CPU is working correctly (maybe...)

    Can you help me? I don't know where to turn

    Thanks (and sorry for my bad English, I'm Italian)!
    Alessio

  2. #2
    Senior Member
    Join Date
    Sep 2011
    Location
    Pace, FL
    Posts
    1,052
    This link may be of some assistance. Theres like 6 pages there, don't reply in that thread though, place your questions here.

    Thanks,
    nosaj
    Behringer DDX3216 - Trying to repair, please help!

  3. #3
    Junior Member
    Join Date
    Nov 2016
    Location
    Italy
    Posts
    4
    Hi nosaj,
    thanks for your reply!

    I have the same problem reported by soundmandoug: after the CPU completes it's power-on sequence (about 14 seconds, during which the display shows the "DDX3216" splash screen) the faders are not loaded and buttons are un-responsive.
    Soundmandoug solves this problem by changing EEPROMs with ones bring out from a working unit.

    I haven't another DDX3216 to try this solution. So, I re-flash EEPROMs with BIN files uploaded by S2udio, but unfortunately this not works: now, the mixer shows a message like "UNCORRECT PROGRAM". Another user said that the uploaded files are not working.

    Finally, can anyone help me with a working set of BIN files?
    Many thanks!
    Alessio

  4. #4
    Member
    Join Date
    Aug 2012
    Location
    UK
    Posts
    59
    Check the fader board for dry joints/ bad ribbon cable.....there is an eprom up there as well that can go corrupt ,a while now since I had any trouble with my two desks,
    One of the main epproms deals with fader positions ,leds etc etc.....cant remember which one ?
    Those flash files do work , you need ver 1.12 update to run them and always set to factory default at first load., they will error if you don't.. ADAT cards we fitted to the imaged desks.
    Sorry been awhile since my last DDX episode.

  5. #5
    Junior Member
    Join Date
    Nov 2016
    Location
    Italy
    Posts
    4
    Hi all! Thanks for your replies, and sorry for my absence in this thread.

    Quote Originally Posted by S2udio View Post
    Those flash files do work , you need ver 1.12 update to run them and always set to factory default at first load., they will error if you don't.. ADAT cards we fitted to the imaged desks.
    Well, I tried to start my desk with your files, by pressing SETUP + 1-16CH buttons (in order to reset the device) but the display said "No valid program - Restart update". My mixer has only one ADAT card.
    Can you help me? Are you sure that your EEPROM files are correct?

    Many, many thanks!
    Alessio

  6. #6
    Junior Member
    Join Date
    Nov 2016
    Location
    Italy
    Posts
    4
    Quote Originally Posted by Elettronico View Post
    Hi all! Thanks for your replies, and sorry for my absence in this thread.


    Well, I tried to start my desk with your files, by pressing SETUP + 1-16CH buttons (in order to reset the device) but the display said "No valid program - Restart update". My mixer has only one ADAT card.
    Can you help me? Are you sure that your EEPROM files are correct?

    Many, many thanks!
    Alessio

    Hi all!
    I resolved my problem using another DDX3216 unit, borrowed by a friend.
    I copied the EEPROMs code from the working unit, then I flashed my EEPROMs.
    Finally, IT WORKS!!!

    Here are EEPROMs bin files, DDX3216 v1.1 with an ADAT expansion.
    CPU_EEPROM_DDX3216_v1.1.zip

    Bye bye!
    Jazz P Bass and The Dude like this.

  7. #7
    Member
    Join Date
    Apr 2015
    Posts
    48
    You totally saved my unit! Thank you so much!

    I have had this repair sitting in the corner for more than a year and when I came across your dumps I thought, can't hurt to try. And it worked. Still testing the unit but it looks like this was the only problem - apart from an old display...

    Thanx again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Behringer DDX3216 - Trying to repair, please help!
    By fznuk in forum Music Electronics
    Replies: 227
    Last Post: 06-18-2017, 08:15 PM
  2. Behringer DDX3216 problem
    By sergio77 in forum Music Electronics
    Replies: 0
    Last Post: 02-12-2016, 08:29 AM
  3. Behringer DDX3216 problems
    By choe62 in forum Music Electronics
    Replies: 9
    Last Post: 02-28-2015, 08:19 PM
  4. Behringer DDX3216 revival
    By Wayne Leeds in forum Music Electronics
    Replies: 12
    Last Post: 12-23-2014, 02:43 PM
  5. Behringer DDX3216
    By guitardad in forum Schematic Requests
    Replies: 0
    Last Post: 10-03-2013, 01:17 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •