Results 1 to 6 of 6

Thread: DDX3216 hangs at CPU production test menu

  1. #1
    Junior Member
    Join Date
    May 2017
    Posts
    3

    DDX3216 hangs at CPU production test menu

    Hi,

    I bought a dead unit and fixed the power supply. Now the issue is that the unit is stuck in some sort of CPU production test.
    I have put in a memory card and loop back MIDI to pass those tests. But the RS232 does not get passed with a loop on the 9 pin connector.
    I made a video, just check https://www.youtube.com/watch?v=vUQD95mq2mo

    Does anyone have a clue how to exit this test? Or can anybody let me know how to flash new firmware? There seems to be a tool that I can find nowhere on the internet...

    Thanks a lot for your help!

  2. #2
    Supporting Member
    Join Date
    Dec 2009
    Location
    UK
    Posts
    2,837
    Hi and welcome.

    Did you do a factory reset?

    I did a quick search on this forum for the model and it turned up a lot of interesting stuff. Maybe read through the other replies to see if you can find what you need. I found the firmware, but it looks like you'd need to flash the EEPROMS outside of the unit. Depending on the specific device family, there are quite a few cheap Chinese programmers that work just fine with generic tools to erase/load/validate the chips. Quite a few of the people posting are still active, so may reply to a P.M.

  3. #3
    Senior Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    28,035
    Before we go nuts, make sure the communication cable to the display is good. Sometimes a diusplay board defaults to a diagnostic mode when communication to the host is lost. That used to be a test procedure with Ensoniq - pull the cable to the display and it went into test mode.
    Education is what you're left with after you have forgotten what you have learned.

  4. #4
    Junior Member
    Join Date
    May 2017
    Posts
    3
    Of course I have checked the forum and the internet before. I found someone with a similar issue on YouTube, but he did not reply. I can say that I'm quite experienced with electronics repair from a hobby perspective. I had another, working, unit and swapped the eproms but the issue stayed in this unit; so it seems not related to the firmware.So probably this EOL production menu should either be finished without issues or be cancelled in any special way. For both I guess that need I some inside info from someone who worked at Behringer or who worked in an official repair shop....

  5. #5
    Old Timer olddawg's Avatar
    Join Date
    Dec 2007
    Location
    Carlsbad, CA and Kona, HI
    Posts
    2,350
    Do you have a pinout diagram to the u? You could try a hard reset to main u. In most cases it just involves grounding (if it's a - reset) the reset pin through a 1k resistor while powering the unit up.

  6. #6
    Junior Member
    Join Date
    May 2017
    Posts
    3
    I have the diagram so I will definitely look into that option, thanks for the tip!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Facebook & Firefox hogging CPU on Mac today
    By Mark Black in forum Fun with computers
    Replies: 1
    Last Post: 07-13-2015, 02:32 AM
  2. Microkorg CPU trouble
    By tired eyes in forum Music Electronics
    Replies: 9
    Last Post: 04-03-2014, 12:52 AM
  3. Kn 1400 error in cpu data transmission??
    By kelanadua in forum Music Electronics
    Replies: 8
    Last Post: 08-31-2013, 09:42 AM
  4. Pickup that hangs from a spring?
    By Bmxbarspin724 in forum Pickup Makers
    Replies: 6
    Last Post: 11-03-2009, 05:05 PM
  5. CPu Fan as winder
    By Tonebucket in forum Tools and Coil Winding Gear
    Replies: 16
    Last Post: 04-05-2007, 03:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •