I have a amp in for evaluation. The customer obtained it from an estate sale and overall, it is in good physical condition. It has been sitting for a at least 10 years from what i am told...and by the look of it, I would agree with that estimate. I opened it up and gave it a visual overview and it is original from what i can tell. I pulled and tested all the tubes. The 5 x 12AX7's test strong (SovTek brand). The 4 x 6L6GC's test good...but they are just making it into the 'green'. I brought it up on a variac with no tubes on it and it seems to come up without issue. Put the tubes in and fired it up. It puts out some low volume hum, but i am not very surprised with that. After a few minutes, I jacked in and played on it for a bit. Generally speaking, the pots need a good cleaning along with the input jacks, but it played. As you get it cranked up a bit, i am hearing some artifacts and crackling. Double checked the tubes by using the highly accurate 'smack' test and found the output tubes to be quiet noisy. I did not have a full set of 6L6's on hand to swap out, but i did have a pair that i put in (by themselves). Sound seems to stabilize and hum virtually went away.

So long story short, I will be recommended a new set of output tubes and a general cleaning and bias adjustment....BUT....here is where i though i you guys could help me. I have read up on these amps and from what I have found, they have a small following, but generally people are not a fan of them...in some cases, I have read that they are not worth keeping. In any case, what your thoughts on this amp (if you have experience with them) and is it worth putting money into. (I know, beauty is in the eye, and ear, of the beholder, but would like to advise my Customer properly.)