Announcement

Collapse
No announcement yet.

Accidental Tremolo on DIY Build

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chuck H
    replied
    Originally posted by ToneHenge View Post
    Way late on this one, but ya'll were right. I added another PS filter cap for the first preamp tube amp everything works great now! Guess I forgot to revisit this thread since I was so happy with the result
    Not that late. We see threads go for a year or two sometimes before the OP returns to say "I'm just getting back to this. What do you guy's think is the problem now?" without having taken advice. Or maybe they NEVER get back to the forum. So this is a positive follow up in a "relatively" timely manner. Believe it or not this is very satisfying. We've learned to live with both long time lags and even zero resolution. This is actually refreshing

    Leave a comment:


  • ToneHenge
    replied
    Way late on this one, but ya'll were right. I added another PS filter cap for the first preamp tube amp everything works great now! Guess I forgot to revisit this thread since I was so happy with the result

    Leave a comment:


  • eschertron
    replied
    Here's my non-technical take: If the amp's PSU was really stiff, there'd be no problem. Each odd stage - in this case, the input stage, the stage after the mid control, and the FX loop send - are all in phase, and the currents flowing in or out of the PSU node "D" sum together. I expect the voltage on the FX loop send anode to be relatively big*. The PSU feedback occurs when the large currents from the 3rd and 5th stages cause some wiggle to the anode voltage at the first stage. This actually is mixing some of the larger, in-phase signals with whatever is happening to the first stage. Positive feedback. The size of that PSU node's decoupling cap will have an effect on the amplitude and frequency of the frequencies that are reinforced. Adding PSU nodes to decouple the interaction between stages is what the PSU design game is all about. What we call 'sag' is a specific example of this interaction, with a big cap for a long time constant, and a gain less that one so feedback doesn't develop. Make the power supply stiff enough, and the amp becomes "design ideal perfect", but isn't any fun to play. It doesn't sound like a guitar amp any more.

    *as an aside, I'm wondering if shrinking the anode resistor and growing the cathode resistor - keeping the signal at the send at the right levels - might also help alleviate the PSU feedback. This as alternative to moving the anodes to a different node. Actually, there's lots to the PSU design than can be tweaked to see what changes/improvements can be gained. But for me, the bottom line is to realize the 'rule' of not more than two (three? four?) gain stages on a PSU node is actually a good idea grounded in theory and practice.
    Last edited by eschertron; 08-28-2019, 06:54 PM.

    Leave a comment:


  • ToneHenge
    replied
    Sounds like the consensus is that I need to add another filter stage. Kind of ironic because I was given this suggestion early on in the design stage, but was feeling too lazy to implement it... I think I’ll try your suggestion first eschertron and hookup the fx loop to the phase inverter filter stage.

    Can anyone shed some light on the theory of how having too many stages share a PS node can cause this modulation at a specific point in the signal path? I always thought of ‘motorboating’ as a little higher frequency than what I’m experiencing - the modulation here is only 2-3Hz

    Thanks all!

    Leave a comment:


  • eschertron
    replied
    My first build had quite a case of 'motor-boating', which is what you're describing.

    You could try moving the FX loop stages to the "C" node, but even then another RC filter for the input - per the Dude's suggestion - would be advisable.

    Leave a comment:


  • loudthud
    replied
    Too much stuff running from the "D" node. You need another filter cap and resistor to make an "E" node for the first stage.

    Leave a comment:


  • Chuck H
    replied
    Well oscillation is a positive feedback loop. There are a couple of typical causes for this condition that are related to the power supply. Make sure you have the preamp filter grounded with the preamp and make sure you aren't using any daisy chained grounds with like phase circuits.

    In your case you have like phase circuits being supplied by the one and only preamp node on the HV rail. I think this problem could be mitigated by adding a node to the rail so that the preamp and effects loop are filtered separately and making sure there are no daisy chained grounds between like phase circuits.

    Leave a comment:


  • ToneHenge
    started a topic Accidental Tremolo on DIY Build

    Accidental Tremolo on DIY Build

    I've stumbled into a real doozy on a recent build. I've noticed my amp starts to produce a very low frequency amplitude modulation (sounds like tremolo) under certain conditions. The problem only arises if the bass control is all the way up and the gain control is anywhere past about 3 o'clock - the treble control and master volume don't appear to have any effect. The modulation stops if I back off the bass control or gain knob whether or not there's any signal at the input. FWIW, the modulation is less of a sine and more of a ramp.

    Here's what I've checked out so far:
    The design uses a serial effects loop right before the phase inverter stage. I was able to hookup a signal generator and trace a tone through the circuit to the point where the modulation seems to gets introduced. It looks like the issue occurs right at the cathode of the cathode follower stage that drives the effects loop send. However, I'm not sure what that tells me. The values are lifted straight from Merlin's website, so nothing too unorthodox there. Also checked the ripple my HT voltages but didn't seek anything unexpected: about 1.5Vpp at the last filter cap.

    I must say it sounds pretty cool to my ears, but it's not deliberate so it's gotta go...

    Here's the circuit that I'm working on. PS and power amp are straight from a twin, but the preamp is tweaked a bit more.
    Click image for larger version

Name:	MEF_post.jpg
Views:	2
Size:	454.8 KB
ID:	874900
Working...
X