Announcement

Collapse
No announcement yet.

Peavey Ultra switching problem question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Peavey Ultra switching problem question

    I have a Peavey Ultra that is not switching from crunch to ultra correctly. I have the schematic and have found Q5, Q6 and Q7 defective. Does anyone know of anything in this circuit I may be missing?

    Thanks
    wrkbnch

  • #2
    Which Ultra do you have? My drawings for the Ultra 60 and 120 as well as the Ultra Plus have no transistors in the channel switching.

    On other PV AMps like the XXX with xstrs, it would be odd for all those to go. But since PV uses mainly relays, there is not much complexity to the circuit. WHat is wrong with the transistors? Without a FS plugged in, on those PV amps, the transistors turn on and hold the relay circuits active. The pedal grounds the bases of the transistors and they essentially disappear.

    Ultra, Cruch, and Clean are not usually three channels to switch between. Usually one switch switches between two - ultra/crunch, for example - then the other switch selects either the clean or those two. So for example, of you were in ultra and hit the clean switch, you'd go to clean. But if you then hit the crunch switch, nothing would happen because you were still in the clean. Now hit the clean switch and it goes back to ultra/crunch, and since you just hit the bitton, you will find yourself in crunch rather than the ultra.

    Various of their amps work that way in various combinations. Point being that on some models there are certain channel transitions that will require pushing two buttons. If that is what you are trying to fix, it is wired that way.
    Education is what you're left with after you have forgotten what you have learned.

    Comment


    • #3
      Thanks Enzo for your reply.

      This is a Peavey Ultra Plus the problem is I loose control of the crunch effect. When I change from the clean channel to the crunch/ultra the ultra volume and gain controls become the the controls for both the crunch effect and ultra effect. The crunch effect volume and gain have no effect. Q5, Q7 JFET, J174) and Q6 (JFET, J111) are all shorted from source to drain. I was hoping this was a common problem since I have a friend whose Peavey Ultra 120 is doing the same thing.

      Thanks again and any information you could provide would be much appreciated.

      wrkbnch

      Comment


      • #4
        Originally posted by wrkbnch
        Q5, Q7 JFET, J174) and Q6 (JFET, J111) are all shorted from source to drain.
        JFETs (depletion mode devices, anyway, like the J111 and J174) are normally-ON devices. To turn them OFF, you need to get the gate at least 3 volts negative WRT the source/drain (for a JFET, they're interchangeable).

        In other words, if the control circuit isn't acting to turn the JFET OFF, it will be ON, and read less than 30 (J111) or 85 (J174) ohms impedance.

        Not to say that they aren't shorted in your amp, but you might want to double-check. Then measure the gate voltages, toggle the switches and check it again. You want to try to isolate to problem to either the JFETs or the control circuit.

        HTH!

        Comment


        • #5
          Silly me, I thought you means transistors in the switching circuit as oposed to the signal path transistors. I'm on board now.

          Listen to Don, those FETs are ON until you turn them off with a gate voltage. They are normally low resistance D-S.

          Q7 is a mute, if it were stuck on it would shunt the signal to ground and nothing would come out in either channel. SInce you have Ultra output, the Q7 is working. Same with Q5,6. They are mutes. Those "clamp" signals are momentary mutes for when channels switch. WIthout them the amp would make loud pops or other noises whenever you switch channels.

          FOr a fun experiment, measure D-S resistance of Q7 with the power off. You get some low resistance. Now turn the amp on and measure the resistance again. It will be much higher. Also you will find a positive 20 volts or so on the gate.

          Are you using the footswitch? On some PV amps you cannot get to the crunch without the FS. If you are not using the footswitch, the amp is working normally.

          If you ARE using the FS and it won't switch to crunch, then the relays are not energizing. K2 and K3 switch to crunch, and they can only be energized by the FS.
          Education is what you're left with after you have forgotten what you have learned.

          Comment


          • #6
            Foot switch required. Duh!

            Thanks for the info.

            Comment

            antalya escort
            kartal escort
            sex vidio
            altyaz?l? porno
            antalya escort
            beylikduzu eskort bayan eskort bayan escort antalya sirinevler bayan escort
            gaziantep escort
            Working...
            X