Announcement

Collapse
No announcement yet.

Help a beginner fix a JC-50

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • glebert
    replied
    Sounds to me more like a capacitor than a transistor, but that is more of a guess. I would use some cold spray on individual components while listening and seeing if it changes the noise. Either that or tapping stuff with a chopstick to look for intermittent connection. Also, I had an Eden bass head that had similar noise and it was a bad master volume pot, basically there was no ground reference for the signal at that point, might be worth checking. You will likely need to pull the pot to check that.
    Last edited by glebert; 12-12-2017, 09:40 PM.

    Leave a comment:


  • nuromantix
    started a topic Help a beginner fix a JC-50

    Help a beginner fix a JC-50

    My JC-50 (older rev) is making loud whooshing & crackling noises constantly.

    The noises are not affected by the tone controls or effects but they are affected by the "bright" switch and the volume pot.

    Looking at the schematic makes me think it's probably transistor Q5, Q7 or Q8 gone leaky, but I am more or less a complete amateur. Testing them on the board isn't really possible.

    Please can anyone case an eye over the schematic and tell me if they think I might be right, before I start removing transistors one by one for testing.

    Thanks!

    http://www.synfo.nl/servicemanuals/R..._NOTES_2nd.pdf
    Last edited by nuromantix; 12-12-2017, 02:53 PM.
antalya escort
pendik escort
sex vidio
altyazili porno
antalya escort
beylikduzu eskort bayan eskort bayan escort antalya sirinevler bayan escort
gaziantep escort
Working...
X