Announcement

Collapse
No announcement yet.

Kustom 200B blowing fuses

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kustom 200B blowing fuses

    Alright, here's another opportunity for me to learn more about repairing SS amps, as my knowledge is extremely limited.

    Customer brings in an amp he picked up that apparently worked fine when it was put in a closet 15 years ago. First fire up the other day, it blows a fuse on him. So what does he do? Shorts across the fuse, of course
    He said something burned up at that point.
    I just opened it up, and can confirm that one of the 1R 5W is open. I'm not sure which one it is on the schematic, but its on the far right looking at the board . That's all i got. Where do I go from here?
    I imagine I should start by disconnecting the power supply from the power amp and see if it holds? I've circled the 1R resistors on the schematic
    PC703 (rev4 1-70).pdf

  • #2
    When the power amp is correct DC output voltage (blu wire) on speaker jack must be 0V +/- few mV.

    For blowing fuses at power amp "cause" are some of the faulty transistors, output Q1, 2, 3, 4 and, or driver Q704, 705, 708, 709.

    For the beginning of the disconect collectors (red wire) of the output transistors from the power supply voltage, or remove them from the socket (if they are in the socket)

    Measure DC voltage to output (blu wire) speaker jack. How much is it?

    All measurements and repairs work without the connected speaker.
    Who does not know and knows that he does not know - teach him Confucius)
    Who knows and does not know that he knows - wake him Confucius)

    Comment


    • #3
      If the fuse hadn't been bypassed, it might have been a single transistor, but I would suggest that you meter test all of the transistors on the board before you try powering up again. The drivers will short very easily and are difficult to replace. Using a light bulb limiter here will help save new parts until you find all of the bad parts.

      The one ohm resistors are the emitter or ballast resistors for the outputs. The one that has gone open, acted like a fuse for a shorted output. When testing the outputs, pull the black plugs from the base and emitter pins and then look for shorts between the emitter and the collector (case).

      The main rectifier bridge rarely goes bad on these and most failures are transistor related. One last thing is the temperature compensating diode that mounts to the heat sink. The leads of these diodes are very fragile and will break off right at the bottom of the case. Try not to bend or stress them if at all possible.

      Good luck.

      Comment


      • #4
        Ok thanks guys.
        Vintagekiki, I need to rig up a fuse situation before I can power it on, as it has a leaded fuse in it, and my attempts to solder leads on a regular one were unsuccessful.

        Originally posted by 52 Bill View Post
        When testing the outputs, pull the black plugs from the base and emitter pins and then look for shorts between the emitter and the collector (case).
        Bill, I'm a little confused here. Here's a picture of what I've got. I'm assuming I desolder the blue and yellow wires from the base and emitter and then test?
        Also, the open ballst resistor is the one on the far right

        Click image for larger version

Name:	IMG_9061.JPG
Views:	1
Size:	2.09 MB
ID:	854354Click image for larger version

Name:	IMG_9062.JPG
Views:	1
Size:	2.59 MB
ID:	854355

        Comment


        • #5
          This is not a complex amp. I would remove and test the output transistors for shorts one at a time. Then the drivers. If you do get it fixed.. make sure you check his speakers and wiring as a short it that mess probably caused the problem.

          Comment


          • #6
            Originally posted by LarBal View Post
            Bill, I'm a little confused here. Here's a picture of what I've got. I'm assuming I desolder the blue and yellow wires from the base and emitter and then test?
            I think he's saying you can just pull those black plugs off, without desoldering the yellow & black.
            "Everything is better with a tube. I have a customer with an all-tube pacemaker. His heartbeat is steady, reassuring and dependable, not like a modern heartbeat. And if it goes wrong he can fix it himself. You can't do that with SMD." - Mick Bailey

            Comment


            • #7
              When the power amp is defective, a DC voltage of up to 39.5V can occur on the speaker jack.

              During repairs to protect from further damage connect speaker jack with speaker or dummy load via capacitor 2200 - 4700 uF/ 63V

              A simple current limiter to safe amp repairs can be done puts the resistors 100 ohm/50W in +/- 39.5V supply.

              Click image for larger version

Name:	Safe current limiter.jpg
Views:	1
Size:	377.1 KB
ID:	854357

              Do not replace ad hoc any transistors, if not previously tested them in what condition.
              Test each transistor with the multimeter in the circuit or removed from the circuit.

              From the 30 year practice, the most common failures in power amp are the output transistors, the driver transistors, and emitters resistors output transistors.

              After each power amp repair, necessarily set the idle current output transistors, and check the DC offset on speaker output jacks.
              Who does not know and knows that he does not know - teach him Confucius)
              Who knows and does not know that he knows - wake him Confucius)

              Comment


              • #8
                This^^^

                The black plastic things are sockets, the transistors just plug into them.


                You don't solder onto fuses. The fuses with wires are called "pigtail" fuses. But you could easily mount a clip style fuse holder into the amp.
                Education is what you're left with after you have forgotten what you have learned.

                Comment


                • #9
                  Originally posted by LarBal View Post
                  I'm assuming I desolder the blue and yellow wires from the base and emitter and then test?

                  [ATTACH=CONFIG]54429[/ATTACH]
                  Do not desolder any wire, because the transistors are mounted in their socket. Simply remove transistors from the socket.

                  Pay attention to the silicone insulating substrate and transistor insulators.
                  Who does not know and knows that he does not know - teach him Confucius)
                  Who knows and does not know that he knows - wake him Confucius)

                  Comment


                  • #10
                    Ok thanks everyone for the responses. It will be a few days before I can get back to this amp, but I'll report my findings.

                    Comment


                    • #11
                      It seems to be "My amp blows fuses! What could POSSIBLY be wrong with it??" season again. I just typed much of this in at another forum beset with "fuses-blowing" problems, so I'll try to reconstruct it, but with SS amps instead of tube amps in mind.

                      If fuses blow, it must mean that something, somewhere, >>that has access to enough current to pop the fuse<< is sucking too much current. To tell where the current is going, the simplest thing for a neophyte to do is to temporarily open the wire that carries the current and see if the fuse blows again. Yes, there are better ways involving current meters and light bulb limiters, but that's more sophisticated than people who are mystified by fuses the first time get. Opening a wire and using up a box of fuses to test is simpler, if more expensive.

                      The process goes like this: get an accurate(ish) schematic so you can tell what parts have access through wires to high currents from the power supply. Then start at the AC wall socket work your way into the amp along the power distribution network, seeing what stops the fuse from blowing when you open that wire.

                      So:
                      1. If it has an IEC power cable, disconnect it from the amp and plug it into the wall. Did the wall socket breaker pop? Sure, this is unlikely, but there have been known to exist faulty IEC cables. If so, you get to quit early.
                      2. If not the IEC cable, or if the amp has a hard wired cable, temporarily desolder the power transformer primary wires. Both of them. Put in a good fuse, plug the amp into the wall socket, flip the power switch on and off again, and unplug the power cable. Did the fuse blow? If yes, there is at least one fault in the AC mains wiring in the amp. Find it and fix it. If not ....
                      3. Reconnect the power transformer primary wires, and disconnect all of the PT secondary leads, safely taping/isolating them so they don't contact you or the chassis. Make sure there is a good fuse in, plug the AC cord into the wall, flip the power switch on and off, unplug the AC cable, then check the fuse. If the fuse blew, and you really, really did isolate the secondary windings, you have a bad power transformer, either with an internal short or you really didn't disconnect the secondaries. If the fuse didn't blow, take this opportunity to use your meter set to AC volts and check the AC secondary voltages. They're probably fine, but this will tell you if they're open. If the fuse did not blow and your secondaries have good-ish voltages, power off, disconnect the AC line cord and reconnect the low power secondary if the amp has one.
                      4. Plug back in, power on and off, check the fuse. If the fuse is good, that secondary isn't causing it to blow. On tube amps, this would best be the heater windings. On SS amps, it's best to test the low voltage/preamp winding on this round. If all is well, check the voltages from this winding, including any DC voltlages. If the fuse didn't blow, they're probably OK, but check anyway. If no trouble found, power off and disconnect the wall plug.
                      5. Reconnect the main power secondary to the rectifiers, but temporarily disconnect the rectifiers from the main power filter caps. Plug back in, power on, power off, check the fuse. If the fuse popped, it must be the rectifiers you just added. If not, unplug, reconnect the rectifiers to the first filter cap(s), disconnect the filter cap(s) from any secondary load, plug in, turn on, turn off, check the fuse. If the fuse popped, it was the cap(s) - or the wiring to them. If not,
                      6. On a SS amps, remove the output transistors or temporarily disconnect them. reconnect the filter caps. Plug in, turn on, turn off, check the fuse. If the fuse popped, it was something connected to the main filter caps but not the output transistors. If not...
                      7. Check the power transistors and drivers for shorted and open with your DMM. If any are shorted or open, replace them all. Don't go ordering and replacing one of a set. There are reasons for this.
                      8. If the transistors are OK by DMM, short the bias network. Bias networks in SS amps are designed to add a little forward bias to the outputs to eliminate crossover distortion. At this point, you don't care if there is crossover, only that it doesn't pop fuses. In a standard SS amp, an open crossover bias network can kill the output transistors and pop fuses.
                      9.Now put in ONLY the first stage that provides a complementary follower to the output, leaving out the main output transistors. A SS amp will work fine into an open load with only the very first followers in the output stage. With the bias shorted and only the minimum outputs, and an open load, plug in, turn on, turn off, and check the fuse. The fuse should not blow unless there is a severe issue inside the power amp. If it does not blow, apply signal to the amp and watch the output (into an open circuit, again) and see that it does or does not amplify, even with severe crossover distortion.
                      If this does not happen, you need to dig through the power amp.
                      10. If all this looks good, replace the outputs and see if the thing works into an open circuit with a shorted bias network, albeit with a lot of crossover distortion. If this works, the bias network is probably the culprit.

                      There are many other things that can go wrong, but this process will get the vast majority of issues isolated down to a place where you can debug it.
                      Amazing!! Who would ever have guessed that someone who villified the evil rich people would begin happily accepting their millions in speaking fees!

                      Oh, wait! That sounds familiar, somehow.

                      Comment


                      • #12
                        Originally posted by vintagekiki View Post
                        Test each transistor with the multimeter in the circuit or removed from the circuit.
                        How to Test a Transistor & a Diode with a Multimeter

                        https://www.instructables.com/id/How-to-test-Bipolar-Transistors-if-you-have-an-Ana/

                        https://www.mikroe.com/ebooks/components-of-electronic-devices/diodes-and-transistors

                        https://www.scribd.com/doc/34162981/Transistor-Test-Using-an-Analogue-Multi-Meter

                        https://www.electronics-notes.com/articles/test-methods/meters/multimeter-diode-transistor-test.php

                        http://120studio.com/tech/transistors.htm

                        When replacing the output transistors, it is necessary to clean the heatsink and insulating washer from the old thermally conductive paste with a some solvent on a nitro base.
                        In order to better cool the transistors, apply to the insulating washer fresh thermally conductive paste on both sides.

                        When replacing the output transistors, it is recommended to replace his emitter resistor (1 Ohm / 5W) no matter what looks nice and healthy.

                        https://rimstar.org/equip/mount_transistor_heatsink.htm
                        Mounting a transistor to heatsink

                        https://www.youtube.com/watch?v=hNRacVQRgBc
                        How to mount/attach transistor to heatsink

                        I'm not old-fashioned, but the ohmmeter in the analog multimeter 20 kohm/V (with pointers) best proved for a semiconductor test in the circuit.
                        Measurement with ohmmeter (measurement range x10 or x100) can detect a faulty semiconductor in a circuit without desoldering.
                        If you have a 2 some amplifier with the same part number PCB, simply compare the same semiconductor in the same conditions in the correct and in the faulty amplifier.

                        Warning.
                        Disconnect amplifier from the AC outlet.

                        When any measuring with ohmmetar, amplifier must be disconnect from the AC outlet.
                        When desolder any component, the amplifier must be disconnect from the AC outlet.
                        Last edited by vintagekiki; 07-24-2019, 07:39 AM.
                        Who does not know and knows that he does not know - teach him Confucius)
                        Who knows and does not know that he knows - wake him Confucius)

                        Comment


                        • #13
                          Thanks so much for the responses and tutorials. I seem to be learning something here

                          Ok so I've tested the power transistors, Q1,2,3,4. I disconnected one from the socket, and removed the screws holding it in, and completely removed it. I then saw I could just pull the sockets and test them without completely removing them, as they are isolated via the fitted wafer insulated washer, and plastic insulators for the screws.

                          I found that on the two outside transistors, the emitter was shorted to the collector(case), as there was continuity with my DMM.
                          I also tested them on the diode setting, and the ones that were shorted read a bit under 400mV, and the other 1.3mV, while the ones that did not read shorted were at 485mV
                          So I certainly need to replace(from what I understand), all of them, as well as the 1R 5W ballast resistors.

                          Can someone suggest what I should purchase, and where, for the 36892 transistor. I'm assuming that exact one is not made anymore.

                          To test the drivers, do I need to remove them, or can I do the same type tests from the back of the board? Also, I'm assuming 38736 x 2 ,38737 x 2 , are the drivers . Why the different part #s?

                          Comment


                          • #14
                            The amp uses +/- 40V power supplies, total of 80V. Use devices rated for at least twice that, 160V, preferably more.

                            A good, safe choice would be the On Semi MJ15022 or MJ15024. There are others. These are in the TO-3 metal case, right?

                            Be sure to get replacements NOT from ebay, as counterfeits are rampant. Do test the drivers, as early SS amps often did a chain of destruction from the outputs way back into the amp. Remove them from the PCB to test them. It's easy to get confusing results with them in circuit. The driver part numbers are different because two are NPNs, two are PNPs. This let the maker use all NPN outputs in a quasi-complementary circuit.
                            Amazing!! Who would ever have guessed that someone who villified the evil rich people would begin happily accepting their millions in speaking fees!

                            Oh, wait! That sounds familiar, somehow.

                            Comment


                            • #15
                              Kustom Semiconductor Replacements

                              http://bee.mif.pg.gda.pl/ciasteczkowypotwor/SM_scena/Inne/Kustom%20Semiconductor%20Information%202.pdf
                              Kustom Semiconductor Information 2

                              http://www.vintagekustom.com/literature/Tech/MemoList.html
                              Kustom Service Memos

                              https://docs.google.com/file/d/0B1FxxpOmGO8vMGRHbzBlenNtYUE/edit
                              Service Note (PC504, PC703, PC900)

                              https://docs.google.com/file/d/0B1FxxpOmGO8vRnB4a2IxZXhCeDQ/edit
                              Transistor Substitute Guide

                              http://www.vintagekustom.com/FUDforum/index.php?t=thread&frm_id=3
                              Replacement Part Suggestions

                              http://www.vintagekustom.com/FUDforum/index.php?t=msg&th=1612
                              Kustom Semiconductor Replacements

                              https://music-electronics-forum.com/showthread.php?t=29847
                              Substitute for RCA36892

                              http://www.vintagekustom.com/FUDforum2/
                              Vintage Kustom Forum

                              https://irationaudio.com/2015/03/26/193/
                              Kustom K100-1

                              https://groupdiy.com/index.php?topic=57282.0
                              Kustom 300 PA*

                              http://www.vintagekustom.com/FUDforum2/index.php?t=rview&goto=18516&th=3251
                              Kustom 400 transistor help*

                              * Replacement driver transistors
                              Last edited by vintagekiki; 07-28-2019, 02:36 AM.
                              Who does not know and knows that he does not know - teach him Confucius)
                              Who knows and does not know that he knows - wake him Confucius)

                              Comment

                              Working...
                              X