Announcement

Collapse
No announcement yet.

Kustom HV30 - Tapping the control panel causes pops

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • nevetslab
    replied
    The characteristics you describe are indeed common, and we all encounter them on a regular basis. Those usually take time to develop, though production flaws and poor quality control can release such defects in new products as well. Solder Joint Factures seem to be what I spend 70% of my time chasing and repairing. Some are easy to find (look at my avatar....surgical head light, surgical loupes find them). Lead Free Solder can hide them within what appears to be good solder joints, yet pounding on the top of an amp can envoke the pops and snits, so it does take a lot of patience and care searching for them without getting shocked in the process. And, of course, not every product is designed for ease of service which has such problems. Welcome aboard!

    Leave a comment:


  • Enzo
    replied
    I find a wooden chopstick, free with most Chinese food orders, makes a darn good insulated "probe" for this.

    Leave a comment:


  • J M Fahey
    replied
    It does not sound like a design or manufacturing defect at all (it would be making that from day 1) , rather amp taking one too many bumps along its life or fallling flat on its face from a certain height (a chair?) or similar , which might crack a pot, solder, break a wire, unseat something (a tube?), etc.

    I understand people's *hopes* to find somebody with the exact same problem who answers something like: "oh, that? ... replace C47 (or whatever), they always break the leg soldered to ground" .... sadly that almost never happens.
    Not impossible, but almost, statistically speaking.

    Gross design problems DO exist, say using a 2W resistor where it will actually dissipate 5W so it won´t last long, underrating an Electrolytic so it quickly vents or bursts, etc. but in general competent Designers don´t make such mistakes and in any case they typically raise their ugly head along product development (which can easily take upto 1 year ) and are corrected.

    Yours looks like mechanical damage after it left the factory and that is as random and unpredictable event as can be.

    Get an insulated device such as a BIC ballpoint pen and tap it **everywhere** and I mean it, component by component (not kidding), wire by wire, joint by joint, including all pot legs, jacks, etc.; you WILL find it.

    IF that amp uses a PCB, also push PCB down all over the place, if you have a tiny invisible crack on a trace/track , slight flexion will separate its edges along the crack, which are just touching, and if there is DC involved you will have a loud thump.

    Patience (and Jeweller´s loupe) are your friends.

    Click image for larger version  Name:	LOUPE01.jpg?20200711031555.jpg Views:	0 Size:	34.8 KB ID:	938026

    Offering 3 times magnification and ideal for working on PC boards, hobby and jewellery.

    Leave a comment:


  • TimeBandit
    replied
    I understand where you're coming from. My perspective comes more from my experience repairing vintage home audio gear where a symptom like this which, while not occurring in every unit, might have appeared in enough that a design or manufacturing fault has been identified by others that have come before. I've found that asking up front if such a situation exists can be a valuable time saver in the diagnostic process.

    Leave a comment:


  • Enzo
    replied
    I understand, but even past the generics, it is unlikely every amp of this model will have the exact same thing wrong with it for this symptom.

    Leave a comment:


  • TimeBandit
    replied
    Ha, yes, I suppose it isn't that uncommon of a symptom, is it? Thanks for the reality check. That said, I was interested more in whether people who have experience with this particular amp (or the board it uses) have discovered any causes asides from the solder joints I noted. The tip about the pots is appreciated Enzo.

    Leave a comment:


  • Enzo
    replied
    Anyone else ever see amps with bad connections that make noise when tapped? Why yes, yes we have. COuld also be a cracked pot wafer somewhere.

    Leave a comment:


  • Kustom HV30 - Tapping the control panel causes pops

    First time poster here. I haven't worked on many guitar amps, and definitely no Kustom hybrids like the HV30. The symptom: Moderate taps to the control panel (near the middle) causes loud distorted pops that sound like DC through the speaker. My first thought was one or more cold or cracked solder joints, so I removed the board to examine it. Well, there are definitely a lot of poor joints, including some on the component side that are barely filled. But before I go any further I'd thought I'd join this forum and see if anyone else has come across this issue.

    P.S. I haven't found a schematic yet, so if anyone can point me in the right direction, I'd appreciate it.
Working...
X