No announcement yet.

5150 evh fuse F3 f4

  • Filter
  • Time
  • Show
Clear All
new posts

  • 5150 evh fuse F3 f4

    Hi at all,
    hi have one head Peavey 5150 block letter "old"...

    ​​​​​​​It does not work anymore
    fuses f3 and f4 blow.
    also I don't hear the relays working ..
    I replaced the preamp tubes ... but nothing.

    i found r47 and r49 burnt and then the amplifier turned on the red and green leds but no sound ..
    just replaced r47 and r49, fuses f3 and f4 blow.
    power tubes come on ...
    i can't hear signal using return, because relay switches don't go ....
    help please.
    Thank you

  • #2
    I add that,
    yesterday after replacing r47 and r49, all tubes on!
    but only hum sound ..
    channel change relays etc do not work..
    today , turn on and fuses ko!!

    thank you
    Last edited by Blosterc; 09-17-2021, 12:09 PM.


    • #3
      F3, F4 blow? Those serve the 24v supplies. WHat is blowing the fuses? Start at the rectifier diodes those fuses serve. Possibly bad filter cap on one of those supplis.
      Education is what you're left with after you have forgotten what you have learned.


      • #4
        Hi, thanks for reply!
        OK, i check all diodes.
        Please wich filter caps?


        • #5
          Click image for larger version

Name:	Screenshot 2021-09-17 at 18.58.43.png
Views:	275
Size:	210.4 KB
ID:	941543
          Support for Fender, Marshall, Mesa, VOX and many more.


          • #6
            thank you very much!
            Now i check


            • #7
              the diodes all ok ..
              I measured the whole track preamp from FIL to FILI ..with the tester... I measured about 55 ohm .. (13/14 per tube)
              and I noticed that the c9 1000uF 35v it swelled ...

              so, without r49 R47, all led on(on, stand by, channel 1 and channel2), but no switch relays work and no soud
              with r49 r47, fuse f3 and f4 blow.
              thank you


              • #8
                Jon, he has the 5150 not the 5150 Combo. But the parts you point out would be the equivalents

                Without R47,49, the preamp tubes won't light and there will be no sound.

                I doubt the tubes themselves are harming things. You found C9 swollen. TAKE IT OUT. The two resistors are burning because of a unwanted path to ground somewhere, and C9 is connected from FIL string to ground and could well be your problem. It needs replacement at some point, but with it removed the amp should function. See if it helps.

                Your problem is the blowing fuses. Until that is solved the LEDs and relays will not work and you won't get sound. All those things rely on the power supply with the blowing fuses.
                Education is what you're left with after you have forgotten what you have learned.


                • #9
                  ok I try to remove the cap.
                  so, i try to work without a cap?
                  Thank you


                  • #10
                    Hi, i have replaced the cap...
                    yes it work! (I have only try with signal radio)
                    relays ok.. switch channel ok..
                    But i have some Light hum ... And
                    New problem.. while i was trying volumes ecc.. the rhythm post pot, is burned (flame)...
                    Also usual two fuse f3 and F4...
                    some idea?

                    But It sound !
                    I'm happy to have a signal!!!
                    thank you


                    • #11
                      I see n way for either post control to burn up, unless you have a ribbon cable plugged onto pins one pin off to one side.
                      Education is what you're left with after you have forgotten what you have learned.


                      • #12
                        unfortunately, the rytm post potentiometer made a flame .. then the usual two fuses are blown .. i tried with another pot (i thought it was bad) but it burns that too..but it wasn't 1m ohm ... it was pot guitar about 700k ..
                        no ribbon cable plugged off to one side..


                        • #13
                          but there is hum that wasn't there before ... could it be related to the potentiometer problem?

                          I add that even cap c64 seems inflated .. I replace it


                          • #14
                            I'm thinking now ...if didn't mount the original potentiometer but the very cheap one,
                            can't stand the power?

                            is it possible to turn on amp without that pot?
                            just to try?
                            Thank you


                            • #15
                              There is no "power" going through the post control. Any voltage/current that is enough to burn up that control is coming from somewhere.. You might have a small solder blob or something that is connecting two copper traces together where they do not belong. This wouldn't show in the schematic, but on the board maybe a high voltage trace runs next to a trace to the pot.

                              Yes, of course you can turn on the amp without that pot. It is just a volume control, not a power switch. Then you could measure voltage on the three points where the pot had been soldered in. That might be a clue as to where it comes from.
                              Education is what you're left with after you have forgotten what you have learned.