Announcement

Collapse
No announcement yet.

Roland Super Cube 60 Squeal Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    How would a TRS jack work? There is no switch on it and only 3 lugs.

    Comment


    • #17
      What about something like this? https://www.parts-express.com/Rean-N...oaAs_UEALw_wcB

      Comment


      • #18
        Originally posted by Helmholtz View Post
        A single switch version is available from the same supplier, search the website.
        Found it, but not the right fit either.

        Looks like I need to home-brew a solution. Right now I have the original jack back in there. It works with two exceptions. It makes a horrible pop noise when inserting the cable. Once inserted it is okay but if the plug moves the awful squeal comes back.

        Comment


        • #19
          Originally posted by misterc57 View Post
          Yes, that's what I meant, a TRS with switch contacts. I'll try to draw something up.

          I guess you cleaned out the original and checked for any bent or damaged contacts?

          Comment


          • #20
            Originally posted by g1 View Post

            Yes, that's what I meant, a TRS with switch contacts. I'll try to draw something up.

            I guess you cleaned out the original and checked for any bent or damaged contacts?
            I cleaned and inspected it. I cannot get access to any contacts to bend due to its housing.

            I am trying to understand the switching on the Drive jack; In the schematic the tip (5) looks un-switched. Pin (2) and (3) is the only switching, with one or the other to ground?

            A TRS jack drawing would be great!

            Thank you

            Click image for larger version  Name:	scl-60-schem.png Views:	0 Size:	218.0 KB ID:	953622

            Comment


            • #21
              Yes, the tip of drive jack is non-switched.
              I hope this will do it. The schematic shows different grounds for the switch part and the jack, but I think this will work.

              Click image for larger version

Name:	scl jack.jpg
Views:	80
Size:	37.4 KB
ID:	953641

              Comment


              • #22
                Originally posted by g1 View Post
                Yes, the tip of drive jack is non-switched.
                I hope this will do it. The schematic shows different grounds for the switch part and the jack, but I think this will work.

                Click image for larger version

Name:	scl jack.jpg
Views:	80
Size:	37.4 KB
ID:	953641
                Interesting. I will order the jack and get back with the results. May be a couple weeks.

                Thank you!

                Comment


                • #23
                  Make sure you purchase the correct jack sockets!
                  They have extra contact switching on the 'drive' socket.
                  Support for Fender, Laney, Marshall, Mesa, VOX and many more. https://jonsnell.co.uk
                  If you can't fix it, I probably can.

                  Comment


                  • #24
                    Originally posted by Jon Snell View Post
                    Make sure you purchase the correct jack sockets!
                    They have extra contact switching on the 'drive' socket.
                    The method I suggested in post #21 relies on the 'natural' action of a mono plug shorting together the ring and sleeve of a TRS jack.
                    If someone decided to try it with a TRS cable, it would not work right.

                    In this particular case, the original 'normal' jack is remaining in use, and the cliff style jack is replacing the 'drive' jack.

                    Comment


                    • #25
                      Originally posted by g1 View Post
                      Yes, the tip of drive jack is non-switched.
                      I hope this will do it. The schematic shows different grounds for the switch part and the jack, but I think this will work.

                      Click image for larger version  Name:	scl jack.jpg Views:	49 Size:	37.4 KB ID:	953641
                      I finally got the jack and tried this but it did not work.

                      When I turn on the amp (volume at zero) there is a different very loud horn sound. If I plug in a guitar, there is a different loud buzz sound. Both of these sounds will knock you out of your chair.

                      Now that I have the new 6 pin jack it will be quick to try more configuration suggestions. I am hopeful that something will work.

                      On the input jack board I removed the drive jack #2 and soldered a wire to pins 5 for the drive, and pins 2 and 3 for the switching. It is quick to clip jumpers from these wires to the new jack.

                      Pin 1 is ground and is jumped to the new input jack.

                      Thank you

                      Comment


                      • #26
                        I mounted J1 to the panel and now have no more squeal. However the drive plug signal is not working.

                        The tip pin 5 is 133K to ground with cable inserted and also not inserted.

                        Comment


                        • #27
                          Can you post some pics? Did you use the exact Neutrik Rean NYS212 ?

                          Comment


                          • #28
                            Right now it is a spaghetti of clipped wires, I must have had a bad contact as it is now working per g1 wiring diagram. Yay!

                            I will solder it up and send pics of the finished work.

                            Thank you!

                            Comment


                            • #29
                              Working great! Thank you

                              Click image for larger version

Name:	IMG_20220927_093521508.jpg
Views:	38
Size:	435.4 KB
ID:	969617 Click image for larger version

Name:	IMG_20220927_093514685.jpg
Views:	32
Size:	709.6 KB
ID:	969618

                              Comment

                              Working...
                              X