Announcement

Collapse
No announcement yet.

Kalamazoo Model 2 cathode bypass problems - hiss and MORE hum!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kalamazoo Model 2 cathode bypass problems - hiss and MORE hum!!!

    I just bought a Kalamazoo Model 2 recently and have been slowly going through it. First I swapped out the two prong for a grounded three prong plug, moved the fuse to where the old plug hole was in the back and added a power switch to the front panel. Worked great. Then I went through the input jacks and fixed the issue of all of the resistors being wired straight to the 12AX7 pins causing serious stress and snap crackle pops. Definite MUST for these as the front panel flexes so much.

    There is a bit of hum that's always there. When not plugged in to either input the hum is the same no matter if the volume pot is at 0 or 10. It's not too annoying though and I'm OK with it. On 10 no other sounds but the hum. I still haven't replaced the filter caps yet, but I did try to add cathode bypass caps across the power tube and pin 8 of the 12ax7. Straight away I noticed a huge difference in overall volume early on, definitely more gain. But that hum is now LOUDER than before and when I turn the volume up to between 8 and 10 there is a noticeable hissing noise. The bypass caps I used are Mallory 25//25 caps I had pulled from a silverface Bassman someone had failed at making into a Twin like head. I checked the capacitance and they were both between 23 and 25. The polarity on each cap was correct and I even second guessed myself and switched them around, same thing. Took them out of the circuit, back to before. Alligator clipped just the power tube cap, hiss there more hum. Alligator clipped just the 12AX7, hiss there more hum. What could it be? Do you think it's the caps I am using? Is the hum that's always there just getting louder with the cathode bypass mods on account of the increase in bass frequencies?

  • #2
    See if there is a humdinger added, or a ct on the heater winding. A humding pot, with wiper to 0V is an easy mod.

    You could temporarily add an extra capacitor to the screen supply to see if that is significant. Likely to need a new cap for the main B+ cap off the rectifier, as that cap gets the hardest life.

    Do you have shorting input jacks or input plugs - if not then the 12AX7 grid may be floating.

    Comment


    • #3
      This is a Gibson amp.
      Rule #1. The filter caps are bad.

      Comment


      • #4
        Originally posted by Sweetfinger View Post
        This is a Gibson amp.
        Rule #1. The filter caps are bad.
        Easy enough to rule out that diagnosis.
        Measure the Vac ripple on the B+ rail.
        Last edited by Jazz P Bass; 01-07-2012, 03:32 PM.

        Comment


        • #5
          First, you have an ANCIENT amplifier, it hums, and you have not yet changed the filter caps? SO change the filter caps. Now how much hum remains?

          Do some general reading on cathode bypass caps, and aside from other things and simplifying, they tend to increase the gain of the bypassed stage, and boost the bottom end. SO now with those parts added, you have more hum, which is bottom end noise, and you have more hiss, which is wide range noise, but in particular higher end. Hiss is a common byproduct of gain.

          I would be surprised if you did not get those results.
          Education is what you're left with after you have forgotten what you have learned.

          Comment


          • #6
            Originally posted by Sweetfinger View Post
            This is a Gibson amp.
            Rule #1. The filter caps are bad.
            Ha ha...
            Bruce

            Mission Amps
            Denver, CO. 80022
            www.missionamps.com
            303-955-2412

            Comment

            Working...
            X