Announcement

Collapse
No announcement yet.

QSC K12.2 repair

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • QSC K12.2 repair

    Symptoms: All 3 signal LEDs light up with the display and then cycles off about every 5 sec. What I found: F1 blown, Q16 shorted, D36, D20, D37, D29 D15 tested bad and all replaced. 15v rails 5v rails and 12 VLOW all there. But thing keeps cycling no difference. Im stumped. any advice?

  • #2
    This came after I closed my QSC authorized shop/ Do you have the schematics for us? I have no idea what or where Q16 D36 and so on might be. You report your low voltage supplies are present, but you don't mention the main rails. Your description sounds to me like an SMPS trying to start. Two things cause that. One is a problem in the SMPS itself, and the other is excess load on it, most likely a shorted output transistor.
    Education is what you're left with after you have forgotten what you have learned.

    Comment


    • #3
      Check this. I've seen several with this problem.

      Click image for larger version  Name:	QSC-Capacitor.jpg Views:	0 Size:	169.4 KB ID:	961036
      "Yeah, well, you know, that's just, like, your opinion, man."

      Comment


      • #4
        Dude thats the K12 Im posting about the K12.2

        Comment


        • #5
          Here's a repair manual at this site. yes I have the big rails and all the OP mosfets test good. https://adjuntos.yoreparo.com/defaul...93137e1102.pdf

          Comment


          • #6
            This has nothing to do with MY repair but evidently this unit needs a firmware upgrade to prevent low end speaker damage. https://www.youtube.com/watch?v=wHKz8mU62x0&t=308s

            Comment


            • #7
              official firmware update from QSC https://www.qsc.com/solutions-produc...s/k2-firmware/

              Comment

              Working...
              X