Announcement

Collapse
No announcement yet.

Boss DR-55 Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Boss DR-55 Problems

    I have a boss DR-55 which only outputs the hats.
    I have already replaced the TC4011UBP with a (socketed) CD4011BE, but that made no difference.
    So, as I see it, either it's not "recording" my programming (although it goes through the motions), or none of the sounds other than hats are being produced.
    I am aware that there is a difference between the UB and B variants of the 4011, so I've ordered a CD4011UBE to try that.

    Apart from that, is there anything obvious I should be looking at.

    I have documented what I've done so far, here: https://synteknik.com/projects/curre...dr-55-project/

    Any help or suggestions gratefully received!

  • #2
    You didn't mention it, but there is a scan of the service manual on your web site, which you linked. Kinda hazy but better than nothing.

    You get high hats but not the others? First the service manual has a good theory of operation section which explains it pretty well, plus the block diagram. But to isolate the problem, does the start/stop switch function? Does it make the hi hats stop and go? If so, then the flip flop is working, and that is your 4011. Also, does the tempo control affect the speed of the hi hats?

    As to the other sounds, they are all triggered from the memory chip, so are there output pulses from pins 12, 14, 16 of that IC? If not, then the voice circuits won't make sound.

    Since you do get hi hats, I assume the noise generator is working.

    If there are control pulses leaving the memory, look at each sound output transistor for signal. Those mostly have to run through the accent circuit, so if it has an issue, you might lose them.

    Someplace to start anyway.
    Education is what you're left with after you have forgotten what you have learned.

    Comment


    • #3
      https://www.google.com/url?sa=t&rct=...uSl4zEoZTfBLHR

      This is somewhat cleaner.
      Education is what you're left with after you have forgotten what you have learned.

      Comment


      • #4
        Originally posted by Enzo View Post
        You didn't mention it, but there is a scan of the service manual on your web site, which you linked. Kinda hazy but better than nothing.

        You get high hats but not the others? First the service manual has a good theory of operation section which explains it pretty well, plus the block diagram. But to isolate the problem, does the start/stop switch function? Does it make the hi hats stop and go? If so, then the flip flop is working, and that is your 4011. Also, does the tempo control affect the speed of the hi hats?

        As to the other sounds, they are all triggered from the memory chip, so are there output pulses from pins 12, 14, 16 of that IC? If not, then the voice circuits won't make sound.

        Since you do get hi hats, I assume the noise generator is working.

        If there are control pulses leaving the memory, look at each sound output transistor for signal. Those mostly have to run through the accent circuit, so if it has an issue, you might lose them.

        Someplace to start anyway.
        Thanks, Enzo!
        The start/stop works ok, and makes the hats start/stop. Tempo also works.
        I will check the outputs from the memory chip, then the accent circuit. Hopefully, I can do that with a simple multimeter..

        (The memory chip was already next on my hit list)

        Comment


        • #5
          Originally posted by Enzo View Post
          Thanks! Much better..

          Comment


          • #6
            Originally posted by Enzo View Post
            You didn't mention it, but there is a scan of the service manual on your web site, which you linked. Kinda hazy but better than nothing.

            You get high hats but not the others? First the service manual has a good theory of operation section which explains it pretty well, plus the block diagram. But to isolate the problem, does the start/stop switch function? Does it make the hi hats stop and go? If so, then the flip flop is working, and that is your 4011. Also, does the tempo control affect the speed of the hi hats?

            As to the other sounds, they are all triggered from the memory chip, so are there output pulses from pins 12, 14, 16 of that IC? If not, then the voice circuits won't make sound.

            Since you do get hi hats, I assume the noise generator is working.

            If there are control pulses leaving the memory, look at each sound output transistor for signal. Those mostly have to run through the accent circuit, so if it has an issue, you might lose them.

            Someplace to start anyway.
            Ok. There's nothing on those pins. I get pulses on 3,4,5,6, and 17&20 on the other side. Looks like a dead chip?
            (I have some on order, but they'll take a while to get here..)

            Comment


            • #7
              Hmm. What if I poke say 5v into the voice circuits? Would I be able to test them that way? Not sure where to do that, though.. I just wanna hear the bloody kick and snare FFS!

              Comment


              • #8
                Originally posted by SynTeknik View Post
                Ok. There's nothing on those pins. I get pulses on 3,4,5,6, and 17&20 on the other side. Looks like a dead chip?
                (I have some on order, but they'll take a while to get here..)
                I ordered another chip, from Holland, not China, and installed it last night. The DR-55 now works 100%. I've spent a really fun hour manually entering patterns. It's great!
                Many thanks to Enzo for the spot-on diagnostics.
                You can read the full story here:
                https://synteknik.com/projects/boss-...ent-tc5501p-2/
                The problem turned out to be two corroded legs on the TC5501P. How the hell? One of them snapped off on removal.. the replacement chip got stood on in transit. Looks like a size 9 doc marten print on the envelope, so I had to straighten the legs before insertion..

                Comment

                antalya escort
                kartal escort
                sex vidio
                altyaz?l? porno
                antalya escort
                beylikduzu eskort bayan eskort bayan escort antalya sirinevler bayan escort
                Working...
                X