Announcement

Collapse
No announcement yet.

Another Marshall valvestate 8004 blowing up Tda1514's

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 888guitars
    replied
    I have blown up 2 TdA's from China. I now ordered one from a USA supplier that is a confirmed Phillips. We shall see.

    The weird thing I am seeing is the volt drop across R2 on channel A is about 8 volts and the drop on R3 is only 2 volts? I replaced r3 and still same 2 volt drop....?

    Leave a comment:


  • Jazz P Bass
    replied
    I am confused as to the question of what is wrong.

    The OP stated that "One side of the amp ( left/chan A) works. But the other is whacked."

    The power supply is common to both TDA1514's, is it not?

    I would also like to know where the OP is going to find a non- bogus TDA1514.
    Last edited by Jazz P Bass; 04-15-2018, 12:32 AM.

    Leave a comment:


  • The Dude
    replied
    Check the AC voltage across the cap. If it's not doing it's job, there will be ripple/AC there. If the supply is clean, no need to replace it. One side of each zener is ground, so yes there will be zero volts on one side of each. It's the other side you need to measure. If there's 27 volts there, no need to change that either. There's no need to shotgun it. Troubleshoot your way through the supply and figure out what's wrong with it.

    Leave a comment:


  • 888guitars
    replied
    Yes the TDA is pulled out.My meter won't read 2200 uf. Maybe c12 is bad? I will just replace him. The Zener must be bad , I will double check the voltage drop when I get back to the bench tomorrow. I do remember seeing zero volts on one side of the diode?

    Leave a comment:


  • The Dude
    replied
    Do you measure any AC on the low rail? You might have a bad filter cap. Do you have the shorted TDA or TDA's removed? If one is defective, it might load down a rail. If you suspect a zener is bad, measure the voltage drop across it. It should be around 27VDC. Are either TR1 or TR2 shorted?

    Edit: Also check that C12 &13 are soldered in well- no cold/cracked joints.
    Last edited by The Dude; 04-14-2018, 03:04 AM.

    Leave a comment:


  • 888guitars
    replied
    Oops. I thought I did 😏

    Leave a comment:


  • The Dude
    replied
    It's a good idea to post a schematic or schematic link when you start a thread so we know what you're talking about.

    http://www.thetubestore.com/lib/thet...-Schematic.pdf

    Leave a comment:


  • Another Marshall valvestate 8004 blowing up Tda1514's

    I just need a bit of help with a Zener question. As I wait for parts, I can't get the two rails to match. One side of the amp ( left/chan A) works. But the other is whacked. I did replace TR2 but still have too much of a voltage difference on either side of c4 and c6. They should be similar right? Well one is negative. But I see 27v on A side and -34 on B side. Is ZD2 most likely the culprit of not dropping enough?
Working...
X