Announcement

Collapse
No announcement yet.

PRS Sonzera 20 Low distorted volume - Pots don't seem to work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PRS Sonzera 20 Low distorted volume - Pots don't seem to work

    Starting another PRS Sonzera 20 post as the symptoms are different than the title of the last thread that I started.
    If amp has low distorted volume and even injecting a signal directly into the return jack isn't good.
    The two mosfets Q1 and Q2 are the culprits. Even just plain weird issues like the reverb pot on channel 2 acts like a second volume pot for that channel can be these two mosfets. Both #IRF820. I used 844-IRF820APBF from Mouser. They're very inexpensive. Under $2.00ea.

    Since there is no full schematic for this little bugger nad it was pretty difficult to draw just this section to determine that these two mosfets actually pass signal.
    I originally thought they were some kind of voltage regulators as they both have very high voltages on their Drains and voltages around 6 - 10V on the Source & Gate.

    Here are the nominal normal voltages these guys should have (all dc of course):
    Q1: G-12.66v D:290.00V S:9.66v
    Q2: G:2.8v D:176.00v S:6.1v

    They are situated around the send return jacks in the schematic so that's probably why I couldn't inject a signal into the return jack and bypass them.

    Just a few tidbits for these PRS amps. glen

  • #2
    Looks pretty interesting to me. Straightforward, nothing too fancy amp. The Archon's cleans were pretty nice considering it wasn't really built for that, so I was curious how a cleaner voiced amp from PRS would sound. $799 for 20w Combo and $899 for 50w Combo isn't bad either (though 57lbs for the 50w is a bit heavy. Archon 50 is about 10lbs lighter i think)

    Comment


    • #3
      I finally purchased a tube amp for Christmas, the PRS Sonzera 20 combo, and I noticed that it makes a faint white noise even though nothing is plugged into it. I know that tube amps are analog technology, and Speed Test that this noise may be coming from the tubes themselves, but I'm not sure if this is normal.

      Comment


      • #4
        Originally posted by novabell View Post
        I finally purchased a tube amp for Christmas, the PRS Sonzera 20 combo, and I noticed that it makes a faint white noise even though nothing is plugged into it. I know that tube amps are analog technology, and Speed Test that this noise may be coming from the tubes themselves, but I'm not sure if this is normal.
        How was shipping to algeria?

        nosaj
        When I die I want to go quietly in my sleep like my grandpa did. Not kicking and screaming like the passengers in his car.

        Comment


        • #5
          Originally posted by novabell View Post
          I finally purchased a tube amp for Christmas, the PRS Sonzera 20 combo, and I noticed that it makes a faint white noise even though nothing is plugged into it. I know that tube amps are analog technology, and Speed Test that this noise may be coming from the tubes themselves, but I'm not sure if this is normal.
          Fully normal.

          NO silent amp technology discovered yet.
          Juan Manuel Fahey

          Comment

          Working...
          X