Results 1 to 11 of 11

Thread: For Enzo PV Classic 30 repair dilemma

  1. #1
    Junior Member
    Join Date
    Mar 2009
    Posts
    10
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0

    For Enzo PV Classic 30 repair dilemma

    Hi Enzo--I got a C30 that I've had for about 12 years. Bought used. The entire time I've had it there has been a significant hum that stays constant regardless of whether the reverb is turned up or not. If I plug a dummy plug into the effects return the hum goes away. I've retubed--no difference. There is a loud pop about a half second after I turn it off.

    My question is this--This sound like the kind of problem that can eat up a lot of bench time. My dilemma is to invest in the repair at 75 bucks an hour or just find another C30 and have this as a backup. It works great other than the hum.

    thanks
    Randy

    0 Not allowed! Not allowed!

  2. #2
    Supporting Member tubeswell's Avatar
    Join Date
    Feb 2007
    Location
    Wellington NZ
    Posts
    4,138
    Blog Entries
    1
    Thumbs Up/Down
    Received: 50/0
    Given: 15/0
    Filter caps?

    0 Not allowed! Not allowed!
    Building a better world (one tube amp at a time)

    "I have never had to invoke a formula to fight oscillation in a guitar amp."- Enzo

  3. #3
    Junior Member
    Join Date
    Mar 2009
    Posts
    10
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    That was my first thought, but then I was confused by the fact that it goes away when plugging in a cable to the effects return. My somewhat marginally informed thinking was that if it was a filter cap problem it would be there in the output power stage too. I've heard of people doing filter cap upgrades to these amps. Is there a particular brand you would suggest?

    0 Not allowed! Not allowed!

  4. #4
    Supporting Member tubeswell's Avatar
    Join Date
    Feb 2007
    Location
    Wellington NZ
    Posts
    4,138
    Blog Entries
    1
    Thumbs Up/Down
    Received: 50/0
    Given: 15/0
    If its in the pre-amp section (suggested to me by your isolation trick with the FX jacks), it could be the pre-amp filter/decoupling cap C43 - This is the cap that decouples the B+ from the B++ on that schematic. It is a 22uF 450V cap. These decoupling caps isolate one part of the power rail from other parts of the power rail and absorb voltage fluctuations (that would otherwise occur in the power rail from normal operation of the relevant gain stages' plate resistors). When these caps start to go, it can induce hum, because these voltage fluctuations are not being removed thoroughly enough to keep the power rail constant.

    However if one filter cap is gone, then the chances are the others may not be far behind. Since the guts of the C30 is a little bit of a PITA to get at, I'd be inclined to replace all the electrolytics in the amp when it is opened up, for longer term peace of mind. JM2CW

    0 Not allowed! Not allowed!
    Building a better world (one tube amp at a time)

    "I have never had to invoke a formula to fight oscillation in a guitar amp."- Enzo

  5. #5
    Junior Member
    Join Date
    Mar 2009
    Posts
    10
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Thanks for your suggestions, Tubeswell. I guess I should just bite the bullet and do the whole series of mods I've been thinking about if I'm going to pull it apart. You sent me the schematic of your Soldano mods earlier and I've been thinking about that but I don't have a point of reference--I've never played through a Soldano. Here's where I'm aty currently with the amp. I've installed a cannibis rex hempcone and retubed with JJs except for V1 which is now a Tungsol. I think the amp sounds very sweet but I wish the OD channel sounds more like the clean channel for it's basic tone. There has to be some kind of voicing going on the OD channel because It's like a bandpass filter with a midrange bump. Chops of some lows and highs. Maybe this is necessary to get a smoother sounding OD--I dont know. How does the Soldano mod affect this characteristic? The SteveA tonestack mod is a given.

    0 Not allowed! Not allowed!

  6. #6
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    30,805
    Thumbs Up/Down
    Received: 723/4
    Given: 0/0
    You can do all the mods in the world, but if it is humming now, it will probably be humming after you are done modding too.


    Isolate the problem. Is it 60Hz hum or 120Hz hum? 120Hz hum is power supply ripple. 60Hz hum is everything else, like grounding problems, radiated hum, etc.

    I might look at C45,C46, they filter the -36VDC that the heaters run on.

    But here is my ace in the hole. Look on the schematic just above the power supply and right below the power tubes. See the two resistors grounded at each end? R61,62. Make sure one of those is not open. They are located just off the + end of C46. Here is the complete schematic that includes layoout in case your schematic lacks it.

    In circuit they will often read shorted, since the grounds they connect are bonded elsewhere.

    You mentioned the reverb control, but do any of the other controls have ANY effect on the hum? If they do, they are after its source.
    Attached Thumbnails Attached Thumbnails PV Classic 30.pdf  

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  7. #7
    Member
    Join Date
    Feb 2014
    Location
    New Jersey
    Posts
    43
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Quote Originally Posted by Enzo View Post
    You can do all the mods in the world, but if it is humming now, it will probably be humming after you are done modding too.


    Isolate the problem. Is it 60Hz hum or 120Hz hum? 120Hz hum is power supply ripple. 60Hz hum is everything else, like grounding problems, radiated hum, etc.

    I might look at C45,C46, they filter the -36VDC that the heaters run on.

    But here is my ace in the hole. Look on the schematic just above the power supply and right below the power tubes. See the two resistors grounded at each end? R61,62. Make sure one of those is not open. They are located just off the + end of C46. Here is the complete schematic that includes layoout in case your schematic lacks it.

    In circuit they will often read shorted, since the grounds they connect are bonded elsewhere.

    You mentioned the reverb control, but do any of the other controls have ANY effect on the hum? If they do, they are after its source.

    Yea, old thread, I know, but have to ask. Concerning R61-62, what's the difference between ground, circled ground, and "E"? Those two resistors are just hanging out there, what's their purpose?

    0 Not allowed! Not allowed!

  8. #8
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    12,385
    Thumbs Up/Down
    Received: 138/2
    Given: 43/0
    The resistors are not 'hanging' anywhere.

    The different "ground" symbols are used on the schematic because that is how the grounding scheme of the amp is wired.

    I read them as Circuit ground, Chassis ground & Earth ground. (ground, circled ground, and "E"? )

    As to your question :" Concerning R61-62, what's the difference between ground, circled ground, and "E"? "
    The difference is the individual value of the resistors: 47 ohms.

    0 Not allowed! Not allowed!

  9. #9
    Member
    Join Date
    Feb 2014
    Location
    New Jersey
    Posts
    43
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Quote Originally Posted by Jazz P Bass View Post
    The resistors are not 'hanging' anywhere.

    The different "ground" symbols are used on the schematic because that is how the grounding scheme of the amp is wired.

    I read them as Circuit ground, Chassis ground & Earth ground. (ground, circled ground, and "E"? )

    As to your question :" Concerning R61-62, what's the difference between ground, circled ground, and "E"? "
    The difference is the individual value of the resistors: 47 ohms.
    Got it, thanks

    0 Not allowed! Not allowed!

  10. #10
    Supporting Member eschertron's Avatar
    Join Date
    Aug 2012
    Location
    Great Black Swamp
    Posts
    1,861
    Thumbs Up/Down
    Received: 114/0
    Given: 281/1
    I believe it was explained to me (haven't searched for the thread, sorry) that 'ground' and 'circle ground' are shorted out by chassis fasteners while the unit is in service, but when disassembled for repair, the 47R resistor allows the input section to maintain its relationship with the signal ground. I'd wager a similar thing for the ground-to-earth connection. The 47R resistors are there to inhibit ground loop currents when the unit is fully assembled.

    It's one of those things that "eyes on" would explain in a heartbeat, but the schematic doesn't without appropriate engineering notes.

    0 Not allowed! Not allowed!
    If it still won't get loud enough, it's probably broken. - Steve Conner
    If the thing works, stop fixing it. - Enzo
    We need more chaos in music, in art... I'm here to make it. - Justin Thomas

  11. #11
    Supporting Member
    Join Date
    Feb 2007
    Location
    Seattle WA
    Posts
    351
    Thumbs Up/Down
    Received: 11/0
    Given: 2/0
    Could the hum be from a bad effects jack (J3) or cracked solder joints to that jack? If those jacks don't properly ground out there will be hum.

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hi there...and wiring problem/dilemma
    By razorcut in forum Music Electronics
    Replies: 6
    Last Post: 05-19-2009, 01:23 PM
  2. Goodmans Audiom 51 dilemma!
    By Le Basseur in forum Vintage Amps
    Replies: 5
    Last Post: 05-18-2009, 07:34 PM
  3. Repair/mod Q 1965 Deluxe Reverb dilemma
    By Wrongdog in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 12-20-2008, 02:08 PM
  4. Classic 20 repair manual
    By lmolter in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 05-25-2008, 03:13 AM
  5. 6L6 dilemma...
    By mom in forum Guitar Amps
    Replies: 2
    Last Post: 04-06-2007, 10:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •