Results 1 to 5 of 5

Thread: Fender Twin loud reverb hiss

  1. #1
    New Member
    Join Date
    Oct 2009
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    Fender Twin loud reverb hiss

    I've noticed that in the last year or two my 65 Twin Reverb Reissue has developed a loud hiss that is in direct relation to the level the reverb is set on. It's almost like the reverb control is a hiss control. It's more prominent than the standard reverb hiss. Anyone have any tips on what to do?

    I'm a noob to amps, but have built a good amount of diy pedals and electronics.

    Thanks.

    0 Not allowed! Not allowed!

  2. #2
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    13,003
    Thumbs Up/Down
    Received: 568/3
    Given: 298/0
    Rep Power
    28

    Reverb hiss

    I just finished a 65 Twin reissue repair.
    Same thing. Above 5 the hiss was terrible.
    I checked "everything". Never found it.
    I ended up putting a 12AT7 in the reverb recovery.(V4)
    Some would call it a mixer.
    I also put a 12AU7 in the phase inverter.

    0 Not allowed! Not allowed!

  3. #3
    New Member
    Join Date
    Oct 2009
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    And that worked? Any chance you can tell me where those are?

    0 Not allowed! Not allowed!

  4. #4
    Senior Member
    Join Date
    Jul 2006
    Location
    Redondo Beach, CA USA
    Posts
    462
    Thumbs Up/Down
    Received: 5/0
    Given: 0/0
    Rep Power
    14
    try replacing v3 and v4 first with the correct tubes before doing any type-swapping. check out the section on hiss here...

    Tube Amplifier Debugging Page

    0 Not allowed! Not allowed!

  5. #5
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    13,003
    Thumbs Up/Down
    Received: 568/3
    Given: 298/0
    Rep Power
    28

    Reverb Hiss

    Quote Originally Posted by deathofaparty View Post
    And that worked? Any chance you can tell me where those are?
    It did not "fix" the hiss.
    Just made it less objectionable.
    V6, phase inverter, is the last 12AX7 before the 6L6 output tubes.
    The tubes are numbered in order. 1-6.
    Attached is the schematic.
    Attached Files Attached Files

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Curing hiss: Fender Custom Vibrolux Reverb
    By Dave Curtis, dB AudioTech in forum Mods & Tweaks
    Replies: 6
    Last Post: 11-06-2011, 05:15 PM
  2. 1979 Fender Twin Reverb - can't turn off reverb
    By pro1911a1 in forum Maintenance, Troubleshooting & Repair
    Replies: 7
    Last Post: 02-02-2009, 03:40 PM
  3. Reverb Issues on a Fender Twin Reverb
    By womantone in forum Repair and Restoration
    Replies: 15
    Last Post: 09-26-2008, 06:31 PM
  4. Loud hum in a Super Twin Reverb
    By JC@ in forum Vintage Amps
    Replies: 12
    Last Post: 06-10-2007, 10:57 PM
  5. Fender Twin Reverb
    By Dano in forum Music Electronics
    Replies: 4
    Last Post: 10-23-2006, 11:56 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •