Results 1 to 29 of 29

Thread: Looking for service bulletins for Ampeg VT-60/120

  1. #1
    Senior Member
    Join Date
    Jan 2009
    Location
    Philadelphia, PA
    Posts
    243
    Thumbs Up/Down
    Received: 2/0
    Given: 5/1
    Rep Power
    11

    Looking for service bulletins for Ampeg VT-60/120

    I just finished fully rehabbing a run-down VT-120 1x12 combo. I have heard that there are service bulletins out for these amps that recommend installation of jumper wires because certain PCB traces are prone to overheating or causing fires (!). I emailed LOUD to see if they'd send them to me, but they won't because I'm not an authorized warranty service center. I've figured out a lot about the amp and how to make the grounding better, improve reliability where there are marginal components, etc. But if there are known safety issues with the PCB traces, I would like to know what they are before I put this thing into regular use.

    If anyone has the service bulletins and would be willing to send them to me, it would be much appreciated. My email is atomiumamps@gmail.com.

    I put up a post on my blog about the changes I made to the VT-120 -- maybe it could be helpful to others:
    Ampeg VT-120 epic overhaul | Electronic States

    0 Not allowed! Not allowed!

  2. #2
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    31,986
    Thumbs Up/Down
    Received: 1,799/7
    Given: 0/0
    Rep Power
    54
    I'm not aware of such bulletins. They may exist, but I've never seen them. I'd be surprised of Loud had much, since the amps are over 20 years old, LONG before Loud bought the SLM amp lines. If you call them and ask for a service bulletin, unless you are a service center, they won;t even bother to look up whether there is such a bulletin, because they won;t be sending one out to you even if there is, so why use up the time?

    The only wiring that overheats in tube amps is generally the heater wiring. Those are the only wires that have to carry any current. And it is usually a connection that fails, not the wiring itself.

    Look in your unit, is ther any wiring or conections that look like they overheated? If not, chances are it will continue that way. It has lasted 20 years without failing in that way.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  3. #3
    Senior Member
    Join Date
    Jan 2009
    Location
    Philadelphia, PA
    Posts
    243
    Thumbs Up/Down
    Received: 2/0
    Given: 5/1
    Rep Power
    11
    Well the amp supposedly can handle either 6L6s or EL34s, according to the manual. The bias voltage has a very large range, -30 to about -60. It's never had anything but 6L6s in it... so that makes me wonder if the heater traces are sufficient for 6L6 heater draw, but cook when using EL34s.

    I've successfully used it with 2x6550s in the power section, but now I'm thinking twice about trying it with 4xEL34s or 4x6550s.

    Here's a picture of the backside of the PCB, the heaters are the wide traces running left to right across the board, just above the power tube sockets:
    http://local.anchorstates.net/images...20-gutshot.jpg

    0 Not allowed! Not allowed!

  4. #4
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    31,986
    Thumbs Up/Down
    Received: 1,799/7
    Given: 0/0
    Rep Power
    54
    I have a layout drawing that shows traces.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  5. #5
    Senior Member
    Join Date
    Jan 2009
    Location
    Philadelphia, PA
    Posts
    243
    Thumbs Up/Down
    Received: 2/0
    Given: 5/1
    Rep Power
    11
    If you have that layout in an easily-accessible electronic version, and wouldn't mind sending it to me, I'd appreciate it. If it's a paper copy, then don't worry about it.

    Thanks for the help!

    0 Not allowed! Not allowed!

  6. #6
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    31,986
    Thumbs Up/Down
    Received: 1,799/7
    Given: 0/0
    Rep Power
    54
    Actually it is an 11x17 paper copy. It would have to be scanned in two pieces and gray-scaled.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  7. #7
    Old Timer oc disorder's Avatar
    Join Date
    Jul 2006
    Location
    Land Down Under
    Posts
    1,268
    Thumbs Up/Down
    Received: 4/0
    Given: 1/0
    Rep Power
    15

    Ampeg VT 120 Pictorial (layout)

    Here you go.. dunno where I got it...bit big but all the better to etc etc.....
    drawn 1989..
    Attached Files Attached Files

    0 Not allowed! Not allowed!

  8. #8
    Senior Member
    Join Date
    Jan 2009
    Location
    Philadelphia, PA
    Posts
    243
    Thumbs Up/Down
    Received: 2/0
    Given: 5/1
    Rep Power
    11
    Wow, thanks a lot.

    0 Not allowed! Not allowed!

  9. #9
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    31,986
    Thumbs Up/Down
    Received: 1,799/7
    Given: 0/0
    Rep Power
    54
    Wow indeed. That's great, and see the handwritten VT120 bottom center? That is my handwriting. My 11x17s are folded in half with three-holes on either end so it fits in a binder. At the edge of the fold I write the model like an index tab. Your scan is of my page. God knows from when.

    I did eventually find an 8x11 reduction of that scan.

    I no longer have that original, I still have the VT60 which is the same board. Seems to me many years ago I sent a bunch of my duplicate files to KB, he may have wound up with that one, so perhaps he provided the scan of it.

    ANyway, glad you found that.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  10. #10
    New Member
    Join Date
    Sep 2008
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Hi!
    Would it be possible to re-post the pictures from this? Each picture comes up as an ad to buy lottery tickets. I'm refurbishing A VT-60 and it would be most helpful.
    Best regards.

    0 Not allowed! Not allowed!

  11. #11
    Old Timer oc disorder's Avatar
    Join Date
    Jul 2006
    Location
    Land Down Under
    Posts
    1,268
    Thumbs Up/Down
    Received: 4/0
    Given: 1/0
    Rep Power
    15
    Hi Kc2eeB and welcome to the forum
    I will repost the layout .. can't help with the photos from jamesmafyew

    Sometimes you can get lucky using the wayback machine .. I had a look it's only been saved once and unfortunately
    there are only 2 exterior photos.
    see here :-
    Ampeg VT-120 epic overhaul | Electronic States
    The text is still there.. perhaps if you contact him he may be able to help...

    I zipped it up as the forum had a server crash and thinks the file is still there and wont allow a double post or some such..
    Attached Files Attached Files

    0 Not allowed! Not allowed!

  12. #12
    New Member
    Join Date
    Sep 2008
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Thank you so much! It's most appreciated. Sorry for the delay in responding.
    So far, I have the chassis out of the cabinet and marking the leads so it all goes back together correctly. It seems Ampeg did not mark the component locations, so this will be most helpful. Thanks again!

    0 Not allowed! Not allowed!

  13. #13
    Old Timer oc disorder's Avatar
    Join Date
    Jul 2006
    Location
    Land Down Under
    Posts
    1,268
    Thumbs Up/Down
    Received: 4/0
    Given: 1/0
    Rep Power
    15
    Here it is again.. Thanks Enzo...

    (Had a request although the repost was in an offshoot thread)
    Attached Files Attached Files

    0 Not allowed! Not allowed!

  14. #14
    Senior Member
    Join Date
    Jan 2009
    Location
    Philadelphia, PA
    Posts
    243
    Thumbs Up/Down
    Received: 2/0
    Given: 5/1
    Rep Power
    11
    I may as well chime in for posterity as well. The hosting for those pics on the original blog post is long expired -- and it'll be a while before I get around to fixing all my old posts there. But I'll upload the pictures here in case it helps someone.

    This particular amp had an interesting story, by the way. It came to me as scrap because the original owner didn't think it was worthwhile to fix. After I overhauled it, I sold it to a guy in Louisiana. Didn't have an issue during the several years he had it, until he took it to a local tech for routine maintenance. The tech was confused by what I had done to the amp, and mangled a few things trying to 'return to stock'. The weird thing was that the original owner who had first dumped it with me bought it back on ebay (yes, the same exact amp) and brought it back to me again to check over. Still working just fine, after I repaired some of the ill-advised 'repairs' from the LA job. The original owner is very happy with it and he spent less on it than he would have to just pay me to do all that work in the first place.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	vt120-rear.jpg 
Views:	288 
Size:	666.4 KB 
ID:	36908   Click image for larger version. 

Name:	vt120-gutshot.jpg 
Views:	684 
Size:	354.2 KB 
ID:	36909   Click image for larger version. 

Name:	vt120.jpg 
Views:	877 
Size:	549.7 KB 
ID:	36910   Click image for larger version. 

Name:	vt120-rearpanel.jpg 
Views:	467 
Size:	368.0 KB 
ID:	36911   Click image for larger version. 

Name:	vt120-starground.jpg 
Views:	221 
Size:	323.7 KB 
ID:	36912   Click image for larger version. 

Name:	vt120-upd.jpg 
Views:	364 
Size:	396.9 KB 
ID:	36913  

    0 Not allowed! Not allowed!

  15. #15
    New Member
    Join Date
    Sep 2008
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Wow, "a blast from the past!" Thanks so much, again! I did repair the amp, did not do the star ground (maybe eventually) and it sounds great!

    0 Not allowed! Not allowed!

  16. #16
    Junior Member
    Join Date
    May 2016
    Posts
    7
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by oc disorder View Post
    Hi Kc2eeB and welcome to the forum
    I will repost the layout .. can't help with the photos from jamesmafyew

    Sometimes you can get lucky using the wayback machine .. I had a look it's only been saved once and unfortunately
    there are only 2 exterior photos.
    see here :-
    Ampeg VT-120 epic overhaul | Electronic States
    The text is still there.. perhaps if you contact him he may be able to help...

    I zipped it up as the forum had a server crash and thinks the file is still there and wont allow a double post or some such..
    Hey OC,

    Sorry to resurrect an old thread, but I just acquired a VT120H and would love to see the layout drawing. I tried downloading the zip file, but the extracted pdf is blank. Any chance you can attach it again?

    Thanks a ton!

    0 Not allowed! Not allowed!

  17. #17
    New Member
    Join Date
    Sep 2008
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by Whoopsies View Post
    Hey OC,

    Sorry to resurrect an old thread, but I just acquired a VT120H and would love to see the layout drawing. I tried downloading the zip file, but the extracted pdf is blank. Any chance you can attach it again?

    Thanks a ton!
    Ampeg VT120 layout PDF attached
    Attached Files Attached Files

    0 Not allowed! Not allowed!

  18. #18
    Junior Member
    Join Date
    May 2016
    Posts
    7
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Terrific, thanks so much!

    0 Not allowed! Not allowed!

  19. #19
    Old Timer oc disorder's Avatar
    Join Date
    Jul 2006
    Location
    Land Down Under
    Posts
    1,268
    Thumbs Up/Down
    Received: 4/0
    Given: 1/0
    Rep Power
    15
    Beat me to it.. but as I've been reducing the file size I'll' put both here

    When I got these the local distributor had to raid new ones for spares think it was the transformer
    can't remember if it was o/p or pwr.
    This was just before the LOUD takeover !

    EDIT : You are right G1 the zips are still ok.
    The schematics for the VT 120 and VT 60 are available at Black Magic Amplifiers.

    http://bmamps.com/Tech_sch.html

    0 Not allowed! Not allowed!
    Last edited by oc disorder; 05-03-2016 at 08:47 PM. Reason: too many copies

  20. #20
    Don't forget the joker g1's Avatar
    Join Date
    Feb 2010
    Location
    Canada, somewhere north of Fargo
    Posts
    11,715
    Thumbs Up/Down
    Received: 1,599/23
    Given: 4,075/11
    Rep Power
    22
    Quote Originally Posted by Whoopsies View Post
    I tried downloading the zip file, but the extracted pdf is blank. Any chance you can attach it again?
    I'm a bit confused about this, I downloaded the zips from both posts, #11 & #13, neither is blank when extracted.

    0 Not allowed! Not allowed!
    Just because they don't have tubes doesn't mean they don't have feelings! - glebert

  21. #21
    Junior Member
    Join Date
    May 2016
    Posts
    7
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by g1 View Post
    I'm a bit confused about this, I downloaded the zips from both posts, #11 & #13, neither is blank when extracted.
    Must be something on my end? In any case, I can read the pdfs in posts #17 and #19.

    0 Not allowed! Not allowed!

  22. #22
    Don't forget the joker g1's Avatar
    Join Date
    Feb 2010
    Location
    Canada, somewhere north of Fargo
    Posts
    11,715
    Thumbs Up/Down
    Received: 1,599/23
    Given: 4,075/11
    Rep Power
    22
    Could you re-test the one's in #11 & #13?
    I'm wondering if the blank you have is actually from #7 ?

    0 Not allowed! Not allowed!
    Just because they don't have tubes doesn't mean they don't have feelings! - glebert

  23. #23
    Junior Member
    Join Date
    May 2016
    Posts
    7
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by g1 View Post
    Could you re-test the one's in #11 & #13?
    I'm wondering if the blank you have is actually from #7 ?
    Just downloaded the zip files in #11 and #13 on my Windows machine: I can view them fine. They are showing up blank on my OSX side.

    0 Not allowed! Not allowed!

  24. #24
    Don't forget the joker g1's Avatar
    Join Date
    Feb 2010
    Location
    Canada, somewhere north of Fargo
    Posts
    11,715
    Thumbs Up/Down
    Received: 1,599/23
    Given: 4,075/11
    Rep Power
    22
    And the ones from 17 & 19 are showing up in OSX ?

    0 Not allowed! Not allowed!
    Just because they don't have tubes doesn't mean they don't have feelings! - glebert

  25. #25
    Junior Member
    Join Date
    May 2016
    Posts
    7
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by g1 View Post
    And the ones from 17 & 19 are showing up in OSX ?
    Correct.

    0 Not allowed! Not allowed!

  26. #26
    Don't forget the joker g1's Avatar
    Join Date
    Feb 2010
    Location
    Canada, somewhere north of Fargo
    Posts
    11,715
    Thumbs Up/Down
    Received: 1,599/23
    Given: 4,075/11
    Rep Power
    22
    Thanks for re-checking those files.
    Maybe someone more familiar with mac will have some idea of what is happening here.
    The zip thing seemed to be a universal cure for the corrupted files, this is the first issue with the zips.

    0 Not allowed! Not allowed!
    Just because they don't have tubes doesn't mean they don't have feelings! - glebert

  27. #27
    Junior Member
    Join Date
    May 2016
    Posts
    7
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by g1 View Post
    Thanks for re-checking those files.
    Maybe someone more familiar with mac will have some idea of what is happening here.
    The zip thing seemed to be a universal cure for the corrupted files, this is the first issue with the zips.
    Might just be something funky with my particular system. I'll reboot and recheck zips in #11 and #13.

    0 Not allowed! Not allowed!

  28. #28
    Junior Member
    Join Date
    May 2016
    Posts
    7
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by Whoopsies View Post
    Might just be something funky with my particular system. I'll reboot and recheck zips in #11 and #13.
    Still showing up blank on OSX 10.11.2.

    0 Not allowed! Not allowed!

  29. #29
    New Member
    Join Date
    Apr 2015
    Location
    San Jose, CA
    Posts
    1
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    Try acrobat, if you have it

    Quote Originally Posted by Whoopsies View Post
    Still showing up blank on OSX 10.11.2.
    This happens to me as well, using OSX preview.
    However, Acrobat displays the content picture just fine.

    -BobK

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. QSC service bulletins
    By e_c_mccollum in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 03-17-2017, 09:31 PM
  2. Ampeg VT-60 bias issue
    By Mars Amp Repair in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 09-05-2009, 11:59 PM
  3. Ampeg VT-120 4 SALE
    By Egyptiansong in forum Vintage Amps
    Replies: 1
    Last Post: 10-06-2008, 02:27 AM
  4. Ampeg VT-60 help
    By ampegguitarplayer in forum Guitar Amps
    Replies: 3
    Last Post: 08-17-2008, 12:24 PM
  5. New member...Ampeg VT-120 hum
    By kaiser_will in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 03-02-2007, 09:42 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •