Results 1 to 13 of 13

Thread: Digitech PDS-2000 not working properly

  1. #1
    Junior Member
    Join Date
    Jul 2011
    Location
    Oak Lawn, IL, USA
    Posts
    20
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    Digitech PDS-2000 not working properly

    My dad's singer brought me this pedal since he knows I like to work on these kind of things. Anyway, the pedal stopped working about a week ago while my dad's band was practicing; the singer said it smelled like something was burning.

    When the pedal is set to "normal," there is a constant "bumping" sound and no delay; it sounds like the pedal is cycling but I'm hearing the "bumping" sound as opposed to the signal from the guitar. Otherwise it doesn't muffle or deaden the sound.

    On any other setting the signal is sort of muffled or there is none at all, and there is no delay at all.

    I've opened it up and there doesn't seem to be any visible signs of a blown component. I was hoping the problem would be a blown resistor or capacitor so I could replace it but it's looking like one of the chips could be fried (though I'm just guessing on this).

    Any ideas as to what could be wrong?

    0 Not allowed! Not allowed!
    Delay and wah... that's almost one pedal too many.

  2. #2
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    13,068
    Thumbs Up/Down
    Received: 609/3
    Given: 314/0
    Rep Power
    28
    Not having a schematic is going to hurt.
    DigiTech has an excellent service department.
    Very reasonable rates.

    0 Not allowed! Not allowed!

  3. #3
    Master Destroyer nosaj's Avatar
    Join Date
    Sep 2011
    Location
    Pace, FL
    Posts
    3,396
    Thumbs Up/Down
    Received: 1,218/102
    Given: 172/36
    Rep Power
    12
    check the 1st and easiest thing the power pack for it, is it putting out the correct voltage, is it even the correct one? does it get too hot. Once power is ok'ed go from there.


    Digitech will send schematics on discontinued items.
    jason

    0 Not allowed! Not allowed!

  4. #4
    Junior Member
    Join Date
    Jul 2011
    Location
    Oak Lawn, IL, USA
    Posts
    20
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    [QUOTE=nosaj;228741]check the 1st and easiest thing the power pack for it, is it putting out the correct voltage, is it even the correct one? does it get too hot. Once power is ok'ed go from there.

    Power's not the problem. Already tried using a 9 volt instead of the adapter; no change. And it's been working with the same power supply for almost 10 years now. Got a schematic...

    0 Not allowed! Not allowed!
    Delay and wah... that's almost one pedal too many.

  5. #5
    Senior Member
    Join Date
    Jul 2007
    Posts
    613
    Thumbs Up/Down
    Received: 54/0
    Given: 9/0
    Rep Power
    14
    [QUOTE=AndyM;228751]
    Quote Originally Posted by nosaj View Post
    check the 1st and easiest thing the power pack for it, is it putting out the correct voltage, is it even the correct one? does it get too hot. Once power is ok'ed go from there.

    Power's not the problem. Already tried using a 9 volt instead of the adapter; no change. And it's been working with the same power supply for almost 10 years now. Got a schematic...
    Schematics you can see in http://music-electronics-forum.com/t23415/

    0 Not allowed! Not allowed!

  6. #6
    Master Destroyer nosaj's Avatar
    Join Date
    Sep 2011
    Location
    Pace, FL
    Posts
    3,396
    Thumbs Up/Down
    Received: 1,218/102
    Given: 172/36
    Rep Power
    12
    [QUOTE=doctor;228793]
    Quote Originally Posted by AndyM View Post
    My powerpack for my digitech says 9 VAC a 9 volt VDC.

    Could be a difference

    0 Not allowed! Not allowed!

  7. #7
    Junior Member
    Join Date
    Jul 2011
    Location
    Oak Lawn, IL, USA
    Posts
    20
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Opened it up, cleaned some connections, now it's working fine. The thing was filthy!

    Well, the pedal is older than I am, so I guess that's to be expected.

    0 Not allowed! Not allowed!
    Delay and wah... that's almost one pedal too many.

  8. #8
    New Member
    Join Date
    Oct 2013
    Location
    Russia, Saratov
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    [QUOTE=doctor;228793]
    Quote Originally Posted by AndyM View Post
    I'm sorry for some necroposting here. Could you please reupload the file? It has been deleted and I think that no one has a chance to get the schematics now Even me

    0 Not allowed! Not allowed!

  9. #9
    Senior Member
    Join Date
    Jul 2007
    Posts
    613
    Thumbs Up/Down
    Received: 54/0
    Given: 9/0
    Rep Power
    14
    [QUOTE=DJGlukBH;320089]
    Quote Originally Posted by doctor View Post

    I'm sorry for some necroposting here. Could you please reupload the file? It has been deleted and I think that no one has a chance to get the schematics now Even me
    I will try to upload this file once more.

    If it will be unsuccessful, please act in accordance with my prescription: http://music-electronics-forum.com/t34360/
    Attached Files Attached Files

    0 Not allowed! Not allowed!

  10. #10
    New Member
    Join Date
    Oct 2013
    Location
    Russia, Saratov
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    [QUOTE=doctor;320095]
    Quote Originally Posted by DJGlukBH View Post

    I will try to upload this file once more.

    If it will be unsuccessful, please act in accordance with my prescription: http://music-electronics-forum.com/t34360/
    Thanks a lot for being so kind! Still getting a blank screen while opening the attachment. I'm unable to download it too ;(

    0 Not allowed! Not allowed!

  11. #11
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    13,068
    Thumbs Up/Down
    Received: 609/3
    Given: 314/0
    Rep Power
    28
    [QUOTE=doctor;320095]
    Quote Originally Posted by DJGlukBH View Post

    I will try to upload this file once more.

    If it will be unsuccessful, please act in accordance with my prescription: http://music-electronics-forum.com/t34360/
    The file SIZE must be changed.
    I use Cute PDF Writer or Bullzip.

    0 Not allowed! Not allowed!
    Last edited by Jazz P Bass; 10-03-2013 at 02:05 PM.

  12. #12
    Don't forget the joker g1's Avatar
    Join Date
    Feb 2010
    Location
    Canada, somewhere north of Fargo
    Posts
    12,360
    Thumbs Up/Down
    Received: 2,031/24
    Given: 5,166/11
    Rep Power
    24
    Here's the re-sized schematic, thanks Doctor!
    Attached Files Attached Files

    0 Not allowed! Not allowed!
    "Everything is better with a tube. I have a customer with an all-tube pacemaker. His heartbeat is steady, reassuring and dependable, not like a modern heartbeat. And if it goes wrong he can fix it himself. You can't do that with SMD." - Mick Bailey

  13. #13
    New Member
    Join Date
    Oct 2013
    Location
    Russia, Saratov
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by g-one View Post
    Here's the re-sized schematic, thanks Doctor!
    Many thanks! I got two unit sitting without it!

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Digitech RDS-2000 Time machine delay?
    By MattB930 in forum Schematic Requests
    Replies: 1
    Last Post: 03-25-2015, 06:30 PM
  2. Fender Frontman 212r - Doesn't mute properly
    By Teknous in forum Maintenance, Troubleshooting & Repair
    Replies: 6
    Last Post: 09-10-2011, 11:24 AM
  3. digitech rp 2000
    By interpoint in forum Guitar Effects
    Replies: 2
    Last Post: 07-29-2011, 11:28 PM
  4. Sovtek MIG-50 pots not working properly
    By corey in forum Guitar Amps
    Replies: 27
    Last Post: 07-28-2011, 05:41 PM
  5. DigiTech RP 2000
    By themusic in forum Music Electronics
    Replies: 1
    Last Post: 06-23-2010, 05:57 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •