Results 1 to 4 of 4

Thread: Crest CA6 Power amp- in protection on one channel

  1. #1
    New Member
    Join Date
    Dec 2012
    Posts
    1
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0

    Crest CA6 Power amp- in protection on one channel

    Hello Tech world
    I am new hear to this furum.This Crest amp came in with all the syptoms of a short in channel B. Channel A worked fine with PWR harness of B diabled. Now after bringing it up on the variac with channel A PWR diabled, it showed excesive current being drawn on B. So I decided to swap out channel A in place of B with maintaining A PWR harness disabled. It then showed a short with Channel A (the known good channel). thus leading me to think PWR supply problems with that side. Has anybody seen this problem any leads would be helpful. Thanks.

    0 Not allowed! Not allowed!

  2. #2
    Senior Member
    Join Date
    May 2006
    Location
    Near Seattle, WA, USA
    Posts
    663
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Most power supply problems will be present even without an output module installed, so check for proper rail voltages that way first.

    Could also be a problem on the preamp board, but that usually only happens after a major fault in an output module so comparison-check all the semiconductors between the working and suspect modules with a meter set to diode-check before doing a lot of module swapping.

    Problems on anything other than the output modules are kind of a PITA to run down on the CA series due to physical construction (as I'm sure you have noticed).

    Probably not the immediate problem - but look for any bulging or leaking main filter caps on the power supply board. Most of the CA amps I saw in recent years had caps that were starting to go. The smaller electrolytic caps on that board also tend to "dry-out" and go high-ESR.

    0 Not allowed! Not allowed!

  3. #3
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    30,660
    Thumbs Up/Down
    Received: 588/1
    Given: 0/0
    Start at the start, check the main rectifier bridge(s) and filter caps.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  4. #4
    Senior Member mozwell's Avatar
    Join Date
    Sep 2009
    Location
    Australia
    Posts
    645
    Thumbs Up/Down
    Received: 4/0
    Given: 0/0
    crest ca6, ca9, ca12, ca18 for reference

    I hope they help
    Attached Files Attached Files

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power Transformers With Internal Thermal Protection Fuse
    By TomCarlos in forum Maintenance, Troubleshooting & Repair
    Replies: 41
    Last Post: 01-18-2014, 01:51 PM
  2. EV 7200 power amp 1 channel not working
    By treatmint in forum Music Electronics
    Replies: 7
    Last Post: 06-30-2011, 12:43 AM
  3. Reverse Diode protection for Power Tubes?
    By leadfootdriver in forum Mods & Tweaks
    Replies: 1
    Last Post: 03-09-2011, 06:48 PM
  4. Bad Crest CA6 power supply
    By clintronics in forum Music Electronics
    Replies: 2
    Last Post: 09-04-2007, 05:54 PM
  5. Crest power amp
    By tonezoneonline in forum Maintenance, Troubleshooting & Repair
    Replies: 20
    Last Post: 08-30-2006, 08:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •