Results 1 to 8 of 8

Thread: Engl E530 Gain pot problem

  1. #1
    Twobie
    Join Date
    Dec 2014
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    Engl E530 Gain pot problem

    hey all. i have ENGl E530 Preamp and i have to replace my Clean Gain pot, i try to find the kind of pot from schematic and i could find the exact pot. can anyone help me?

    0 Not allowed! Not allowed!

  2. #2
    Senior Member
    Join Date
    Dec 2007
    Location
    Poland
    Posts
    1,642
    Thumbs Up/Down
    Received: 51/0
    Given: 14/0
    Rep Power
    14
    What exactly you were searching for? This should be 1M logarithmic pot (available in almost every shop). Can you post a photo of the pot?

    Mark

    0 Not allowed! Not allowed!

  3. #3
    Twobie
    Join Date
    Dec 2014
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by MarkusBass View Post
    What exactly you were searching for? This should be 1M logarithmic pot (available in almost every shop). Can you post a photo of the pot?

    Mark
    Click image for larger version. 

Name:	IMG_2681.JPG 
Views:	113 
Size:	219.4 KB 
ID:	31826
    Click image for larger version. 

Name:	IMG_2682.JPG 
Views:	121 
Size:	212.7 KB 
ID:	31827
    Click image for larger version. 

Name:	IMG_2683.JPG 
Views:	114 
Size:	303.7 KB 
ID:	31828


    thanks for helping, i need exactly like that. i see it ALPS pot but i didn't find it anywhere... the one with the caption erased is the lead channel gain pot and it look like the same to clean channel. i try spray contact but without luck .. still don't helps much....

    0 Not allowed! Not allowed!

  4. #4
    Senior Member Pedro Vecino's Avatar
    Join Date
    Jul 2006
    Location
    Spain
    Posts
    718
    Thumbs Up/Down
    Received: 237/2
    Given: 122/0
    Rep Power
    14
    These potentiometers with four pins are identical to those (Alpha) used by Marshall in TSL/DSL100 and others. Maybe they're easier to find.


    0 Not allowed! Not allowed!

  5. #5
    Twobie
    Join Date
    Dec 2014
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Quote Originally Posted by Pedro Vecino View Post
    These potentiometers with four pins are identical to those (Alpha) used by Marshall in TSL/DSL100 and others. Maybe they're easier to find.

    great ! i have sdl100 but i didnt open it yet =]
    its doesn't metter what brand. what the specific pot i need to search?

    0 Not allowed! Not allowed!

  6. #6
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    13,106
    Thumbs Up/Down
    Received: 629/3
    Given: 331/0
    Rep Power
    28
    You may want to look into repairing the lead channel pot.
    The crimps at the rear of it appear to be 'uncrimped'.
    Possibly from getting wacked from the front.
    That would make for a very intermittent wiper connection.

    0 Not allowed! Not allowed!

  7. #7
    Senior Member
    Join Date
    Dec 2007
    Location
    Poland
    Posts
    1,642
    Thumbs Up/Down
    Received: 51/0
    Given: 14/0
    Rep Power
    14
    Is it similar to this one: RK11K1120060 ALPS | Mouser just different value? Go to ALPS web site and check distributors in the country where you live.

    Mark

    0 Not allowed! Not allowed!

  8. #8
    Don't forget the joker g1's Avatar
    Join Date
    Feb 2010
    Location
    Canada, somewhere north of Fargo
    Posts
    12,648
    Thumbs Up/Down
    Received: 2,186/24
    Given: 5,514/11
    Rep Power
    24
    Quote Originally Posted by Jazz P Bass View Post
    You may want to look into repairing the lead channel pot.
    The crimps at the rear of it appear to be 'uncrimped'.
    Possibly from getting wacked from the front.
    That would make for a very intermittent wiper connection.
    Good call, but the back of the pot has a break in it (center), so the wafer is probably broken too.

    0 Not allowed! Not allowed!
    "Everything is better with a tube. I have a customer with an all-tube pacemaker. His heartbeat is steady, reassuring and dependable, not like a modern heartbeat. And if it goes wrong he can fix it himself. You can't do that with SMD." - Mick Bailey

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engl amp -strange problem!
    By Valvehead in forum Maintenance, Troubleshooting & Repair
    Replies: 12
    Last Post: 06-10-2014, 01:34 PM
  2. Engl Powerball interesting problem.
    By DizzyD in forum Maintenance, Troubleshooting & Repair
    Replies: 18
    Last Post: 04-03-2013, 02:04 PM
  3. Engl E530 problem. Help!
    By pjutter in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 12-03-2012, 04:31 PM
  4. ENGL e530 build help/advice
    By Bill_Nephew in forum Build Your Amp
    Replies: 11
    Last Post: 02-29-2012, 02:55 AM
  5. problem with an ENGL Sovereign amp
    By JC@ in forum Maintenance, Troubleshooting & Repair
    Replies: 0
    Last Post: 07-11-2008, 09:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •