Results 1 to 4 of 4

Thread: AC15C1 burning power supply resistor

  1. #1
    Senior Member
    Join Date
    Jul 2006
    Posts
    187
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    14

    AC15C1 burning power supply resistor

    r80 on this schematic... https://app.box.com/s/n4rogzmzmt2i7dsubfno

    It was burnt, and I pulled the tubes, replaced it, and powered up and it burns again, even with no power tubes installed. Bad filter cap maybe?

    0 Not allowed! Not allowed!

  2. #2
    Supporting Member
    Join Date
    May 2006
    Location
    Staffordshire UK
    Posts
    3,729
    Thumbs Up/Down
    Received: 475/1
    Given: 440/2
    Rep Power
    18
    Yes, maybe C53, or a short somewhere.

    0 Not allowed! Not allowed!

  3. #3
    Member mhuss's Avatar
    Join Date
    Oct 2006
    Location
    West of Philly
    Posts
    310
    Thumbs Up/Down
    Received: 23/0
    Given: 1/0
    Rep Power
    13
    Quote Originally Posted by pdf64 View Post
    maybe C53
    or C52

    0 Not allowed! Not allowed!

  4. #4
    Senior Member
    Join Date
    Jul 2006
    Posts
    187
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    14
    Yes, it was C52. I noticed some discoloration on it and changed it and C53 for good measure. All good now!

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ampeg svt cl (korean) burning cathode resistor on 12ax7
    By dangin in forum Maintenance, Troubleshooting & Repair
    Replies: 15
    Last Post: 02-08-2017, 11:48 PM
  2. VOX AC15C1
    By Jay D in forum Schematic Requests
    Replies: 2
    Last Post: 11-12-2014, 07:57 AM
  3. Burning resistor on my Road 220
    By Rykonen in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 12-12-2010, 12:21 PM
  4. 5E3 cathode resistor power and screen resistor
    By bluescaster in forum 5 E 3
    Replies: 4
    Last Post: 01-19-2010, 10:49 AM
  5. SS amp with Burning Resistors at Power-Up
    By bob p in forum Other Amps
    Replies: 7
    Last Post: 07-25-2007, 08:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •