Results 1 to 1 of 1

Thread: JCM 900 2100 SLX Bias Problem

  1. #1
    New Member
    Join Date
    Apr 2016
    Location
    S.E. Michigan
    Posts
    5
    Thumbs Up/Down
    Received: 0/0
    Given: 1/0
    Rep Power
    0

    JCM 900 2100 SLX Bias Problem

    Just picked up JCM 900 2100 SLX with 5881,
    unfortunately it came with Tung Sol 5881 and
    they couldn't cope with plate voltage.

    TS 5881 rated for 400V and one tube went poof
    within a day.

    Got a set of TAD 6L6GC's and installed them and thus
    my problem, no matter where the tubes are swapped
    around V5/V7 come in @ 40 ma and V6/V8 @ 60 ma.

    I'm getting 470v plate voltage and -90
    grid voltage off pin 5 on all 4 tubes.

    Checked all screen resistors 470ohm and they
    are fine, nothing really scorched on the board.

    Getting 490v on screen pin 4

    I'm at a loss, looking for some help and
    guidance as where to troubleshoot next.

    Appreciate any help anyone can give
    me


    Thanks


    http://www.drtube.com/schematics/mar...slxa-61-02.gif

    http://www.drtube.com/schematics/mar...2100-60-02.gif

    http://www.drtube.com/schematics/mar...2100-60-58.gif


    Click image for larger version. 

Name:	slxa-61-02.gif 
Views:	0 
Size:	68.7 KB 
ID:	39646

    Click image for larger version. 

Name:	2100-60-02.gif 
Views:	0 
Size:	71.0 KB 
ID:	39647

    Click image for larger version. 

Name:	2100-60-58.gif 
Views:	0 
Size:	72.7 KB 
ID:	39648

    0 Not allowed! Not allowed!
    Last edited by hadley101; 06-25-2016 at 01:32 AM. Reason: added links and pictures

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. JCM 900 SLX Feedback
    By Tage in forum Maintenance, Troubleshooting & Repair
    Replies: 43
    Last Post: 11-18-2019, 04:46 PM
  2. Marshall 2100 JCM 900 head oscillating
    By rf7 in forum Maintenance, Troubleshooting & Repair
    Replies: 7
    Last Post: 07-07-2018, 02:26 AM
  3. Marshall 2100 JCM 900 Head Hum
    By rf7 in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 05-22-2013, 05:20 AM
  4. Marshall jcm 900 2100 noisy buzz/hiss/squeal
    By lespaul924 in forum Maintenance, Troubleshooting & Repair
    Replies: 0
    Last Post: 03-28-2011, 04:35 AM
  5. JCM 900 2100 w/ potential blown PT
    By jamesmafyew in forum Maintenance, Troubleshooting & Repair
    Replies: 30
    Last Post: 10-20-2010, 04:43 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •