Results 1 to 4 of 4

Thread: Need a replacement power transformer for a Silvertone 1482 Tube amp

  1. #1
    New Member
    Join Date
    Nov 2017
    Posts
    2
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    Need a replacement power transformer for a Silvertone 1482 Tube amp

    I am an experienced electronics repair person, but a newbie when it comes to tube amp repair.

    I was given a non-working Silverton 1482 amplifier. I plugged it in and the power light came on, but about 1 minute later the power transformer starting smoking out the holes where the wires come out, so I am pretty sure it is bad.
    The heaters in the tubes did not come on either. The unit did not blow a fuse.

    I want to replace the transformer, and it doesn't have to be cosmetically correct, but I would like it to be electrically sufficient.

    Here is the info I have gleaned:

    There are no numbers on the transformer.

    Primary is two wires, and it is for 115V.
    The secondary after the rectifier tube (Tube type 6X4) is supposed to be 350V, and the output stages on this amp are two 6V6GT tubes. The heater secondary output is 6.3VAC.
    The wattage of the amplifier is 15W, and the primary input power rating is 70W total at 115V.
    The speaker is 4 Ohms running on a 4 ohm tap on the output transformer.

    There are two secondary’s, one is center tapped three wire for the main power at 350V DC, and the other is two wire at 6.3VAC.

    Since the primary is rated at 70W, I assume it will have maximum 70/115-> .61A in it. The fuse is 1 slow blo 1A MDL, which also validates the .61A number.

    Would anyone on this board be able to advise me on a specific transformer (or pair of transformers) that might work, and where to get them?

    What should the voltage rating of the secondary be in order to crated 350V DC? Is this calculated similarly if you just had had two diodes feeding the caps, or is there more drop in the tube rectifier than in a silicon diode?

    I also need to know the amperage rating of the two secondary windings, as this info isn't in the schematic.

    The schematic is here for reference: http://www.silvertoneworld.net/schem...rtone_1482.pdf

    Thanks in advance for any help.

    GregGarner

    0 Not allowed! Not allowed!

  2. #2
    New Member
    Join Date
    Nov 2017
    Posts
    2
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Further thoughts: According to this web page on rectifiers, I think I have a full wave rectifier so I need to divide 350V/.45 to find the transformer voltage rating, which is about 770V.
    Rectifier web page:
    http://www.hammondmfg.com/pdf/5c007.pdf

    I found this transformer that might work:http://el34world.com/Transformers/files/MOJO756.pdf
    More info here: Fender Transformer hookups

    The MOJO756 has two 384V windings, which adds up to 768V. The page also specifically says that it can be used with two 6V6 output tubes, and it has a 6.3V winding that can supply up to 3A.

    Can anyone that has a bit more experience than myself comment as to whether or not this transformer seems electrically suitable?

    The transformer has the wires coming out the bottom, which is also suitable for my amplifier.

    GregGarner

    0 Not allowed! Not allowed!

  3. #3
    Supporting Member mozz's Avatar
    Join Date
    Oct 2015
    Location
    NEPA
    Posts
    827
    Thumbs Up/Down
    Received: 192/1
    Given: 135/0
    Rep Power
    5
    These amps were made by Danelectro. All i can say is to check Mojotone, heyboer, magnetic components and few other guitar amp transformer companies. You have to repair the amp or again it's gonna burn out any replacement transformer you put in there. There is a seller on ebay called musical power supplies who probably has something that would also work.

    You need 325v-335v max. That Mojo 756 is too hot and has 5v which you don't need.

    0 Not allowed! Not allowed!

  4. #4
    Old Timer
    Join Date
    May 2006
    Location
    Chill-Ville, VA
    Posts
    3,188
    Thumbs Up/Down
    Received: 686/6
    Given: 1,342/9
    Rep Power
    18
    Agree with mozz. There's very VERY likely to be other issues with the amp, which will smoke any replacement you put in. Transformers (even in "crappy" amps) are among the most reliable (and expensive) components. They RARELY fail by themselves, without some other component taking the tranny with it. There's a good chance the smoke started coming out last time it was on, and that's why it was gifted to you!
    My first guesses would be rectifier tubes, power tubes, or filter caps. But, that said, check HERE:

    Geofex.com

    Go to the top left corner and click on "tube amp debug page." It's where a lot of us got our start. Do what you can from there, and I guarantee you'll learn a load in the process.

    Justin

    0 Not allowed! Not allowed!
    "Wow it's red! That doesn't look like the standard Marshall red. It's more like hooker lipstick/clown nose/poodle pecker red." - Chuck H. -
    "Of course that means playing **LOUD** , best but useless solution to modern sissy snowflake players." - J.M. Fahey -
    "All I ever managed to do with that amp was... kill small rodents within a 50 yard radius of my practice building." - Tone Meister -

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hot power tubes on Silvertone 1482
    By mike60510 in forum Maintenance, Troubleshooting & Repair
    Replies: 12
    Last Post: 06-21-2016, 03:49 AM
  2. Question for 1472/1482 Silvertone amp owners
    By slidincharlie (Carlo P) in forum Vintage Amps
    Replies: 7
    Last Post: 05-11-2014, 12:37 AM
  3. Silvertone 1482 Tremolo does nothing. Bad tube?
    By kpreese in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 02-13-2011, 01:32 AM
  4. New power tranny: rectifier and power lamp blow (Silvertone 1482)
    By slidincharlie (Carlo P) in forum Maintenance, Troubleshooting & Repair
    Replies: 55
    Last Post: 11-21-2009, 09:13 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •