Results 1 to 4 of 4

Thread: Does this amp schematic look usable

  1. #1
    New Member
    Join Date
    Jan 2018
    Location
    Kent, UK
    Posts
    2
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    Does this amp schematic look usable

    Hi all,

    Although I've built a few small solid state amps using slightly modified designs, I'm completely new to the world of valve/tube amps and have come up with this schematic based on a modified Harley Benton GA5. The reason I am using the UCC85 and UL84 is purely because I already have those tubes. I am only building this for a bit of fun, so it doesn't have to be amazing.

    The reason I am using 2 transformers back to back for the power supply is because I can't find a reasonably priced 1:1 isolation transformer and will be using 12v elsewhere in the amp.

    The tube heaters will be powered by the 12v DC rail which will then be going into an adjustable DC-DC boost module. I've done it this way as it's cheaper and I can also adjust the output voltage should I add any further circuitry requiring more valves to be heated later. The 12v AC will be going off to run a low powered light bulb for aesthetics only.

    Click image for larger version. 

Name:	Valve amp modulalised_schem - Final.png 
Views:	185 
Size:	351.3 KB 
ID:	46441

    Thank you in advance for any suggestions and help

    Jim

    p.s. forgot to add, I plan on connecting the 200-240v DC GND to earth.

    0 Not allowed! Not allowed!

  2. #2
    Old Timer J M Fahey's Avatar
    Join Date
    Oct 2007
    Location
    Buenos Aires, Argentina
    Posts
    11,753
    Thumbs Up/Down
    Received: 1,883/23
    Given: 1,463/35
    Rep Power
    27
    Sorry, your schematic is hard to read as is, please redraw it using standard tube symbols and "all in one", not criscrossing all over the screen from PCB to PCB.

    And your supply arrangement is way too complex and heavy; try toget a proper transformer or even salvage one from an old tube radio or record player.

    Do you have the proper sockets for "U Technology" tubes?
    If I remember well, those are miniature 8 pin tubes (not octals) with a raised glass dot on the envelope to serve as an alignment key, not too easy to find today.

    If you pulled tubes and sockets from an old radio, also reuse its power transformer (and presumably theoutput one too)
    I presume you are somewhere in Europe.

    0 Not allowed! Not allowed!
    Juan Manuel Fahey

  3. #3
    New Member
    Join Date
    Jan 2018
    Location
    Kent, UK
    Posts
    2
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Hello J M Fahey, Thank you for your response.

    I am in the UK. The parts radio isn't with me for the next couple of days so I can't confirm if the 'U' tubes have the notches. If they do not fit the B9A sockets I should be able to remove 2 from the original circuit. The radio that the parts are coming from doesn't have a transformer in it, I'm sure I can find something to salvage a transformer from if required.

    Do you have any suggestions for schematic software that has the correct symbols for various tube layouts as the software I am using (Fritzing) doesn't have any tube parts? When I get some time (hopefully later today) I'll attempt to re-arange the schematic into a more user-friendly format.

    0 Not allowed! Not allowed!

  4. #4
    Supporting Member
    Join Date
    Dec 2009
    Location
    UK
    Posts
    3,467
    Thumbs Up/Down
    Received: 196/0
    Given: 24/0
    Rep Power
    14
    The tubes you refer to are usually standard 9-pin, the 'U' prefix being the UK convention for a universal heater voltage and roughly the tubes equate to an ECC85 and EL84, though with different heater voltages. In the original radio the UCC85 was probably used as an RF amplifier/oscillator and the UL84 as audio output. The UCC85 is similar to a 12AT7 and is not a good choice for an amp of this type (not enough gain).

    A few observations regarding your schematic;

    The plate load resistor on the 2nd preamp stage is exceptionally high (1.1M Ohm) - why is this?
    The output valve is effectively triode strapped and not efficient. The screen connection needs to be powered off a node prior to the output transformer and run in pentode mode.
    You have a rectified but unsmoothed supply feeding your boost converter.
    I think your preamp would need a lower cathode resistor and plate load. Probably the cathode should be closer to 300 Ohm and plate load 22K.
    The tone stack would be too lossy - you won't have much signal to spare from the preamp.

    I would recommend that you didn't use those particular tubes and get hold of a 12AX7 & EL84. You stand a much better chance of success and have a much broader range of tried and tested circuits to base your amp on.

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 05-04-2013, 02:06 PM
  2. Replies: 0
    Last Post: 10-27-2011, 12:48 AM
  3. Replies: 1
    Last Post: 12-25-2010, 01:30 PM
  4. I need help with an amp schematic please (fuses).
    By BWitz in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 12-09-2008, 12:38 AM
  5. Sovtek rectifier usable??
    By buschfsu in forum 5 E 3
    Replies: 5
    Last Post: 10-21-2008, 03:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •