Results 1 to 3 of 3

Thread: Marshall DSL-5 and effects loop

  1. #1
    New Member
    Join Date
    Feb 2018
    Posts
    2
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0

    Marshall DSL-5 and effects loop

    Hi everyone,
    Got a new TC Hall of fame 2 reverb pedal yesterday,
    love the sound and the quality of it.

    It seems that when I connect it to my Marshall DSL-5 and effects loop it takes over
    all of the volume and EQ controls, which is pretty bad, even when the pedal is turned off,
    as long as it's connected by the cables I got no control over the AMP (Except for the Level switch on the pedal).
    Had also a pop sound when I turned the pedal on\off (even when the amp wasn't turned on),
    this was fixed by changing the pedal configuration from true bypass to buffered bypass.

    Any advise?

    0 Not allowed! Not allowed!
    Last edited by black_crow; 02-10-2018 at 04:32 PM.

  2. #2
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    30,934
    Thumbs Up/Down
    Received: 887/5
    Given: 0/0
    You are plugging the guitar into the amp front input jack, then the FX send on the amp to the effect unit IN and the effect unit OUT to the FX return on the amp?

    I am having a hard time imagining the pedal making any sound out the speaker when the amp is not powered on.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  3. #3
    New Member
    Join Date
    Feb 2018
    Posts
    2
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Quote Originally Posted by Enzo View Post
    You are plugging the guitar into the amp front input jack, then the FX send on the amp to the effect unit IN and the effect unit OUT to the FX return on the amp?

    I am having a hard time imagining the pedal making any sound out the speaker when the amp is not powered on.
    You can ignore that part since the issue resolved when I changed the pedal configuration from true bypass to buffer mode,
    the popping noise stopped while turning the pedal on/off (yes even when the amp was turned off).

    It seems that I had some wiring issues, so everything resolved successfully.

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Marshall TSL100 Effects loop question
    By BrotherJ in forum Mods & Tweaks
    Replies: 3
    Last Post: 03-12-2018, 09:28 PM
  2. Marshall 5275 ss combo: no sounds when golng thru input jack, ok thru effects loop :(
    By Led Hendriani in forum Maintenance, Troubleshooting & Repair
    Replies: 11
    Last Post: 06-10-2016, 10:29 PM
  3. Replies: 5
    Last Post: 09-24-2013, 04:14 AM
  4. Marshall Valvestate 8100 Effects Loop question
    By just dave in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 04-21-2011, 03:17 PM
  5. jcm 200 dsl 100 head blowing H.T. fuse with the effects loop.?
    By whistlingcookie in forum Maintenance, Troubleshooting & Repair
    Replies: 5
    Last Post: 10-22-2008, 10:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •