Results 1 to 3 of 3

Thread: Yamaha CS50, I seem to have power, but no magic!

  1. #1
    Senior Member Sowhat's Avatar
    Join Date
    Mar 2010
    Location
    San Diego California
    Posts
    415
    Thumbs Up/Down
    Received: 7/0
    Given: 2/0

    Yamaha CS50, I seem to have power, but no magic!

    Iíve got a Yamaha CS50 in the shop with the complaint that it donít workÖ that gives me a lot to go on.

    What it does is basically nothing. Flip the power switch and the pilot light in it comes on for about 2 seconds and then extinguishes. Thereís no noticeable current draw and no blown fuses.

    I removed the power supply and put it up on the bench. I jumped out the power switch connections and jumped the +-15 volt sense lines to +-15 volts and powered it up on a variac. Everything looks good there, voltages were a little off but they adjusted easily. I got +15, -15, +8.5 and +6.5 volts coming out of the power supply, steady and no problem.

    One of those good old troubleshooting charts sure would come in handy here but I donít see one around, I have the service manual but itís a confused mass of circuitry with a lot of errorsÖ 25 pages or so, and in half of it in Japanese!

    Anyone got a clue with this, maybe some experience with failures like this?

    Here's a link to the service manual I've been able to find...

    Yamaha Corporation - CS-50 - Service Manual

    0 Not allowed! Not allowed!
    ... That's $1.00 for the chalk mark and $49,999.00 for knowing where to put it!

  2. #2
    Senior Member Sowhat's Avatar
    Join Date
    Mar 2010
    Location
    San Diego California
    Posts
    415
    Thumbs Up/Down
    Received: 7/0
    Given: 2/0
    I have a little follow on with this. There's also 10 volts used and that regulator is not in the power supply but on board R71 instead, that regulator was not working due to an open 5.6 volt zener diode, I replace that and got the 10 volts back. Still, nothing on the output. I checked around the SUB (sub oscillator) board and the VCO's check out good and output waves in all the variations just fine. I also injected the PRE (preamp) board and the output preamplifier, headphone driver separately and through the ring modulator circuit on the board and everything checks out good.

    Click image for larger version. 

Name:	cs50_bench.jpg 
Views:	28 
Size:	225.7 KB 
ID:	47460

    My problem is that there are so many VCO's and VCA's in this system I loose track of the signal path when tracing things through, that plus, I don't really understand how this thing works at the component level, and at the users level as well. This coupled with proprietary Yamaha chips, especially the keyboard decoder and polyphonic processor all over the thing makes the going a bit tough.

    Really guys? none of you have any words or wisdom, ridicule or even pity?

    0 Not allowed! Not allowed!
    ... That's $1.00 for the chalk mark and $49,999.00 for knowing where to put it!

  3. #3
    Senior Member Sowhat's Avatar
    Join Date
    Mar 2010
    Location
    San Diego California
    Posts
    415
    Thumbs Up/Down
    Received: 7/0
    Given: 2/0
    This saga continues... I finally got around to the digital control section of the unit and lo and behold, there was no clock! ... well, there's a problem. I replaced U6, a 4069 hex inverter which comprises the main clock for the digital processors and I finally got a clock, not the best looking clock but a clock none the less.

    Click image for larger version. 

Name:	IMG_0273.JPG 
Views:	14 
Size:	939.6 KB 
ID:	47566

    I can now faintly hear the synthesizer in the headphones and it's capable of 4 channel polyphony, all the controls seem to work, so my job is not yet done but well on the way. I'm going to shotgun replace all the 4000 series CMOS chips... there's 5 of them on the KAS board. I have heard that these chips do not stand the test of time, at least so far the clock inverters didn't.

    0 Not allowed! Not allowed!
    ... That's $1.00 for the chalk mark and $49,999.00 for knowing where to put it!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha EMX512SC power supply
    By Jeff907 in forum Music Electronics
    Replies: 1
    Last Post: 11-28-2017, 11:39 PM
  2. Yamaha EMX5000 no power
    By dosmun in forum Music Electronics
    Replies: 14
    Last Post: 11-03-2016, 04:29 PM
  3. Yamaha DG60 power transformer help
    By JerryP in forum Maintenance, Troubleshooting & Repair
    Replies: 8
    Last Post: 05-03-2016, 03:26 PM
  4. Yamaha DG Stomp won't power up
    By richmondscribe in forum Guitar Effects
    Replies: 1
    Last Post: 08-14-2014, 03:27 PM
  5. Need schematic for a Yamaha P2050 power amp
    By Twist in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 01-15-2008, 01:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •