Results 1 to 9 of 9

Thread: Need help with Pevey vt series 240T amp trouble shooting

  1. #1
    New Member
    Join Date
    Aug 2018
    Location
    Md
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 1/0

    Question Need help with Pevey vt series 240T amp trouble shooting

    I have a Pevey vt series 240T amp that the effects channel went out. Only the clean input works but it is clean, clear and loud. The reverb is supposed to work on the clean channel and it also does not work. I am not sure about the phase circuit, but it also does nothing. The channel lights on the front change with the foot switch like they should but the mix or the two effects inputs are quiet. The tubes have been changed, but I think this is in the preamp circuit.
    HELP...
    Les

    None of my reply's have shown up, waiting for review by monitor. the auto mix works only the clean side in both clean and combined. No effects at all on clean and no sound on effects channel. How do I ger reply's approved ???


    https://www.thetubestore.com/lib/the...-Schematic.pdf

    0 Not allowed! Not allowed!
    Last edited by drummer125; 08-21-2018 at 10:33 PM. Reason: Change of info. not able to reply

  2. #2
    Supporting Member The Dude's Avatar
    Join Date
    May 2010
    Location
    Sioux Falls, SD
    Posts
    5,300
    Thumbs Up/Down
    Received: 254/0
    Given: 217/0
    Welcome to the place!

    You'll get a quicker response if you post a schematic or schematic link.

    0 Not allowed! Not allowed!
    “Yeah, well, you know, that’s just, like, your opinion, man.”

  3. #3
    Old Timer nosaj's Avatar
    Join Date
    Sep 2011
    Location
    Pace, FL
    Posts
    1,869
    Thumbs Up/Down
    Received: 245/20
    Given: 25/5
    Quote Originally Posted by drummer125 View Post
    I have a Pevey vt series 240T amp that the effects channel went out. Only the clean input works but it is clean, clear and loud. The reverb is supposed to work on the clean channel and it also does not work. I am not sure about the phase circuit, but it also does nothing. The channel lights on the front change with the foot switch like they should but the mix or the two effects inputs are quiet. The tubes have been changed, but I think this is in the preamp circuit.
    HELP...
    Les
    What if you plug your guitar into the automix jack do the effects work now?

    nosaj

    schematic
    https://www.thetubestore.com/lib/the...-Schematic.pdf

    2 Not allowed! Not allowed!
    Binkie McFartnuggets‏:If we really wanted to know the meaning of life we would have fed Stephen Hawking shrooms a long time ago.

  4. #4
    New Member
    Join Date
    Aug 2018
    Location
    Md
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 1/0
    No. I tried all 4 inputs and the clean is the only one that works. I now have 5 Deuce schematics and I am not sure which is right.

    0 Not allowed! Not allowed!

  5. #5
    New Member
    Join Date
    Aug 2018
    Location
    Md
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 1/0
    I was wrong ! Automix works on clean side and clean side plays on the combined, but no reverb or phase. Switch to effects and no sound. Now if monitor will post this, I tried to respond last night but it had to be approved before posting. I hope It is approved today...

    Says Deuce VT series on front and 240T on back. Thank you for responding. Monitor must review again. Amp is not apart yet...

    0 Not allowed! Not allowed!
    Last edited by drummer125; 08-22-2018 at 01:44 AM. Reason: Change of info. not able to reply

  6. #6
    Old Timer nosaj's Avatar
    Join Date
    Sep 2011
    Location
    Pace, FL
    Posts
    1,869
    Thumbs Up/Down
    Received: 245/20
    Given: 25/5
    Quote Originally Posted by drummer125 View Post
    No. I tried all 4 inputs and the clean is the only one that works. I now have 5 Deuce schematics and I am not sure which is right.
    Look at the pc boards you should see a number on one of them.

    Nosaj

    0 Not allowed! Not allowed!
    Binkie McFartnuggets‏:If we really wanted to know the meaning of life we would have fed Stephen Hawking shrooms a long time ago.

  7. #7
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    30,614
    Thumbs Up/Down
    Received: 545/1
    Given: 0/0
    You didn't specify at first, but you have a Deuce VT, right? I don't know from five schematics, but Mace/Deuce without the VT are the early ones, series A and series B. Neither of those is the VT, so discount any non VT schematic. (Mace and Deuce are the same amp, just slight different power amp.) A Deuce II is not a Deuce VT either. Deuce II, Deuce A, and Deuce B do not have AUTOMIX inputs, so as far as I know there is only one Deuce VT schematic.

    Get your channels going right, then worry about reverb and phase later.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  8. #8
    New Member
    Join Date
    Aug 2018
    Location
    Md
    Posts
    4
    Thumbs Up/Down
    Received: 0/0
    Given: 1/0
    Amp has Deuce VT series on front and 240T on back. It is not apart yet but soon.

    0 Not allowed! Not allowed!

  9. #9
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    12,346
    Thumbs Up/Down
    Received: 100/0
    Given: 30/0
    Here is the VT schematic: peavey-mace-deuce-vt.zip

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stereo guitar amp trouble shooting
    By Magic Potion in forum Debugging Your Build
    Replies: 23
    Last Post: 04-23-2018, 09:19 AM
  2. Need help trouble shooting MOD 102 amp kit.
    By smallpoxchampion in forum Maintenance, Troubleshooting & Repair
    Replies: 10
    Last Post: 10-29-2014, 05:21 PM
  3. Need help trouble shooting peavey xl-500 mix amp
    By captainlee in forum Maintenance, Troubleshooting & Repair
    Replies: 66
    Last Post: 02-09-2012, 06:05 PM
  4. Need help trouble shooting peavey Mark III amp
    By vjw757 in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 05-10-2011, 04:41 PM
  5. Trouble shooting
    By überfuzz in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 04-03-2010, 11:59 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •