Results 1 to 11 of 11

Thread: Marshall DSL 100HR schematic needed and comment appreciated

  1. #1
    Member fredcapo's Avatar
    Join Date
    Mar 2013
    Location
    NJ
    Posts
    254
    Thumbs Up/Down
    Received: 3/0
    Given: 0/0

    Marshall DSL 100HR schematic needed and comment appreciated

    Hi. Looking at a newer Marshall DSL 100HR. Came in with FS2 and FS3 blown. 1 of 4 EL34 tested shorted and was discolored along with its mate. Noticed that the charge on FS2 was/is not bleeding off...got a nice spark on my discharge probe. I replaced the tube and jumpered in new sacrificial fuses and the amp sounded great for 20 minutes, though still not bleeding off the charge. Power cycled a few times now getting fat humm on power up and blowing fuses again. Bad electrolytic? Amp only 2 year old.

    Can someone please post schematic for dsl 100hr. Thanks.

    0 Not allowed! Not allowed!

  2. #2
    Stray Cap DrGonz78's Avatar
    Join Date
    Oct 2011
    Location
    Scottsdale, AZ
    Posts
    1,845
    Blog Entries
    1
    Thumbs Up/Down
    Received: 134/6
    Given: 90/0
    Do the circuit boards have DSL 100-60-02 printed on them??

    0 Not allowed! Not allowed!
    When the going gets weird... The weird turn pro!

  3. #3
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    12,458
    Thumbs Up/Down
    Received: 184/2
    Given: 88/0
    That is a pretty new amp.

    Not too sure if the schematic is even out there yet.

    1 Not allowed! Not allowed!

  4. #4
    Member fredcapo's Avatar
    Join Date
    Mar 2013
    Location
    NJ
    Posts
    254
    Thumbs Up/Down
    Received: 3/0
    Given: 0/0
    I got the schematic from our marshall rep. D10 of the f2 plate bridge circuit was a dead short when measured yesterday. Funny thing was when the amp came it had f2 blown. at that time I replaced f2 and a shorted el34 (not of that circiut i later learned) and the amp worked fine for a spell. Then f2 blew again. Replaced D10 and now seems fine. Question is, can these 1n4007s go intermittent for a while? Should i suspect the other diodes? Thanks.

    0 Not allowed! Not allowed!

  5. #5
    Member
    Join Date
    Jun 2006
    Posts
    80
    Thumbs Up/Down
    Received: 3/0
    Given: 0/0
    This may be it ??
    John


    dsl100.pdf

    1 Not allowed! Not allowed!

  6. #6
    "Thermionic Apocalypse" -JT nickb's Avatar
    Join Date
    Dec 2009
    Location
    Devon, UK
    Posts
    3,018
    Thumbs Up/Down
    Received: 291/1
    Given: 279/1
    Quote Originally Posted by fredcapo View Post
    I got the schematic from our marshall rep. D10 of the f2 plate bridge circuit was a dead short when measured yesterday. Funny thing was when the amp came it had f2 blown. at that time I replaced f2 and a shorted el34 (not of that circiut i later learned) and the amp worked fine for a spell. Then f2 blew again. Replaced D10 and now seems fine. Question is, can these 1n4007s go intermittent for a while? Should i suspect the other diodes? Thanks.
    So are you going to keep it to yourself?

    2 Not allowed! Not allowed!
    Experience is something you get, just after you really needed it.

  7. #7
    Member fredcapo's Avatar
    Join Date
    Mar 2013
    Location
    NJ
    Posts
    254
    Thumbs Up/Down
    Received: 3/0
    Given: 0/0
    The kid handling the call with u.s. music just handed me 3 pages. I will ask him if he saved the pdfs and if so will post.

    The schematic John above posted is an earlier version (looks like 2011). I did not check for similarity.

    2 Not allowed! Not allowed!

  8. #8
    Senior Member nevetslab's Avatar
    Join Date
    Apr 2010
    Location
    Burbank, CA
    Posts
    1,058
    Thumbs Up/Down
    Received: 236/1
    Given: 566/1
    I didn't see a D10 on John's schematic. FS2, being a fuse leading to the bias network....that's the first time I've seen a fuse in the bias circuit. If that fuse blows, there's no negative bias on the tubes, and they'd conduct like crazy, red-plating. I'd assume that would cause FS1 to blow as well. As there's so little current flowing in the bias network, I'd suspect the first filter cap following the rectifier (D8 on this schematic).

    Also the first Marshall schematic I've seen where you can see all of the circuits without having to make a connector list to piece all the individual pages together to follow it.

    1 Not allowed! Not allowed!
    Logic is an organized way of going wrong with confidence

  9. #9
    Member fredcapo's Avatar
    Join Date
    Mar 2013
    Location
    NJ
    Posts
    254
    Thumbs Up/Down
    Received: 3/0
    Given: 0/0
    FS2 in the DSL100HR is one of the plate circuits. Actually i could not find all of the connection endpoints to match.

    0 Not allowed! Not allowed!

  10. #10
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    12,458
    Thumbs Up/Down
    Received: 184/2
    Given: 88/0
    Can you please post the schematic so we can all be on the same page.

    If you agreed to not post it, copy the page in question & post just that.

    0 Not allowed! Not allowed!

  11. #11
    Member fredcapo's Avatar
    Join Date
    Mar 2013
    Location
    NJ
    Posts
    254
    Thumbs Up/Down
    Received: 3/0
    Given: 0/0
    Sorry but I only work on several amps per month so I dont go into my shop every day...away a few days now but will be back next week and will see if the pdf is on the shop pc somewhere...else will scan it in.

    1 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Marshall DSL40CR schematic needed
    By xtian in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 06-13-2018, 10:16 PM
  2. Marshall DSL 40C schematic needed
    By Tone Meister in forum Schematic Requests
    Replies: 7
    Last Post: 01-06-2017, 11:11 PM
  3. Weird fault in Marshall 100V model 8100. Advice appreciated!
    By allante666 in forum Maintenance, Troubleshooting & Repair
    Replies: 24
    Last Post: 07-04-2016, 04:09 PM
  4. Marshall AVT150X schematic needed!!
    By diydidi in forum Schematic Requests
    Replies: 1
    Last Post: 02-04-2015, 03:34 PM
  5. Marshall MB150 Schematic needed.
    By Drewline in forum Schematic Requests
    Replies: 0
    Last Post: 10-20-2014, 11:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •