Results 1 to 3 of 3

Thread: Peavey PV i2 problem

  1. #1
    Twobie
    Join Date
    Jan 2019
    Posts
    2
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    Peavey PV i2 problem

    I cant seem to get any sound/noise/ reaction at all out of my Peaveyt PCi2 mic. I checked all the wiring and the solder points are connected - there does not seem to be any damage to it etc - any sugestions? I have Shure 58's to use but I like (d) the way it sounded and would really like to see if I could get it to work

    0 Not allowed! Not allowed!

  2. #2
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    31,483
    Thumbs Up/Down
    Received: 1,383/7
    Given: 0/0
    Rep Power
    53
    Here is some old guy advice:

    Never love anything that can't love you back.

    I love my Shure SM58s and 57s. And the PV mic is probably a nice mic too. But Musician Friend sells them for $45 and zero shipping. And I could certainly never repair them for that low a price. If it isn't something immediately apparent, it sounds like time for a new one.

    1 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  3. #3
    Twobie
    Join Date
    Jan 2019
    Posts
    2
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    thanks Enzo!

    your right - not worth the effort and time for what I already have put in ....




    Quote Originally Posted by Enzo View Post
    Here is some old guy advice:

    Never love anything that can't love you back.

    I love my Shure SM58s and 57s. And the PV mic is probably a nice mic too. But Musician Friend sells them for $45 and zero shipping. And I could certainly never repair them for that low a price. If it isn't something immediately apparent, it sounds like time for a new one.

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with a Peavey
    By Peaveyman16 in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 05-08-2014, 01:51 AM
  2. Peavey JSX problem
    By wcb2 in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 01-16-2014, 03:32 AM
  3. Peavey TNT 150 Hum Problem
    By Billy Penn in forum Maintenance, Troubleshooting & Repair
    Replies: 15
    Last Post: 12-21-2013, 09:04 PM
  4. peavey 400 problem
    By Eddy lonergan in forum Maintenance, Troubleshooting & Repair
    Replies: 10
    Last Post: 08-23-2011, 12:16 PM
  5. Peavey problem
    By Noah Pearly in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 01-19-2008, 06:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •