Results 1 to 6 of 6

Thread: Crate BX50 DLX

  1. #1
    Old Timer
    Join Date
    Jun 2007
    Location
    Pensacola, FL
    Posts
    3,576
    Blog Entries
    1
    Thumbs Up/Down
    Received: 10/0
    Given: 5/0
    Rep Power
    16

    Crate BX50 DLX

    This came in with a blown TDA output chip. Replaced it and now it's working, however it has a gated/farty distortion thing going on. It's even worse on the lead channel. So it's common to both channels.

    High v rails are +/- 21v
    Low v rails are:
    -14.9v
    +13.8v

    So clearly a low v supply issue, or a bad op-amp. None of the opamps seem to be getting hot. I can't find any obviously bad components in-circuit in the low v power supply. At this point I was going to replace the filters and 15v zeners and see what happens. Anyone have any ideas aside from this approach?
    Attached Files Attached Files

    0 Not allowed! Not allowed!

  2. #2
    "Thermionic Apocalypse" -JT nickb's Avatar
    Join Date
    Dec 2009
    Location
    Devon, UK
    Posts
    3,633
    Thumbs Up/Down
    Received: 821/1
    Given: 633/1
    Rep Power
    14
    I doubt the voltage is low enough to be the cause. Measure the drop across the 220 and 100 ohms resistors on the -ve supply. The current thru the 220 should be > than that thru the 100 for the zener to be doing anything. If they are the same then something is drawing too much current or the design was poor and / or line voltage is too low.

    Have you checked the speaker? If that is OK put a sine wave in and scope it until you find the issue.

    0 Not allowed! Not allowed!
    Last edited by nickb; 02-25-2019 at 08:30 PM.
    Experience is something you get, just after you really needed it.

  3. #3
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    32,751
    Thumbs Up/Down
    Received: 2,163/7
    Given: 0/0
    Rep Power
    55
    The low voltage supplies won't cause drastic effect if they are off a volt.

    This affects both channels? Good, just solve for the clean channel, that eliminates a whole bunch of circuits.

    Go down the rows of op amps, and check pins 1 and 7 for unwanted DC offset.

    Apply a signal, then follow it through teh signal path. Where does it turn sour? Look at TP1,2,6,7.

    And yes, try a different speaker. Your burnt up TDA chip could have damaged teh speaker.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

  4. #4
    Old Timer
    Join Date
    Jun 2007
    Location
    Pensacola, FL
    Posts
    3,576
    Blog Entries
    1
    Thumbs Up/Down
    Received: 10/0
    Given: 5/0
    Rep Power
    16
    Thanks guys... I'll skip replacing all those components then for now. I already checked opamps for DC offset.

    Not a speaker issue... forgot to say I tried others

    0 Not allowed! Not allowed!

  5. #5
    Old Timer J M Fahey's Avatar
    Join Date
    Oct 2007
    Location
    Buenos Aires, Argentina
    Posts
    11,753
    Thumbs Up/Down
    Received: 1,884/23
    Given: 1,463/35
    Rep Power
    27
    Ok, then itīs scope time.

    0 Not allowed! Not allowed!
    Juan Manuel Fahey

  6. #6
    Lifetime Member Enzo's Avatar
    Join Date
    May 2006
    Location
    Lansing, Michigan, USA
    Posts
    32,751
    Thumbs Up/Down
    Received: 2,163/7
    Given: 0/0
    Rep Power
    55
    A scope, or put together a signal tracer using some other small amp.


    I am surprised more folks don't use signal tracers. Back in the 1950-60s every shop had a signal tracer. It is like a scope for your ears.

    0 Not allowed! Not allowed!
    Education is what you're left with after you have forgotten what you have learned.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Crate BX50 noise
    By sunshine_bassman in forum Maintenance, Troubleshooting & Repair
    Replies: 22
    Last Post: 12-19-2018, 03:27 AM
  2. Crate GXT-100 PT
    By andyjazz in forum Maintenance, Troubleshooting & Repair
    Replies: 7
    Last Post: 04-23-2017, 05:45 AM
  3. Replies: 6
    Last Post: 03-18-2015, 02:01 AM
  4. Crate KXB-60
    By StratosaurusTX in forum Maintenance, Troubleshooting & Repair
    Replies: 1
    Last Post: 07-27-2012, 02:34 PM
  5. Crate amp hum
    By monsteranus in forum Music Electronics
    Replies: 7
    Last Post: 03-11-2011, 04:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •