Results 1 to 16 of 16

Thread: Univox U-1220 w/ 1221 pickyback amp & 1005 2x12 cab

  1. #1
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0

    Univox U-1220 w/ 1221 pickyback amp & 1005 2x12 cab

    I put the Astro Amp aside for a while after a major setback and started looking at my latest acquisition. It's a tube amp with a schematic! That's what I like!

    I picked this up for $240 a few weeks ago. It seemed like a small price for a tube amp with a speaker cabinet. I know Univox doesn't have the demand or appeal of a fender amp, but I'm always curious to compare the tonal differences and build quality of these lesser known amps to the fender. This amp was used by a pro musician for many years so I'm told. Upon inspection, there were no hums or buzzes, just a nice clean tone. Volume was weak for 50 watts, and reverb and tremolo not working. I was told the chassis was all original but the speakers likely not.

    I brought it home and let my son try it out. He plays jazz and really likes the tone. Now it's time to get it back into good working order. Here's a pic. Sorry it's not a closeup. I forgot to get a shot before I took it apart. If you zoom in, it's on the back wall between the keyboard and drums.

    Click image for larger version. 

Name:	0316190956[1].jpg 
Views:	98 
Size:	1.90 MB 
ID:	53015

    0 Not allowed! Not allowed!

  2. #2
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    According to vintageunivox.com the 1005 cab originally came with two 12" Eminence special design speakers. The cabinet has a rating of 16 ohms, but the speakers combined measure 8 ohms. When I pulled the cabinet apart, I found two Kustom 12" speakers. I didn't find any info from the markings on the speaker, so I know nothing about them other than they seem to sound good.

    Click image for larger version. 

Name:	0302191508[2].jpg 
Views:	57 
Size:	2.28 MB 
ID:	53016 Click image for larger version. 

Name:	0302191508b[1].jpg 
Views:	50 
Size:	2.55 MB 
ID:	53017 Click image for larger version. 

Name:	0302191526[1].jpg 
Views:	59 
Size:	2.40 MB 
ID:	53018 Click image for larger version. 

Name:	0302191509[1].jpg 
Views:	52 
Size:	1.95 MB 
ID:	53019

    0 Not allowed! Not allowed!

  3. #3
    Supporting Member TomCarlos's Avatar
    Join Date
    Oct 2009
    Location
    Roseville, Ca.
    Posts
    756
    Thumbs Up/Down
    Received: 120/0
    Given: 230/0
    Rep Power
    11
    Someone swapped the speakers and hooked up as 8 ohms to use with a different head? That is always a possibility. So right now, you have two speakers in parallel measuring 8 ohms or do you have two 4 ohm speakers in series?

    0 Not allowed! Not allowed!

  4. #4
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    The Univox chassis in on the bench. I didn't expect such a solidly made chassis. Seems on par with a fender. There's a cover on the bottom which keeps it totally enclosed. Remove the cover to reveal the components inside. This one is clean inside and does look all original. It has a pcb. When you remove two covers from the top side it reveals the bottom of the pcb. That should make servicing easy!

    Click image for larger version. 

Name:	0320191845_HDR[1].jpg 
Views:	69 
Size:	2.21 MB 
ID:	53020 Click image for larger version. 

Name:	0320191848[1].jpg 
Views:	64 
Size:	2.31 MB 
ID:	53021 Click image for larger version. 

Name:	0320191847_HDR[1].jpg 
Views:	59 
Size:	1.67 MB 
ID:	53022 Click image for larger version. 

Name:	0320191912[1].jpg 
Views:	53 
Size:	2.50 MB 
ID:	53023

    0 Not allowed! Not allowed!

  5. #5
    Supporting Member TomCarlos's Avatar
    Join Date
    Oct 2009
    Location
    Roseville, Ca.
    Posts
    756
    Thumbs Up/Down
    Received: 120/0
    Given: 230/0
    Rep Power
    11
    The amp looks very clean. I found a pic on the web and the schematic.

    Here is a page with info on the Univox amps - http://www.vintageunivox.com/amps/uniamp.html

    Looks like you picked up a nice amp!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1220 Head and Cab.jpg 
Views:	38 
Size:	23.0 KB 
ID:	53025  
    Attached Files Attached Files

    1 Not allowed! Not allowed!
    Last edited by TomCarlos; 03-21-2019 at 05:10 PM.

  6. #6
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    Quote Originally Posted by TomCarlos View Post
    Someone swapped the speakers and hooked up as 8 ohms to use with a different head? That is always a possibility. So right now, you have two speakers in parallel measuring 8 ohms or do you have two 4 ohm speakers in series?
    I'm pretty sure it's two 16 ohms speakers in parallel. The amp and cabinet remained together. It appears there is a 16 and 8 ohm tap on the OT. I'll have to checked to see if that was changed to 8 ohm as well. I prefer an 8 ohm cabinet for versatility.

    0 Not allowed! Not allowed!

  7. #7
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    I replaced all the electrolitic capacitors. There were a lot. They didnt look bad and I wasn't getting any hum, but I didn't want to diagnose the amp with 40 plus years old caps. I was concerned that my work might introduce more problems. My concerns seemed realized when after replacing all the caps, I powered the amp and I got no output. With a little more time I found a bad solder connection and repaired. I also found a fried power filter resistor and replaced, added 3 prong power cord and switched to the 8 ohm tap on the OT. To my relief the amp now seems in good working order. Tremelo and reverb are now working too! Here are pics with new caps.

    Click image for larger version. 

Name:	0331191716_HDR.jpg 
Views:	46 
Size:	2.29 MB 
ID:	53192 Click image for larger version. 

Name:	0331191716a.jpg 
Views:	63 
Size:	2.24 MB 
ID:	53193

    3 Not allowed! Not allowed!
    Last edited by tigerzilly; 04-01-2019 at 05:29 PM.

  8. #8
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0

    Still some issues

    Close, but not there yet. I still have some issues I need to work through. With the amp reassembled I did some testing, and I'm hearing a faint 60 cycle hum. I need to lift the ground that I installed and see if it goes away. There was no hum before the cap replacement.

    I'm still sorting out the footswitches for the reverb and tremolo. I picked up a dual footswitch, but when I went to switch out the two RCA connectors with 1/4", I discovered only one conductor going to one of the plugs. That's not working here.

    Lastly I'm getting a pop when I switch off the power. I don't recall that before either, put I'm thinking arcing in the switch.

    1 Not allowed! Not allowed!

  9. #9
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    Click image for larger version. 

Name:	1022191102.jpg 
Views:	26 
Size:	1.84 MB 
ID:	55685

    There is hope for the Univox U-1220!

    0 Not allowed! Not allowed!

  10. #10
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    I've been working on the Univox U-1220 on and off for a while now. I replaced all the electrolytic and oil filled caps, but it wasn't right. There was always sum hum or offending noise. Then I replaced a number of tube sockets and the power switch. I think I finally have it. A buddy of mine played through it last week and it smoked. And that was after hearing him play through his 68 vibrolux reverb and my 64 Deluxe Reverb. I told him it was 50 watts and he though it was more. Now I need to find some new speakers for the 1005 cab. It has Kustom speakers in now, but the are buzzing. This amp will never be worth much, but after I'm done, its gonna be a winner for playing through.

    1 Not allowed! Not allowed!

  11. #11
    Supporting Member TomCarlos's Avatar
    Join Date
    Oct 2009
    Location
    Roseville, Ca.
    Posts
    756
    Thumbs Up/Down
    Received: 120/0
    Given: 230/0
    Rep Power
    11
    Tiger.... when you said "smoked" ... I was thinking Mushroom Cloud !!! Glad that "smoked" means "it sounded great" !!!!

    5 Not allowed! Not allowed!

  12. #12
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    So I installed two Jensen MOD12 70 speakers in the 1005 cab. I couldn't justify expensive speakers and I didn't see any bad reviews for the Jensen Mods. Initially I was still hearing some buzzing. Seemed to be coming from the reverb tank, so I tightened it down. The closed back cab vibrates quite a bit when the amp is cranked. The piggy back amp configuration can make the amp susceptible to the speaker cab vibration. Seems to be good now. It's pretty much a new amp now and with new speakers. Hopefully this project is complete.

    1 Not allowed! Not allowed!

  13. #13
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    The mighty Univox U1220. Here is a sample.
    Attached Files Attached Files

    0 Not allowed! Not allowed!

  14. #14
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    U-1220 Jazz style.

    0 Not allowed! Not allowed!

  15. #15
    Old Timer olddawg's Avatar
    Join Date
    Dec 2007
    Location
    La Jolla CA, Hanalei, Kauai
    Posts
    2,980
    Thumbs Up/Down
    Received: 292/0
    Given: 30/1
    Rep Power
    15
    You might want to replace the rubber grommets mounting the reverb tank or put a chunk of 1/2” foam under the tank rather than just tightening the mounting screws. You usually want a reverb tank “floating” and not acoustically coupled to the cabinet by hard mounted screws.

    1 Not allowed! Not allowed!

  16. #16
    Member
    Join Date
    Jan 2019
    Location
    Rhinebeck NY
    Posts
    88
    Thumbs Up/Down
    Received: 59/0
    Given: 30/0
    Rep Power
    0
    Quote Originally Posted by olddawg View Post
    You might want to replace the rubber grommets mounting the reverb tank or put a chunk of 1/2” foam under the tank rather than just tightening the mounting screws. You usually want a reverb tank “floating” and not acoustically coupled to the cabinet by hard mounted screws.
    That's a good point. Reverb seems ok now, but that will be my next move if it's not sounding right.

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Univox 1221 - tremolo circuit won't oscillate
    By tubegeek in forum Guitar Amps
    Replies: 4
    Last Post: 01-14-2012, 10:57 AM
  2. 2x12 cab.... confusion
    By shugs81 in forum Build Your Amp
    Replies: 13
    Last Post: 07-02-2010, 06:42 PM
  3. Univox model 1221
    By joenotte in forum Vintage Amps
    Replies: 1
    Last Post: 02-25-2010, 06:00 AM
  4. Univox 2x12 tall tube amp-japanese
    By Mars Amp Repair in forum Maintenance, Troubleshooting & Repair
    Replies: 7
    Last Post: 10-13-2008, 04:43 PM
  5. 2X12 Cab, need help
    By CattMallahan in forum Build Your Amp
    Replies: 1
    Last Post: 05-23-2008, 03:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •