Results 1 to 3 of 3

Thread: Laney VC30 whistling when signal wires near cap on pc board

  1. #1
    Twobie
    Join Date
    May 2019
    Posts
    5
    Thumbs Up/Down
    Received: 0/0
    Given: 4/0
    Rep Power
    0

    Laney VC30 whistling when signal wires near cap on pc board

    Hi there

    After putting on some new pots to a 1995 Laney VC30 I noticed it whistles when the pot's signal wires get close to or touch a smallish orange drop capacitor (C9), is this something I should address with layout and make sure the wires will stay away from it (it's pretty closely packed) or is it maybe a failing capacitor and I could help it by replacing? Also, nearby, C10 (which is in the signal path) is quite noisy when 'chopsticked', is this to be expected or should I order one of those while I am at it?

    It is, in general, fairly hummy (50Hz, UK) despite having the can cap and the 3 biggest filter caps replaced, does anyone know of any obvious source on this particular amp? I'll be slowly working through everything to try and track it down but thought I'd ask if there's a known particular culprit in these amps!

    Thanks in advance for any help!

    Click image for larger version. 

Name:	VC30.pdf 
Views:	8 
Size:	340.1 KB 
ID:	53640

    0 Not allowed! Not allowed!
    Last edited by OwenM; 05-17-2019 at 12:06 PM.

  2. #2
    Member
    Join Date
    Nov 2013
    Posts
    232
    Thumbs Up/Down
    Received: 65/1
    Given: 14/1
    Rep Power
    6
    caps are microphones,so yes,you need to avoid running grid wires near them,and maybe use some quality film or multilayer ceramic.
    50Hz hum is mainly heater induced or a bad grounding point or a bad tube.
    Once you rule out tubes and solderings,i suggest elevating heater center tap.

    2 Not allowed! Not allowed!

  3. #3
    Twobie
    Join Date
    May 2019
    Posts
    5
    Thumbs Up/Down
    Received: 0/0
    Given: 4/0
    Rep Power
    0
    Great info, thanks I'll dive in!

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Laney VC30 212
    By jondoe in forum Maintenance, Troubleshooting & Repair
    Replies: 5
    Last Post: 01-16-2019, 01:50 PM
  2. Laney VC30 Porblems
    By shadygreentree in forum Maintenance, Troubleshooting & Repair
    Replies: 8
    Last Post: 07-24-2015, 11:19 PM
  3. Laney VC30 112 bias problem (?)
    By MobileYankee in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 06-02-2013, 08:59 AM
  4. Laney VC30 run away bias
    By technicalxpectations in forum Guitar Amps
    Replies: 1
    Last Post: 06-23-2010, 05:36 AM
  5. Sick Laney VC30 112
    By LochNessMonster in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 05-19-2008, 12:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •