Results 1 to 7 of 7

Thread: Solid state Marshall Amp squeeling while turning pots

  1. #1
    Twobie
    Join Date
    Jul 2019
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    Solid state Marshall Amp squeeling while turning pots

    Hello dear MEFrs,
    I'm trying to keep it as short as possible:
    My Marshall MG50FX screeches when im turning any pot (except Master). Master seems to just amplify the noise. The noise is the same with every pot. White noise from amp starts 2-3 seconds after switching on. It still picks up the guitar, but not as loud as it should.
    What I've tried:
    -Checked most of the capacitors.
    -unplugged the speaker and used headphones instead-> Exactly the same result

    So, hopefully someone of you knows more than me and can give me some clues.
    I'll link an audio of the issue.
    Thanks a lot!
    Palomacy
    Audio file of screeching noise(VOL. WARNING) :
    https://drive.google.com/file/d/1SHr...w?usp=drivesdk

    0 Not allowed! Not allowed!

  2. #2
    Supporting Member
    Join Date
    May 2006
    Location
    Staffordshire UK
    Posts
    3,729
    Thumbs Up/Down
    Received: 477/1
    Given: 440/2
    Rep Power
    18
    How exactly did you check the caps? eg ESR assessment.
    Schematic file or link?
    If no schematic available then best to raise another topic in that regard in the ‘schematic request’ sub forum.

    0 Not allowed! Not allowed!

  3. #3
    Twobie
    Join Date
    Jul 2019
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Thanks for the quick answer!
    I checked all of them for exterior damage and soldered half of them out and checked them with a multimeter one by one.

    0 Not allowed! Not allowed!

  4. #4
    Supporting Member
    Join Date
    May 2006
    Location
    Staffordshire UK
    Posts
    3,729
    Thumbs Up/Down
    Received: 477/1
    Given: 440/2
    Rep Power
    18
    The parameters of ecaps that fail with age / use are ESR and leakage resistance. Unless you have checked those your testing was insufficient.

    0 Not allowed! Not allowed!

  5. #5
    Supporting Member Jazz P Bass's Avatar
    Join Date
    Dec 2008
    Location
    Wernersville, PA
    Posts
    12,885
    Thumbs Up/Down
    Received: 491/3
    Given: 260/0
    Rep Power
    26
    I am not sure if there even IS an MG50FX schematic.
    If there is, it has never surfaced.

    If the front end is anything like the MG15-30 FX, there is a bunch of DSP, atmeg microcontroller stuff going on.
    So the controls are feeding the microcontroller.

    That is what the 'FX' indicates.

    Here is the 15-30 schematic:
    MG15_30FX.pdf

    The 50FX uses a TDA7293 output ic:
    Click image for larger version. 

Name:	MG 50fx_tda board.png 
Views:	19 
Size:	112.2 KB 
ID:	54233

    0 Not allowed! Not allowed!

  6. #6
    Senior Member mozwell's Avatar
    Join Date
    Sep 2009
    Location
    Australia
    Posts
    650
    Thumbs Up/Down
    Received: 13/0
    Given: 0/0
    Rep Power
    11
    MG50DFX, not sure if this is close enough
    Attached Files Attached Files

    0 Not allowed! Not allowed!

  7. #7
    Twobie
    Join Date
    Jul 2019
    Posts
    3
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0
    Hello guys!
    I appreciate your help! Yesterday I soldered some more capacitors out for testing and found some faulty ones on the output ic board. Hope that fixes the problem. I'll take a look inside the schematic and see if it matches.
    Thanks again and I'll tell you if it worked!

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Solid state amp with OT?
    By überfuzz in forum Guitar Amps
    Replies: 18
    Last Post: 08-22-2016, 04:32 PM
  2. Marshall 2098 Solid State Lead 100 Repair
    By Billy R aka DynaFreak in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 07-04-2011, 06:27 PM
  3. Marshall 2205 Solid State Slave Head
    By Ted in forum Schematic Requests
    Replies: 6
    Last Post: 10-18-2010, 05:21 PM
  4. Solid State Marshall MG50DFX
    By Pablomago in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 07-30-2007, 04:16 PM
  5. Loud Buzz from Marshall Valvestate 65 (solid state)
    By markh99999 in forum Maintenance, Troubleshooting & Repair
    Replies: 9
    Last Post: 02-02-2007, 07:49 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •