Results 1 to 2 of 2

Thread: Echoplex EP-4 slider issue

  1. #1
    New Member
    Join Date
    Sep 2019
    Posts
    1
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    0

    Echoplex EP-4 slider issue

    Hey there everyone!

    First time posting here. Just acquired a 77 EP-4 echoplex and it sounds lovely but Iím noticing a few issues. Number one being the slide is tough to move, some spots will slide right by easily but other spots on the tracks take some serious force. Also, if the play head get too close to the record head - the fastest delay time, the tape will stop spinning. In which case I have to move it to the right a bit and then it starts again.

    The other two intermittent issues are :

    A. A squeak coming from somewhere but I canít seem to locate it.

    B. Very occasionally a loud pop happens almost as if the cable is being pulled out of an input or something.

    Anyway thanks and any help is very much appreciated. Thanks!

    0 Not allowed! Not allowed!

  2. #2
    Old Timer olddawg's Avatar
    Join Date
    Dec 2007
    Location
    La Jolla CA, Hanalei, Kauai
    Posts
    3,028
    Thumbs Up/Down
    Received: 320/0
    Given: 34/1
    Rep Power
    16
    Quote Originally Posted by Dessert guy View Post
    Hey there everyone!

    First time posting here. Just acquired a 77 EP-4 echoplex and it sounds lovely but Iím noticing a few issues. Number one being the slide is tough to move, some spots will slide right by easily but other spots on the tracks take some serious force. Also, if the play head get too close to the record head - the fastest delay time, the tape will stop spinning. In which case I have to move it to the right a bit and then it starts again.

    The other two intermittent issues are :

    A. A squeak coming from somewhere but I canít seem to locate it.

    B. Very occasionally a loud pop happens almost as if the cable is being pulled out of an input or something.

    Anyway thanks and any help is very much appreciated. Thanks!
    Replace the pinch roller and lubricate the bearing. Check the pinch roller pressure to the capstan. Check/lubricate the capstan bearing. Clean/lubricate the slider track with a little molybdenum grease. (Very little). Itís basically a tape deck. Check the tape tension. Demagnetize, etc..

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need part # mackie 406m eq slider
    By guitardad in forum Music Electronics
    Replies: 10
    Last Post: 03-18-2015, 09:08 PM
  2. EQ slider question
    By sweatyk in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 09-08-2014, 06:18 PM
  3. What do YOU do to reconstitute broken slider knobs?
    By Mark Hammer in forum Guitar Effects
    Replies: 4
    Last Post: 08-29-2012, 02:05 AM
  4. Acoustic pre-amp mini slider pots?
    By oc disorder in forum Music Electronics
    Replies: 0
    Last Post: 04-03-2012, 02:00 AM
  5. Where can I find a 10k Audio slider control for my old Carvin
    By 1ampman in forum Maintenance, Troubleshooting & Repair
    Replies: 2
    Last Post: 02-23-2011, 10:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •