Results 1 to 4 of 4

Thread: Ampeg R-12-R hum problem

  1. #1
    Member
    Join Date
    Nov 2008
    Location
    London UK
    Posts
    97
    Thumbs Up/Down
    Received: 0/0
    Given: 0/0
    Rep Power
    11

    Ampeg R-12-R hum problem

    Hello everyone

    I have been trying to restore an old Ampeg R-12-R with only partial success.

    The problem left is excessive hum. The hum is present with or without guitar connected, and regardless of the volume control position. If the vibrato is turned up, that modulates the hum. The hum disappears if I take out the phase inverter tube, but not if I take out the other preamp tubes.

    The amp has had a major refurbish. Power transformer replaced, all tubes replaced, all capacitors replaced. It's a real shame because I invested a lot of time and money into it, but the hum is still a major concern.

    I would really appreciate if someone might have a suggestion on what to check, or if there is anything specific I should try out.

    Thanks in advance

    0 Not allowed! Not allowed!

  2. #2
    Supporting Member Randall's Avatar
    Join Date
    Jan 2013
    Location
    Cape Coral, FL
    Posts
    2,357
    Thumbs Up/Down
    Received: 514/0
    Given: 92/0
    Rep Power
    9

    0 Not allowed! Not allowed!
    It's weird, because it WAS working fine.....

  3. #3
    Supporting Member
    Join Date
    Dec 2009
    Location
    UK
    Posts
    3,419
    Thumbs Up/Down
    Received: 161/0
    Given: 18/0
    Rep Power
    13
    Yes, we need the schematic so we know exactly which model we're discussing.

    0 Not allowed! Not allowed!

  4. #4
    Stray Cap DrGonz78's Avatar
    Join Date
    Oct 2011
    Location
    Scottsdale, AZ
    Posts
    2,113
    Blog Entries
    1
    Thumbs Up/Down
    Received: 316/5
    Given: 208/0
    Rep Power
    10
    Is this the same amp from a thread you had from 2017?

    https://music-electronics-forum.com/...ad.php?t=44679

    0 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ampeg SVT 4 Problem
    By Street 760 in forum Music Electronics
    Replies: 4
    Last Post: 01-31-2011, 08:41 PM
  2. Ampeg B-2RE problem
    By kevindquill in forum Maintenance, Troubleshooting & Repair
    Replies: 5
    Last Post: 10-07-2010, 07:49 AM
  3. Problem with my 81 Ampeg V3
    By deanamite in forum Guitar Amps
    Replies: 4
    Last Post: 10-06-2010, 01:44 AM
  4. Ampeg b-100 problem
    By machinegunstudios in forum Maintenance, Troubleshooting & Repair
    Replies: 4
    Last Post: 10-15-2009, 12:04 AM
  5. ampeg vt-40 vol. problem
    By billrifle in forum Vintage Amps
    Replies: 2
    Last Post: 08-11-2009, 07:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •