Results 1 to 4 of 4

Thread: KRK Rokit 8 Gen 2 (RPG2) Monitor Problem - SOLVED

  1. #1
    Member
    Join Date
    Dec 2011
    Posts
    136
    Thumbs Up/Down
    Received: 7/0
    Given: 1/0
    Rep Power
    9

    KRK Rokit 8 Gen 2 (RPG2) Monitor Problem - SOLVED

    Hello all... one of my Rokit 8 Powered Gen 2 monitors went out on me.

    Problem: No volume.

    Solution:

    Scraped off the black gunk (thanks KRK); replaced the two big PS caps (4700uf) with some generic (ie. way better than KRK put in there) caps. Also changed out the 2.2k resistors that are right next to them.

    New Problem: Very low volume

    Solution: I have no friggin idea, i tested the heck out of the preamp circuit since i was getting loud reports from the power amp section when futzing around on the preamp card. So, since KRK would not give me a schemo (thanks again, you shitsters), i opened up the working one and compared. Here's where my understanding spins out of control...

    When I tested the first opamp (JRC4580d) pin 1 and 7 i got signal on the BROKEN amp. When i tested the same pins on the working amp - NO SIGNAL!

    Then, i came here to MEF to do this post... and I guess the MEF Forum GODS smiled upon me, because the friggin thing just started working again! Totally out of the blue.

    I buttoned the broken amp back up and did a listening test. A VERY obvious difference in volume (say 2-3 db or so) and a massive improvement in the high frequencies - i mean - massive. And i only replaced those 4 parts.

    Since i ordered doubles, i'm about to do the same shotgunning to the 'working' one.

    I also ordered up all the other electrolytics, but since it ain't broke i ain't gonna fix it. If one of them goes out on me in the future, i def will.

    Wow, a month without stereo... brutal, but what a pleasure to have it back! Back to the future...

    As a postscript: I worked at Guitar Center in LA 20 yrs ago and sold a ton of their early model they had just released. The KRK rep came in and said bro, go to our factory (was around Huntington Beach or something) and get yourself a pair for half price ($150). I did. One blew on me after 10 yrs and I bought these Rokit 8's. So, i've been exclusively on KRK's for 20yrs. When I got this problem recently the customer service from them was like (I'm busy being angry at my life too much to help you and we don't do schematics). Asked for a call back from a supervisor. Nada. I explained i'm in a small town in Europe. They said 'send it to a tech'. Yeah, a 30lbs speaker sent via the mail, repair costs, shipping back. I said bro... i could buy new monitors for that. Why no schematics... is this to protect profits of authorized service centers cuzza your nasty black gunk? Nada.

    I can tell you what, next time I will buy new monitors... and they won't be KRKs. I think i'm gonna add 'customer service level' to my requirements for future purchases.

    1 Not allowed! Not allowed!

  2. #2
    Stray Cap DrGonz78's Avatar
    Join Date
    Oct 2011
    Location
    Scottsdale, AZ
    Posts
    2,173
    Blog Entries
    1
    Thumbs Up/Down
    Received: 364/5
    Given: 262/0
    Rep Power
    11
    I am pretty sure it is well known now that the black glue they used on their monitors was conductive. The EEVblog was the place I remember watching a repair video where this became apparent. There are several videos on youtube about this very issue. We just saw some black glue in another amp posted in another thread on MEF, hopefully that black goo stuff is not the same stuff.


    1 Not allowed! Not allowed!
    When the going gets weird... The weird turn pro!

  3. #3
    Member
    Join Date
    Dec 2011
    Posts
    136
    Thumbs Up/Down
    Received: 7/0
    Given: 1/0
    Rep Power
    9
    Hey Doc, yeah I've watched his vids on this more than once! It's not hard to remove it, and it is definitely a big problem. For anyone doing this repair, I'd flat out change those PS caps and resistors no matter what. Startling difference in the sound on my set.

    0 Not allowed! Not allowed!

  4. #4
    Member
    Join Date
    Dec 2011
    Posts
    136
    Thumbs Up/Down
    Received: 7/0
    Given: 1/0
    Rep Power
    9
    By the way, this little repair also took care of the noise I had heard in them for years... they are dead silent now which is just nutz.

    1 Not allowed! Not allowed!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. KRK Rokit 8 RPG2 head scratcher...
    By Emmons in forum Music Electronics
    Replies: 5
    Last Post: 01-29-2019, 05:25 PM
  2. Mesa LSS, problem apparently not solved....
    By Jared Purdy in forum Guitar Amps
    Replies: 7
    Last Post: 01-30-2011, 05:40 PM
  3. Solved Hartke 3500 shutdown problem
    By crthnsn in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 08-04-2010, 08:22 PM
  4. ****problem solved****
    By 6tring in forum Guitar Effects
    Replies: 2
    Last Post: 04-11-2010, 11:12 PM
  5. Last Gaussmeter Problem? (solved!)
    By Jeff Callahan in forum Pickup Makers
    Replies: 43
    Last Post: 01-30-2010, 07:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •