Results 1 to 6 of 6

Thread: Two failed pickups in two Epiphones this week

  1. #1
    Supporting Member Randall's Avatar
    Join Date
    Jan 2013
    Location
    Cape Coral, FL
    Posts
    2,547
    Thumbs Up/Down
    Received: 604/0
    Given: 107/0
    Rep Power
    10

    Two failed pickups in two Epiphones this week

    I currently have two Epiphone acoustics in, AJ-220SCE and AJ-200SCE with the same problem. Loud hum that I believe is the Nanoflex under saddle pickup failure, made by Shadow Electronics. One guitar also has a NanoMag magnetic pickup that also appears to be dead. If I plug in a spare mini plug into either input jack I can get noise at the 1/4" output jack, so it appears the preamp is functioning. I had already ordered a replacement NanoFlex from Shadow that is on the way, so I will be able to confirm both guitars in a few days.

    Just seems odd to have two of the same failed pickups in at the same time. Methinks this may be a product prone to failure, and only one source for replacement that I can see. I would steer clear of the Epis with Shadow pickups now.

    1 Not allowed! Not allowed!
    It's weird, because it WAS working fine.....

  2. #2
    Supporting Member Randall's Avatar
    Join Date
    Jan 2013
    Location
    Cape Coral, FL
    Posts
    2,547
    Thumbs Up/Down
    Received: 604/0
    Given: 107/0
    Rep Power
    10
    And a third one in this week, same issue.

    0 Not allowed! Not allowed!
    It's weird, because it WAS working fine.....

  3. #3
    Old Timer Leo_Gnardo's Avatar
    Join Date
    Sep 2012
    Location
    Dogpatch-on-Hudson
    Posts
    6,642
    Thumbs Up/Down
    Received: 1,617/21
    Given: 1,347/0
    Rep Power
    14
    Quote Originally Posted by Randall View Post
    I would steer clear of the Epis with Shadow pickups now.
    That, or get your Epi at a bargain price, figuring in the eventual cost of having to replace the pickup & maybe the whole p/u & preamp system.

    Hmm, a third one within a week? As Arlo said, that's a movement!

    0 Not allowed! Not allowed!
    Enjoy. Every. Sandwich.

  4. #4
    Supporting Member Randall's Avatar
    Join Date
    Jan 2013
    Location
    Cape Coral, FL
    Posts
    2,547
    Thumbs Up/Down
    Received: 604/0
    Given: 107/0
    Rep Power
    10
    And it just gets worse, the latest replacement version is fixed at a 90 degree angle with a smaller male plug. You have to drill out the hole in the guitar, which is at about a 45 degree angle, to get the new fixed arrangement installed from the top. Not so bad, except this replacement does not work. Original pickup measures 675 ohms, this new one is open. Called Traveller Guitars about it, got voice mail. Still waiting for a call back.

    0 Not allowed! Not allowed!
    It's weird, because it WAS working fine.....

  5. #5
    Supporting Member Randall's Avatar
    Join Date
    Jan 2013
    Location
    Cape Coral, FL
    Posts
    2,547
    Thumbs Up/Down
    Received: 604/0
    Given: 107/0
    Rep Power
    10
    Never did get a call back, but I did get someone from the seller, Traveler Guitars, on the line finally. Turns out what they sent doesn't work with this preamp. I still think an open reading says it's faulty, but they can have it back. The direct replacement is out of stock coming from China, and under the present world circumstances there is no real idea when they will be fulfilled.

    Not real impressed at this point.

    0 Not allowed! Not allowed!
    It's weird, because it WAS working fine.....

  6. #6
    Supporting Member The Dude's Avatar
    Join Date
    May 2010
    Location
    Sioux Falls, SD
    Posts
    6,695
    Thumbs Up/Down
    Received: 1,494/1
    Given: 1,111/1
    Rep Power
    17
    Perhaps it's a piezo pickup and it's supposed to read open?

    0 Not allowed! Not allowed!
    “Yeah, well, you know, that’s just, like, your opinion, man.”

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking for .195" Humbucker Slugs (For Epiphones)
    By ZRGuitarPickups in forum Tools and Coil Winding Gear
    Replies: 14
    Last Post: 11-07-2018, 12:54 AM
  2. Replies: 3
    Last Post: 08-13-2017, 05:47 PM
  3. Deluxe Reverb FAILED at gig
    By Steve Casas in forum Repair and Restoration
    Replies: 4
    Last Post: 01-11-2010, 08:32 PM
  4. Deluxe Reverb FAILED at gig!
    By Steve Casas in forum Maintenance, Troubleshooting & Repair
    Replies: 3
    Last Post: 12-05-2009, 11:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •