Announcement

Collapse
No announcement yet.

Peavey VTM 120 Won't Turn On

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Peavey VTM 120 Won't Turn On

    Hello everyone, my Peavey VTM120 was plugged in at my apartment in my home recording setup. It was working fine for an hour of playing. I then turned it off and when I turned it on it powered on and then the lights seemed to get brighter on it and the whole amp shut off. It will now not power on at all with no lights showing at all. What could have happened and how could I possibly go about fixing it?

  • #2
    https://www.thetubestore.com/lib/the...-Schematic.pdf

    You likely blew a fuse in the amp. There are 4 fuses and if one blew, it's for a reason. If you can tell us which, if any fuses blew, it might point us in the right direction. The most likely cause is a bad tube or tubes.
    "Yeah, well, you know, that's just, like, your opinion, man."

    Comment


    • #3
      I appreciate the schematic but I'm a bit of a novice when it comes to electronic repair. Could anyone give me a place to start looking for problems?

      Comment


      • #4
        Post edited. See above.
        "Yeah, well, you know, that's just, like, your opinion, man."

        Comment


        • #5
          You'd have to find the fuse that blew.Replace it and plug into a current limiter (light bulb in series) and check for a short.If you get a short indication on the light bulb,begin pulling the tubes one at a time til the bulb dims and locate the short.Or take it to a tech.

          Comment

          Working...
          X