Announcement

Collapse
No announcement yet.

Bassbreaker 15 combo buzz/humm that gets louder when reverb is truned up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bassbreaker 15 combo buzz/humm that gets louder when reverb is truned up

    I bought a bassbreaker 15 combo amp from guitar center used yesterday. Worked great day one, day 2, not so much.

    The amp was totally silent the first day. When I turned it on today it humms / hisses. When I turn the reverb up the hiss gets louder. After some googling I found a youtube video where guy had same problem and someone in the comments said their amp repair guy fixed it by resautering the reverb pcb joint

    What are your alls thoughts on repairing this? I seached bassbreaker on here and their was a post saying what a nightmare it was getting to the board. Does it sound reasonable that a sauter joint would cause the issue after only one day?

    I pretty much blew all my money on the amp so cant afford an expensive repair. Is sautering something like that easy? I see a couple of sautering irons for under 15 dollars. Im not sure if guitar center will allow me to return it because I bought it used but ill find out tomorrow I guess. Honesltly I would rather just fix it if thats all it is. I love (err..Loved) the sound and the line out for recording. So dont really want to get another one that might have the same issue.

    Thanks for your help,
    Cody

  • #2
    See if they will take the amp back.

    These amps where designed by an idiot.
    Impossible to work on.

    http://music-electronics-forum.com/s...ad.php?t=44184

    Comment


    • #3
      Originally posted by Jazz P Bass View Post
      See if they will take the amp back.

      These amps where designed by an idiot.
      Impossible to work on.

      http://music-electronics-forum.com/s...ad.php?t=44184
      I took it back. They gave me a 15% discount on a brand new one. That way atleast it will be under warrenty and fender can deal with it. Also brand new tubes! This must be a common problem with these amps because one of the two floor models they had did the same thing. Thanks for your help. Take care
      Cody

      Comment

      antalya escort
      pendik escort
      sex vidio
      porno
      antalya escort
      beylikduzu eskort bayan eskort bayan escort antalya sirinevler bayan escort
      gaziantep escort
      Working...
      X