Announcement

Collapse
No announcement yet.

Silvertone 1484 Restoration - almost there, but need assistance!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Alrighty

    So I have attempted to do an updated schematic in terms of how the reverb circuit looks, with some notes, to try and make it easier for anyone who wants to replace the stock reverb in the Silvertone 1484 with a transformerless tube / current driven reverb using minimal parts and minimal changes to the existing circuit. When you take a look, you can see it takes minimal changes. The cost of the new reverb tank is the biggest. Total cost of this mod is around USD$30 if you do it yourself. Other bits are simply RCA connectors, a few caps and resistors.

    So far this is what I have:

    https://www.dropbox.com/s/amj34ls9zb...%2015.jpg?dl=0

    I think I have captured everything thus far. Lines and text in red are changes or additions to the stock circuit. Keen on any input you might have. Wanting to get this right so others can relatively easily follow it.

    I have installed the 100k grid stopper resistor on the audio in - this didn’t make much difference to the reverb control dropping audio at full. Thought it might be some sort of oscillation so installed a shielded cable run for the reverb audio in and this solved the issue.

    I then put a 0.002 if across the 220k resistor and a 2.2uf/63v across the 10k resistor - and voila, the reverb works and sounds great. So mission accomplished!

    Let me know of any suggested changes to the diagram so I can finalise for use by others.

    Before I stitch it up I’ll go through and do a final voltage check - and check the bias on the tubes. Still can’t help but feel it should be louder. I have a 25w Supro that is quite a bit louder.
    Last edited by q9522678; 11-12-2019, 10:04 AM.

    Comment


    • #32
      I thought I would take a closer look at the bias for this amp before putting it all back together.

      So noting plate dissipation of 6L6 is 25w and DC plate voltage from pin 3 of power tubes is around 450v:

      25 / 450 = 0.055 x 0.7 = 0.0388

      So should be around 39ma?

      I measure 28ma using a euro tubes bias probe. So seems biased a bit too cold - which I guess could explain quieter temperament of this amp.

      From the schematic appears R60 is the bias resistor?

      Before I start playing around with this to try and get bias a little hotter, does my logic seem sound?

      Comment


      • #33
        Just a small thing to bring up is that the schematic shows 6L6GC as the tubes. What version of 6L6's are in there now. They might be rated at 30 watts and not 25 watts. I might have missed something earlier in thread but just thought to point it out.
        When the going gets weird... The weird turn pro!

        Comment


        • #34
          Actually that’s a good point.

          It presently has Ruby tubes 6L6GC, which I believe are relabelled Shuguang. I’ll have to look those up as I suspect they are closer to 30 watts. Which would put the bias even higher. Although I do intend to put the original Silvertone ones back in as they seem to be working AOK.

          Some current power tube voltages:

          V7
          Pin 3: 451v (schematic says this should be 480v)
          Pin 4: 327v
          Pin 5: -31.8v

          V8
          Pin 3: 453v (schematic says this should be 480v)
          Pin 4: 327v
          Pin 5: 31.7v
          Last edited by q9522678; 11-12-2019, 11:50 AM.

          Comment


          • #35
            Strange that plate voltage readings appear low and increasing the bias will only lower plate voltage even lower. At -31v bias supply I would expect higher bias readings from the tubes that you got from the bias probe. I am pretty sure that decreasing r60 sets the bias supply lower, thus bleeding more voltage to ground. That should get the bias hotter. Also the old tubes might bias differently than what you have in there now. You can always measure the bias of the tubes using the current shunt method too, remove the PI tube if you check it that way.
            When the going gets weird... The weird turn pro!

            Comment


            • #36
              Yeah - it is strange. If I take a reading from the voltage doubler it is also only pumping out around 450v when it should be 480v. I did replace all the old caps in here with 100uf / 450 caps. Will need to double check my work as seems odd that it’s 30v shy of where it should be.

              All of the original diodes in the doubler tested ok using the diode test on my DMM so left them in there. Could a degraded / poorly functioning diode cause this? I could always replace them with IN4007s I guess.

              Comment


              • #37
                What's on schematics doesn't always match up perfectly. Typically it's higher B+ readings since line voltages were lower back when these amps were made. Maybe there were versions of the amp that had lower B+ with certain batches of transformers than what's on the schematic. Not sure if the diodes could drag down the B+ voltage. How accurate is your bias probe?
                When the going gets weird... The weird turn pro!

                Comment


                • #38
                  They might be rated at 30 watts and not 25 watts.
                  Good point, indeed.

                  Would like to add that there is absolutely no good reason to bias a 30W 6L6 hotter than a 25W one. Bias determines idle current and idle current (not idle power dissipation!) determines performance (crossover distortion etc.) As all 6L6 and 5881 types can be expected to share more or less the same operating characteristics (otherwise they wouldn't be 6L6/5881 types) independent of limiting data, optimum idle current should be the same for all of them.

                  Major difference is that a 30W 6L6 can be used with a higher plate voltage than a 25W tube at the same idle current. But within the 25W PD limit operating conditions and electrical performance should be essentially the same.
                  - Own Opinions Only -

                  Comment


                  • #39
                    If I take a reading from the voltage doubler it is also only pumping out around 450v when it should be 480v.
                    I wouldn't worry about a difference of 6%. That's well within the daily variation of line/mains voltage. What was your mains voltage during measurements? What exactly is your heater voltage?
                    - Own Opinions Only -

                    Comment


                    • #40
                      Helmholtz

                      Heater voltage is 6.2v and wall voltage 122v.

                      I’m not too worried - just wanting to be sure it’s all operating ok before I put it back together.

                      Noting the 28ma bias - should I be reducing the value of the bias resistor to try and get it closer to 70%, maybe around 36ma?

                      Comment


                      • #41
                        As far as this internet lore of 70% of max idle dissipation, I don't follow along. Most traditional tube amps that I bias are somewhere between 40-60% max idle dissipation. I am all about tube lasting longer rather than running them hotter for a shorter life.

                        In the case of the old silvertone amp being discussed. If the amp was on my bench I would be more interested in installing adjustable bias capability, so I could easily install an array of different output tubes and bias them easily.
                        When the going gets weird... The weird turn pro!

                        Comment


                        • #42
                          You’re singing my tune.

                          I’d just ordered a 50k linear taper pot just for that purpose.

                          I’m doing some reading I am lead to believe these amps were generally biased cold from the factory. Which is why the power tubes last in them so long - and many still have the stock power tubes going strong.

                          I’m not religiously about the 70% I generally use it as a guide. I usually bias largely by ear once in the ballpark to what sounds good to me.

                          The bias pot will enable this to be done a little easier.

                          Comment


                          • #43
                            Me too, forget the 70% internet thing. Most amp makers and many techs bias amps cooler than that, there is no right and wrong. Well... So cold you get massive crossover distortion is wrong one way, and so warm the tube get red hot is wrong the other way. Between those, whatever sounds good IS good. it is just a guitar amp, nothing precision about it.
                            Education is what you're left with after you have forgotten what you have learned.

                            Comment


                            • #44
                              Heater voltage is 6.2v and wall voltage 122v.
                              Now this is just perfect.

                              Yes, 28mA cathode current looks a bit cold, meaning around 25mA real plate current. You may verify using the OT primary DCR biasing method (but pull the PI tube before measuring plate voltage to avoid oscillation).
                              - Own Opinions Only -

                              Comment


                              • #45
                                Once I receive the pot I’ll install and experiment and report back on where I settled in terms of bias.

                                In the meantime I’ll recheck the voltage doubler circuit to ensure all connections are where they should be and are solid. May consider replacing old diodes in there with IN4007s but generally don’t like replacing parts for the sake of it. Though I suppose there is the argument these are now 55 year old diodes and putting new ones now is a good opportunity and good insurance. Something to cogitate on while wait for the bias post.

                                Comment

                                Working...
                                X